summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2022-12-24 19:04:21 +0100
committerLouis Sautier <sbraz@gentoo.org>2022-12-24 19:34:36 +0100
commitc3de54a5703f1cc9977052374e9c7abcc8ccebe4 (patch)
treeef00ed7c95846bc7ad3678cec599bc22dbafc162 /app-admin/supervisor
parentsci-physics/lammps: Stabilize 20220217 amd64, #886977 (diff)
downloadgentoo-c3de54a5703f1cc9977052374e9c7abcc8ccebe4.tar.gz
gentoo-c3de54a5703f1cc9977052374e9c7abcc8ccebe4.tar.bz2
gentoo-c3de54a5703f1cc9977052374e9c7abcc8ccebe4.zip
app-admin/supervisor: add 4.2.5, Python 3.11 support
And switch to DISTUTILS_USE_PEP517. Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'app-admin/supervisor')
-rw-r--r--app-admin/supervisor/Manifest1
-rw-r--r--app-admin/supervisor/supervisor-4.2.5.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/app-admin/supervisor/Manifest b/app-admin/supervisor/Manifest
index f20cd79a3b38..635d9abb518d 100644
--- a/app-admin/supervisor/Manifest
+++ b/app-admin/supervisor/Manifest
@@ -1,2 +1,3 @@
DIST supervisor-4.2.2.tar.gz 463657 BLAKE2B 766feffcbd70b575b6b7dfd6ed98e3510e0fd9362c423b677d44a2b5dd23ded14a349a279d3d28d4fd9e04a2175c8f00e24c07df310b61d34c7f69f60d26a4ac SHA512 f787206e6c6a5d3dfc4284974a4a87cbcaeac0c705afb2b8eae53f066413bd9e68095c5309e29625e01469a4748613370e1ac0d7be84b9d72c3623244bdd2eb3
DIST supervisor-4.2.4.tar.gz 465151 BLAKE2B 91b99a64950dc874bdc008ba53ca8b1962cc34981fee27c2fd82956d73ace9eaaf91439ef6be40530c4860fe1eee193e19b51ab81050f7368aa7d31f8444c785 SHA512 38c55aeadb8664337b667aad891a3a2134ae4af88e90d636054e6be9aebc8a3ef87d79d15fcafd2b9966af562deeedc96ac3730bde9439dde30208f0a874f2d7
+DIST supervisor-4.2.5.tar.gz 466073 BLAKE2B 54b45c824a1ad2960b04ca4ca9e54337f8c4da1a13008b559103f9efb9043588e72b3ee97c41218eb9252606d717575ad2615d12136047734f83d843d0a63bfa SHA512 ea80c8c91356646deccf20735e065fd9b341f3be6d56838d333989297a912b0a59142338925b2eb08690e038f0617814e03447673701a19093aa483432ce6d41
diff --git a/app-admin/supervisor/supervisor-4.2.5.ebuild b/app-admin/supervisor/supervisor-4.2.5.ebuild
new file mode 100644
index 000000000000..de4148c5f9bd
--- /dev/null
+++ b/app-admin/supervisor/supervisor-4.2.5.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+# xml.etree.ElementTree module required.
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 systemd
+
+DESCRIPTION="A system for controlling process state under UNIX"
+HOMEPAGE="http://supervisord.org/ https://pypi.org/project/supervisor/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="repoze ZPL BSD HPND GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="acct-group/supervisor"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ newinitd "${FILESDIR}/init.d-r2" supervisord
+ newconfd "${FILESDIR}/conf.d-r1" supervisord
+ dodoc supervisor/skel/sample.conf
+ keepdir /etc/supervisord.d
+ insinto /etc
+ doins "${FILESDIR}/supervisord.conf"
+ keepdir /var/log/supervisor
+ systemd_dounit "${FILESDIR}/supervisord.service"
+}
+
+pkg_preinst() {
+ fowners :supervisor /var/log/supervisor
+ fperms 750 /var/log/supervisor
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ # This is a new installation
+ elog "You may install your configuration files in ${EROOT}/etc/supervisord.d"
+ elog "For config examples, see ${EROOT}/usr/share/doc/${PF}/sample.conf.bz2"
+ elog ""
+ elog "By default, only members of the supervisor group can run supervisorctl."
+ fi
+}