summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-05-11 23:55:30 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-05-12 00:05:21 +0200
commit7f634a1461d6f4b26f3637cd90faa67a80740d5e (patch)
tree9217f754ca0e067194507a0700ecd6029e845cd7 /app-admin/sxid/sxid-4.2-r2.ebuild
parentapp-admin/watchfolder: stable for amd64. (diff)
downloadgentoo-7f634a1461d6f4b26f3637cd90faa67a80740d5e.tar.gz
gentoo-7f634a1461d6f4b26f3637cd90faa67a80740d5e.tar.bz2
gentoo-7f634a1461d6f4b26f3637cd90faa67a80740d5e.zip
app-admin/sxid: EAPI 6 bump.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-admin/sxid/sxid-4.2-r2.ebuild')
-rw-r--r--app-admin/sxid/sxid-4.2-r2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-admin/sxid/sxid-4.2-r2.ebuild b/app-admin/sxid/sxid-4.2-r2.ebuild
new file mode 100644
index 000000000000..1dd3cef652d9
--- /dev/null
+++ b/app-admin/sxid/sxid-4.2-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="suid, sgid file and directory checking"
+HOMEPAGE="http://freshmeat.net/projects/sxid"
+SRC_URI="http://linukz.org/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="virtual/mailx"
+
+DOCS=( docs/sxid.{conf,cron}.example )
+
+src_prepare() {
+ default
+ # this is an admin application and really requires root to run correctly
+ # we need to move the binary to the sbin directory
+ sed -i s/bindir/sbindir/g source/Makefile.in || die
+ eautoreconf
+}
+
+pkg_postinst() {
+ elog
+ elog "You will need to configure sxid.conf for your system using the manpage and example"
+ elog
+}