summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-05-25 17:17:54 +0200
committerMichał Górny <mgorny@gentoo.org>2016-05-25 17:22:37 +0200
commit54c6797117fbf70034ab299c46161a7d235527e6 (patch)
tree671bd81a9b47da207ab7224e01b0eff37a1c84ec /app-admin/systemrescuecd-x86/systemrescuecd-x86-4.5.1.ebuild
parentdev-perl/Search-Xapian-1.2.22.0-r0: add alpha keyword (diff)
downloadgentoo-54c6797117fbf70034ab299c46161a7d235527e6.tar.gz
gentoo-54c6797117fbf70034ab299c46161a7d235527e6.tar.bz2
gentoo-54c6797117fbf70034ab299c46161a7d235527e6.zip
app-admin/systemrescuecd-x86: Support running isohybrid on images
Add isohybrid flag that uses isohybrid (from syslinux) to make the images dual-bootable as CD and USB media. This is the new upstream-suggested method of using SRCD on USB sticks. Since isohybrid modifies images in place and takes less than a second, it seems reasonable to run it while installing rather than expecting the user to copy it to a temporary location, convert it, then copy to the media.
Diffstat (limited to 'app-admin/systemrescuecd-x86/systemrescuecd-x86-4.5.1.ebuild')
-rw-r--r--app-admin/systemrescuecd-x86/systemrescuecd-x86-4.5.1.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/app-admin/systemrescuecd-x86/systemrescuecd-x86-4.5.1.ebuild b/app-admin/systemrescuecd-x86/systemrescuecd-x86-4.5.1.ebuild
index d7cc39e4ee14..9ac4ee7db461 100644
--- a/app-admin/systemrescuecd-x86/systemrescuecd-x86-4.5.1.ebuild
+++ b/app-admin/systemrescuecd-x86/systemrescuecd-x86-4.5.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -11,7 +11,9 @@ SRC_URI="mirror://sourceforge/systemrescuecd/sysresccd-${PN#*-}/${PV}/${P}.iso"
LICENSE="GPL-2"
SLOT="${PV}"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="+isohybrid"
+
+DEPEND="isohybrid? ( >=sys-boot/syslinux-4 )"
S=${WORKDIR}
@@ -20,6 +22,12 @@ RESTRICT="mirror"
src_install() {
insinto "/usr/share/${PN%-*}"
doins "${DISTDIR}/${P}.iso"
+
+ if use isohybrid; then
+ set -- isohybrid -u "${ED}usr/share/${PN%-*}/${P}.iso"
+ echo "${@}"
+ "${@}" || die "${*} failed"
+ fi
}
pkg_postinst() {