summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2020-04-20 11:56:41 -0500
committerWilliam Hubbs <williamh@gentoo.org>2020-04-20 12:31:24 -0500
commit1a79a29158f9eb792183183e828fe14f2c0ef1e8 (patch)
tree6e7b3acf4bdca2864b5a818f67ac0717437040a9 /app-admin/vault/vault-1.4.0.ebuild
parentdev-python/wsproto: simple bump (diff)
downloadgentoo-1a79a29158f9eb792183183e828fe14f2c0ef1e8.tar.gz
gentoo-1a79a29158f9eb792183183e828fe14f2c0ef1e8.tar.bz2
gentoo-1a79a29158f9eb792183183e828fe14f2c0ef1e8.zip
app-admin/vault: 1.4.0 bump
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-admin/vault/vault-1.4.0.ebuild')
-rw-r--r--app-admin/vault/vault-1.4.0.ebuild72
1 files changed, 72 insertions, 0 deletions
diff --git a/app-admin/vault/vault-1.4.0.ebuild b/app-admin/vault/vault-1.4.0.ebuild
new file mode 100644
index 000000000000..08f205087d1e
--- /dev/null
+++ b/app-admin/vault/vault-1.4.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit fcaps go-module systemd
+
+DESCRIPTION="A tool for managing secrets"
+HOMEPAGE="https://vaultproject.io/"
+VAULT_WEBUI_ARCHIVE="${P}-webui.tar.xz"
+SRC_URI="https://github.com/hashicorp/vault/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ webui? (
+ https://dev.gentoo.org/~williamh/dist/${VAULT_WEBUI_ARCHIVE}
+ )"
+
+LICENSE="MPL-2.0 Apache-2.0 BSD BSD-2 CC-BY-SA-4.0 ISC MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+webui"
+
+BDEPEND="dev-go/gox"
+COMMON_DEPEND="acct-group/vault
+ acct-user/vault"
+ DEPEND="${COMMON_DEPEND}"
+ RDEPEND="${COMMON_DEPEND}"
+
+FILECAPS=(
+ -m 755 'cap_ipc_lock=+ep' usr/bin/${PN}
+)
+
+RESTRICT+=" test"
+
+src_prepare() {
+ default
+ # Avoid the need to have a git checkout
+ sed -e 's:^\(GIT_COMMIT=\).*:\1:' \
+ -e 's:^\(GIT_DIRTY=\).*:\1:' \
+ -e s:\'\${GIT_COMMIT}\${GIT_DIRTY}\':: \
+ -i scripts/build.sh || die
+ sed -e "/hooks/d" \
+ -e 's|^\([[:space:]]*\)goimports .*)|\1true|' \
+ -i Makefile || die
+ if [[ -f "${WORKDIR}/http/bindata_assetfs.go" ]]; then
+ mv "${WORKDIR}/http/bindata_assetfs.go" "${S}/http" ||
+ die "mv failed"
+ fi
+}
+
+src_compile() {
+ mkdir "${T}"/bin || die
+ BUILD_TAGS="$(usex webui ui '')" \
+ GOFLAGS="-mod=vendor" \
+ GOPATH="${T}" \
+ XC_ARCH=$(go env GOARCH) \
+ XC_OS=$(go env GOOS) \
+ XC_OSARCH=$(go env GOOS)/$(go env GOARCH) \
+ emake
+}
+
+src_install() {
+ dobin bin/${PN}
+ dodoc CHANGELOG.md CONTRIBUTING.md README.md
+ insinto /etc/${PN}.d
+ doins "${FILESDIR}/"*.json.example
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/${PN}.logrotated" "${PN}"
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ keepdir /var/log/${PN}
+ fowners ${PN}:${PN} /var/log/${PN}
+}