summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-04-11 18:41:31 +0200
committerJeroen Roovers <jer@gentoo.org>2018-04-11 18:49:00 +0200
commit3ce48211fa5c618bec7a6ee314af4789abf48616 (patch)
tree6634642c99d15d565c264e99a6c776f8ad699b36 /app-admin/whowatch/whowatch-1.8.6.ebuild
parentdev-python/pbr: 4.0.2 bup (diff)
downloadgentoo-3ce48211fa5c618bec7a6ee314af4789abf48616.tar.gz
gentoo-3ce48211fa5c618bec7a6ee314af4789abf48616.tar.bz2
gentoo-3ce48211fa5c618bec7a6ee314af4789abf48616.zip
app-admin/whowatch: Version 1.8.6.
Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'app-admin/whowatch/whowatch-1.8.6.ebuild')
-rw-r--r--app-admin/whowatch/whowatch-1.8.6.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-admin/whowatch/whowatch-1.8.6.ebuild b/app-admin/whowatch/whowatch-1.8.6.ebuild
new file mode 100644
index 000000000000..b29bc3afdbcd
--- /dev/null
+++ b/app-admin/whowatch/whowatch-1.8.6.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools
+
+DESCRIPTION="Displays information about users currently logged on in real time"
+HOMEPAGE="http://wizard.ae.krakow.pl/~mike/ https://github.com/mtsuszycki/whowatch/"
+SRC_URI="https://github.com/mtsuszycki/${PN}/releases/download/${P}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~x86"
+
+RDEPEND="
+ sys-libs/ncurses:0=
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.8.4-tinfo.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ dobin src/${PN}
+ doman ${PN}.1
+ dodoc AUTHORS ChangeLog README TODO
+}