summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-09-03 11:50:35 +0200
committerMichał Górny <mgorny@gentoo.org>2022-09-03 14:04:42 +0200
commit04c0e9a4cb9fabc8d1fad5bb9240f34b4d179b11 (patch)
tree592e92f281e6ea8f49a776305f7277450885ae14 /app-admin
parentdev-python/boto3: Bump to 1.24.66 (diff)
downloadgentoo-04c0e9a4cb9fabc8d1fad5bb9240f34b4d179b11.tar.gz
gentoo-04c0e9a4cb9fabc8d1fad5bb9240f34b4d179b11.tar.bz2
gentoo-04c0e9a4cb9fabc8d1fad5bb9240f34b4d179b11.zip
app-admin/awscli: Bump to 1.25.67
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.25.67.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 21542bfe5fdb..3161ebd64c2c 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -3,3 +3,4 @@ DIST aws-cli-1.25.61.gh.tar.gz 2257977 BLAKE2B d1090ca3eb86284520e970a997932af31
DIST aws-cli-1.25.64.gh.tar.gz 2263441 BLAKE2B d68ef0a3dabba879d9d650a911d5f286116a6d407d9d958088f7b7cd54c27db3be28165a1676e949785056519477f315ca4e08f6df9938da2516974d026fef81 SHA512 4db256228dde6aed2432133373c045bf2f2e69a7764629f3d13a94e086f99b43cc2a29862e6f973742a0de08032e6c26499b230db81575eabd288c8f2f63eb0a
DIST aws-cli-1.25.65.gh.tar.gz 2263933 BLAKE2B 5c516e6a95a333073cf7200eff476e625e9b832b32b44fc41e3656c5c78710ba8272fdb5fbafcfe85fe17853c1f40e26fd6de84a6c4c42a7cd6d7d2ce41ab8f5 SHA512 7dcdd2d0e05000f09d41a24c8e14ee7b4623e89f027c193c67635296f568c8d1f383956c5c351c85b7c48150796203dce777ef2f6376c3778ea2ec8b8f39072b
DIST aws-cli-1.25.66.gh.tar.gz 2264111 BLAKE2B 7aaa42d654a873fea44fe64e0805c240700830c653ecfbfab4bf8838ba2aca5ec9508241e9fd9329b546d098eb4c68f886dac1afc31e12cea4779cc35ec091fb SHA512 dcddfebf2051fad23208c2617596c6aa4462e940056f5963526983c15b6c33bb118a769f139a8c8297d413e9a6ae129d7e14a6ffa56aa595dcde0128ea10d5c2
+DIST aws-cli-1.25.67.gh.tar.gz 2264702 BLAKE2B 88bdeab8fe85d17d7aa78ff00125e1c3e1d098093d68b7e7213896d101bff443cb2ed23b8ed9245eb3727b41abd34a8047616eee777f802d52b3a26594e214c5 SHA512 a01b333d36160a43c1f28d01600e1f1d095e4713500bac3b13fc336bf790943251fefb72dc7bc177eaf4265b794658d62ff72ee00abd348c1265d04b58564136
diff --git a/app-admin/awscli/awscli-1.25.67.ebuild b/app-admin/awscli/awscli-1.25.67.ebuild
new file mode 100644
index 000000000000..3d5bba5c1200
--- /dev/null
+++ b/app-admin/awscli/awscli-1.25.67.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+# botocore is x.(y+2).(z-1)
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(( $(ver_cut 3-) - 1 ))"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)" --forked
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}