summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-02 00:09:05 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-02 00:29:53 +0200
commit149b29ce1ecf62b0a06e0a09e32f6e35140422e3 (patch)
treeee984ce1b2700c064d81c252b2bafd7d716b1f51 /app-admin
parentdev-python/boto3: Bump to 1.17.104 (diff)
downloadgentoo-149b29ce1ecf62b0a06e0a09e32f6e35140422e3.tar.gz
gentoo-149b29ce1ecf62b0a06e0a09e32f6e35140422e3.tar.bz2
gentoo-149b29ce1ecf62b0a06e0a09e32f6e35140422e3.zip
app-admin/awscli: Bump to 1.19.104
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.19.104.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index e0afbde2c4f9..6dc6742161cd 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -1,4 +1,5 @@
DIST awscli-1.19.102.tar.gz 2023841 BLAKE2B 1960557f4dce8b1929dd98f307036e9e802ecb79ca3f74547b44598a523dddc20bfb4c917a0515d6bc896902be49c06c8c0790175fd791d0bdc0b90e6e075903 SHA512 09bbf2fe3812e035ecef35c183bcdcb9007595992bd1f87359e4fab7060631d25de686daec970e5f40fc55974185ed688efb72b29fd018cc6f6c1654b002ea4d
DIST awscli-1.19.103.tar.gz 2024444 BLAKE2B 59230fc2f6f2ed9c19b9dcef090259a07cf74cb0b8252c5db0f0c912f38293a9f2072c0b553735015c3629daa0bf835b8df00af38512f816dc4d94fe0a5fe69c SHA512 5b81d6dba8fc68c2d58dadb5d1abf274315463b948466a3675a1365ad0ffbeb354774e9a4b0e464eed4cfaf65ac091a1b9a119bebdbabbd7624b3b0f3d444771
+DIST awscli-1.19.104.tar.gz 2024567 BLAKE2B 82662ffe6a05dd329210ff84962e1ad37ece63a8f964c3c6bb293f53fea3af151bb088150260b3b279730871b7e962f2c580385b21a56a8bc2f86b437fab92d4 SHA512 444e533219e23b5151bab29d2d65deb8de9008b883b08ae553dd322b3f4e96d3836fedabc7be0393303ea146a0b8ad8220d4f4de458bca00303dc0798e543840
DIST awscli-1.19.47.tar.gz 1990843 BLAKE2B c894aaf84d5fe7cb8998fcd682783a1f2e75dd9273a2aa22babe4d57175a1716aefccda50edb96a1203f010dbb2af29cd47d43b5d5f94adfdee1730ab98345af SHA512 7d51022e13609f5f5ab3155e3ac09670c7e49508d67eca8cb477e556e4b06b7643e86bdfe5fa8db59360f6d73e5774b433cb7093c25d6b688f98847b502872b7
DIST awscli-1.19.97.tar.gz 2020143 BLAKE2B 2dac6f59a04a958b09e0f8b7d056583015762df78ed1349b55c6301d3189e1100bd8ab98445ded3ccc0ddbf1148ddf0475086704f123b0db1ccfd1cacb6b4680 SHA512 4e4e0f34ba02819232427f7571a4b10d22b167788d758c9ac43749607ea7a4c498259fcc5c69fb32d66faffc535a5b3045006168b64506f2b0f9fbbaa804e387
diff --git a/app-admin/awscli/awscli-1.19.104.ebuild b/app-admin/awscli/awscli-1.19.104.ebuild
new file mode 100644
index 000000000000..ff429f8d3a3e
--- /dev/null
+++ b/app-admin/awscli/awscli-1.19.104.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="https://pypi.org/project/awscli/"
+#SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/aws/aws-cli/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/aws-cli-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+# botocore is x.(y+1).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 1)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.4.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests --install nose
+
+PATCHES=(
+ "${FILESDIR}"/awscli-1.19.47-py39.patch
+)
+
+python_test() {
+ distutils_install_for_testing
+ # integration tests require AWS credentials and Internet access
+ nosetests -v tests/{functional,unit} ||
+ die "Tests failed for ${EPYTHON}"
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}