summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-06-03 13:03:22 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-06-03 13:03:40 -0500
commit1fc3c5c6fe7d87f8c727793f0f788cf76df8a76e (patch)
tree1771c7e0472104c7880d841b7c006a87080739e1 /app-admin
parentdev-python/bpython: Fix tests (diff)
downloadgentoo-1fc3c5c6fe7d87f8c727793f0f788cf76df8a76e.tar.gz
gentoo-1fc3c5c6fe7d87f8c727793f0f788cf76df8a76e.tar.bz2
gentoo-1fc3c5c6fe7d87f8c727793f0f788cf76df8a76e.zip
app-admin/puppet-agent: update to focal version for readline/8 support
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/puppet-agent/Manifest1
-rw-r--r--app-admin/puppet-agent/puppet-agent-6.16.0.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/app-admin/puppet-agent/Manifest b/app-admin/puppet-agent/Manifest
index 0937ffb9d1f1..ef5954d82d26 100644
--- a/app-admin/puppet-agent/Manifest
+++ b/app-admin/puppet-agent/Manifest
@@ -1,2 +1,3 @@
DIST puppet-agent_6.15.0-1stretch_amd64.deb 22581842 BLAKE2B 19c45427e56a41f6030836129a7fb2824ea47f1000745a8c74b0968c61f719d3cef9a0e02f51009b8e91c4ad66445c074ccc203754bb13d82007316a3d053c60 SHA512 4ec7e04fb6bab697bfccd369740a57f735476a4614dbfa1f7c893901f5ffb9d6ce3d79886b6e035805b1a8f2c3de3e0b9b468b08909881df6022c9700c7a2768
DIST puppet-agent_6.15.0-1stretch_i386.deb 22917002 BLAKE2B 5bab2b6cdde11a46e64996074e8db50d48d004b601c0d08ddfde9c8dec0c0f62da1176b9148d084f0250b582460606b7cd0a97291d157a186b7a97dee4184c51 SHA512 89e676491f7b7b44c9c747b129166db7b025adf76d9911d12d7d026aa8d04de293d3d1c638ca309ee8ed45a37c49b4ab0076ea0c711ac0e43f4297084446784f
+DIST puppet-agent_6.16.0-1focal_amd64.deb 22255252 BLAKE2B 64690ea444c666476864ff8d2373a266bd91f91ef996c87f04cfdd3401093795610e0e09a4f0588bbec8b83d64848c92a95572ea570fc7985d93c5e161256e00 SHA512 47ebcac58d9b54b62fa9a854ec4eb4fcc83d2fdef199658532b7b87cf461a8ac611f776db3fbb2e1c11e607896b85a67d7a32a4e9844e1b9b07904e0860c39b8
diff --git a/app-admin/puppet-agent/puppet-agent-6.16.0.ebuild b/app-admin/puppet-agent/puppet-agent-6.16.0.ebuild
new file mode 100644
index 000000000000..0b6ca4ff0251
--- /dev/null
+++ b/app-admin/puppet-agent/puppet-agent-6.16.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit eutils systemd unpacker
+
+DESCRIPTION="general puppet client utils along with hiera and facter"
+HOMEPAGE="https://puppetlabs.com/"
+SRC_URI="http://apt.puppetlabs.com/pool/focal/puppet/p/puppet-agent/puppet-agent_6.16.0-1focal_amd64.deb"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="puppetdb selinux"
+RESTRICT="strip"
+
+CDEPEND="!app-admin/puppet
+ !dev-ruby/hiera
+ !dev-ruby/facter
+ !app-emulation/virt-what
+ acct-user/puppet
+ acct-group/puppet"
+
+DEPEND="
+ ${CDEPEND}
+ app-admin/augeas"
+RDEPEND="${CDEPEND}
+ app-portage/eix
+ sys-apps/dmidecode
+ sys-libs/libselinux
+ sys-libs/glibc
+ sys-libs/readline:0/8
+ sys-libs/ncurses:0[tinfo]
+ selinux? (
+ sys-libs/libselinux[ruby]
+ sec-policy/selinux-puppet
+ )
+ puppetdb? ( >=dev-ruby/puppetdb-termini-5.0.1 )"
+
+S=${WORKDIR}
+
+src_install() {
+ # conf.d
+ doconfd etc/default/puppet
+ doconfd etc/default/pxp-agent
+ # logrotate.d
+ insinto /etc/logrotate.d
+ doins etc/logrotate.d/pxp-agent
+ # puppet itself
+ insinto /etc/puppetlabs
+ doins -r etc/puppetlabs/*
+ # logdir for systemd
+ dodir var/log/puppetlabs/puppet/
+ fperms 0750 var/log/puppetlabs/puppet/
+ # the rest
+ insinto /opt
+ dodir opt/puppetlabs/puppet/cache
+ doins -r opt/*
+ fperms 0750 /opt/puppetlabs/puppet/cache
+ # init
+ newinitd "${FILESDIR}/puppet.initd" puppet
+ systemd_dounit lib/systemd/system/puppet.service
+ systemd_dounit lib/systemd/system/pxp-agent.service
+ systemd_newtmpfilesd "${FILESDIR}/puppet-agent.conf.tmpfilesd" puppet-agent.conf
+ # symlinks
+ chmod 0755 -R "${D}/opt/puppetlabs/puppet/bin/"
+ chmod 0755 "${D}//opt/puppetlabs/puppet/lib/virt-what/virt-what-cpuid-helper"
+ dosym ../../opt/puppetlabs/bin/facter /usr/bin/facter
+ dosym ../../opt/puppetlabs/bin/hiera /usr/bin/hiera
+ dosym ../../opt/puppetlabs/bin/puppet /usr/bin/puppet
+ dosym ../../opt/puppetlabs/puppet/bin/virt-what /usr/bin/virt-what
+}