summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEspen Henriksen <dev@henriksen.is>2017-01-13 23:21:58 +0100
committerPatrice Clement <monsieurp@gentoo.org>2017-01-21 22:19:32 +0100
commit29e345642b6fb70052db4204d396745a493feb5f (patch)
tree2d8f410f7a06143264ce8dda918e56924d77c1b4 /app-admin
parentnet-analyzer/zmap: remove unused patches. (diff)
downloadgentoo-29e345642b6fb70052db4204d396745a493feb5f.tar.gz
gentoo-29e345642b6fb70052db4204d396745a493feb5f.tar.bz2
gentoo-29e345642b6fb70052db4204d396745a493feb5f.zip
app-admin/yadm: version bump to 1.06.
Package-Manager: portage-2.3.0 Closes: https://github.com/gentoo/gentoo/pull/3458
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/yadm/Manifest1
-rw-r--r--app-admin/yadm/yadm-1.06.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/app-admin/yadm/Manifest b/app-admin/yadm/Manifest
index 375081c41e66..79336e72dc3a 100644
--- a/app-admin/yadm/Manifest
+++ b/app-admin/yadm/Manifest
@@ -1,2 +1,3 @@
DIST yadm-1.04.tar.gz 27391 SHA256 a73aa51245866ce67aeb4322a62995ebbb13f29dc35508f486819dceb534968a SHA512 f3f909118f29382c6cbae565de336c27fd7d159955a231ac22b0d25e25e50c4c3e1bdc68b1629920904ad9353ee8ce8f7e5c5e50d289984447815a685a4132c9 WHIRLPOOL c74c2bfc89abb6955bb4e0d60b1cb0777c9f9ec43bc1919c130cd8470e44c090fba9003e473f4344ed92df23e399ea45ece6dafde80d575a8af491bb4c16b554
DIST yadm-1.05.tar.gz 26554 SHA256 2989b458f62cd08a65ee4f43e7ecf18f539b52d4bbb20c52b0ecff619f5e76cd SHA512 74f215957038b38e056b9d5dccb03af11066627215c16171f2fb61c0f7bcc8c042784554f549224a2ba1847a9a8dea399237c3910bc978802e8a798b51f5074f WHIRLPOOL 02e9992589b3ed0a6d4ba13ade1e54377361cb085bb7be93a750fb6f742c439febd5e18af49cfe25e6f55272cd52f013aba3ff7c929581f71b8512ed3daf7876
+DIST yadm-1.06.tar.gz 27842 SHA256 1f7bfaf4dea088e247ab35c0f571d21ef41be21a6ca66a198878c018ac756f08 SHA512 85941b233ce17fd6371a1b6b11027c65e7e0cc6a42d2674deb433e367b3666a8b7d69c0983d83b4b29797c6591c282a5a8ff890dcaff2f62ced98eb33b46a8ed WHIRLPOOL 5eb85984f77417830c88658a7bddc5d035c2c5658481901dc8fc3babe2b89d0ba4983faa8b2ea47618a461ee57722740817594844e9d8d8872b8dc8c6c3b36e8
diff --git a/app-admin/yadm/yadm-1.06.ebuild b/app-admin/yadm/yadm-1.06.ebuild
new file mode 100644
index 000000000000..05ed23470fdd
--- /dev/null
+++ b/app-admin/yadm/yadm-1.06.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="A dotfile manager for the config files in your home folder"
+HOMEPAGE="https://github.com/TheLocehiliosan/yadm/"
+SRC_URI="https://github.com/TheLocehiliosan/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DOCS=( CHANGES CONTRIBUTORS README.md )
+
+DEPEND="
+ test? (
+ dev-util/bats
+ dev-vcs/git
+ )"
+RDEPEND="dev-vcs/git
+ app-crypt/gnupg"
+
+src_compile() {
+ make yadm.md
+}
+
+src_test() {
+ # 109_accept_encryption tests are interactive, thus fail. Skip them
+ bats $(find test/ -type f -name '*.bats' -and -not -name '109_accept_encryption.bats') \
+ || die "Tests failed"
+}
+
+src_install() {
+ einstalldocs
+
+ dobin "${PN}"
+ doman "${PN}.1"
+}