summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-07-24 10:24:34 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-07-24 10:30:44 -0500
commit2a54d10569ce98ed33847543e2844e2c11ad660c (patch)
tree45c661c6c5a1444294846dc29b8fe13f3366915d /app-admin
parentapp-admin/puppet: 6.7.0 bump (diff)
downloadgentoo-2a54d10569ce98ed33847543e2844e2c11ad660c.tar.gz
gentoo-2a54d10569ce98ed33847543e2844e2c11ad660c.tar.bz2
gentoo-2a54d10569ce98ed33847543e2844e2c11ad660c.zip
app-admin/puppet-agent: 6.7.0 bump
Package-Manager: Portage-2.3.66, Repoman-2.3.16 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/puppet-agent/Manifest2
-rw-r--r--app-admin/puppet-agent/puppet-agent-6.7.0.ebuild79
2 files changed, 81 insertions, 0 deletions
diff --git a/app-admin/puppet-agent/Manifest b/app-admin/puppet-agent/Manifest
index fb1d124ddc38..129ea23dac3b 100644
--- a/app-admin/puppet-agent/Manifest
+++ b/app-admin/puppet-agent/Manifest
@@ -2,3 +2,5 @@ DIST puppet-agent_6.4.2-1stretch_amd64.deb 18776024 BLAKE2B d8fd52357abb9649d74c
DIST puppet-agent_6.4.2-1stretch_i386.deb 19250972 BLAKE2B 8424047586f7747daf24901f7ba134bfcd1fc4db094fd458f4298251880b0446221575cc463c511a32a6f7cf4c635c95b6132631640b5091e48b1e7cec67b844 SHA512 0041b1e3ff1401b21f7d9ab3b3aee66d76e30acd4748571ff3ff595d7006008e0d9d3f4c28db85cccece0cf08595cf4a3342353f5b18ea3e02ae02a094e42e41
DIST puppet-agent_6.6.0-1stretch_amd64.deb 19177382 BLAKE2B c8034e4a943394da7fd97756b3dfb59897f3d787a8f49743a4c42ed47db4411f6d0e125cf6984728a108e5070cc8e42ca0a203d2afdcce99e08ae38a6ebb9293 SHA512 f0d129b357feb6e5d05c080437910e119bbce0e97e36927c2f97d3d7fb8f54a0eb1503a74ffec3cef7fd29785fe97ffd53f04a4be6a35b558ee278af8871289b
DIST puppet-agent_6.6.0-1stretch_i386.deb 19443284 BLAKE2B c017abc3166b3cb04a98c511b5ab05dd7076906a38edd8ee919848c130ae5b1cb6c7542b6c6c3da267fa801e152ad963c84293083c709dd769185f943a4bebcb SHA512 adadc3201dae261f2000282b67b8c4735eeb588c4c6c5dcbcde2e655772bebb1c343611607d84ba1b019279480445dc44cd4e3cc3d64e89b70e93b85a37678d5
+DIST puppet-agent_6.7.0-1stretch_amd64.deb 19184896 BLAKE2B bc9f4fbd55711feb6a47c6dc41f16841bb0ec58e880071f736da0816f3f657bb2d1b6550894ed3f632ade6a937759b8dfa8a01caf782406a82852b9169d687f2 SHA512 3c88dbf585643ed8f033d589636c1fe437be9baa0891077186856d5cb34be52b0cf769842bc7d59c18f0e62348cfc83f3f3a2415381eb15e7621b124abfcf2e8
+DIST puppet-agent_6.7.0-1stretch_i386.deb 19451958 BLAKE2B 4d77e6f7ed5ffaf6e45a2c72bc47fc48ed227ea851257b50d3533ac62a2bfd4d50140f37fe28f12daa4f359ab548ccfcca0400461423943ad1a8440946557412 SHA512 04e4b98ccb94e036ec19c11c6d5cb497689c315394068c61ee9c13bf3160185402864201987805e61edaa5bc3922ec5dd8329465f802ccf8881ac602d2c98b30
diff --git a/app-admin/puppet-agent/puppet-agent-6.7.0.ebuild b/app-admin/puppet-agent/puppet-agent-6.7.0.ebuild
new file mode 100644
index 000000000000..a72df734d6b1
--- /dev/null
+++ b/app-admin/puppet-agent/puppet-agent-6.7.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit eutils systemd unpacker user
+
+DESCRIPTION="general puppet client utils along with hiera and facter"
+HOMEPAGE="https://puppetlabs.com/"
+SRC_BASE="http://apt.puppetlabs.com/pool/stretch/puppet/${PN:0:1}/${PN}/${PN}_${PV}-1stretch"
+SRC_URI="
+ amd64? ( ${SRC_BASE}_amd64.deb )
+ x86? ( ${SRC_BASE}_i386.deb )"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="puppetdb selinux"
+RESTRICT="strip"
+
+CDEPEND="!app-admin/augeas
+ !app-admin/puppet
+ !dev-ruby/hiera
+ !dev-ruby/facter
+ !app-emulation/virt-what"
+
+DEPEND="
+ ${CDEPEND}"
+RDEPEND="${CDEPEND}
+ app-portage/eix
+ sys-apps/dmidecode
+ sys-libs/glibc
+ sys-libs/readline:0/7
+ sys-libs/ncurses:0[tinfo]
+ selinux? (
+ sys-libs/libselinux[ruby]
+ sec-policy/selinux-puppet
+ )
+ puppetdb? ( >=dev-ruby/puppetdb-termini-5.0.1 )"
+
+S=${WORKDIR}
+
+pkg_setup() {
+ enewgroup puppet
+ enewuser puppet -1 -1 /var/run/puppet puppet
+}
+
+src_install() {
+ # conf.d
+ doconfd etc/default/puppet
+ doconfd etc/default/pxp-agent
+ # logrotate.d
+ insinto /etc/logrotate.d
+ doins etc/logrotate.d/pxp-agent
+ # puppet itself
+ insinto /etc/puppetlabs
+ doins -r etc/puppetlabs/*
+ # logdir for systemd
+ dodir var/log/puppetlabs/puppet/
+ fperms 0750 var/log/puppetlabs/puppet/
+ # the rest
+ insinto /opt
+ dodir opt/puppetlabs/puppet/cache
+ doins -r opt/*
+ fperms 0750 /opt/puppetlabs/puppet/cache
+ # init
+ newinitd "${FILESDIR}/puppet.initd" puppet
+ systemd_dounit lib/systemd/system/puppet.service
+ systemd_dounit lib/systemd/system/pxp-agent.service
+ systemd_newtmpfilesd "${FILESDIR}/puppet-agent.conf.tmpfilesd" puppet-agent.conf
+ # symlinks
+ chmod 0755 -R "${D}/opt/puppetlabs/puppet/bin/"
+ chmod 0755 "${D}//opt/puppetlabs/puppet/lib/virt-what/virt-what-cpuid-helper"
+ dosym ../../opt/puppetlabs/bin/facter /usr/bin/facter
+ dosym ../../opt/puppetlabs/bin/hiera /usr/bin/hiera
+ dosym ../../opt/puppetlabs/bin/puppet /usr/bin/puppet
+ dosym ../../opt/puppetlabs/puppet/bin/virt-what /usr/bin/virt-what
+ dosym ../../opt/puppetlabs/puppet/bin/augparse /usr/bin/augparse
+ dosym ../../opt/puppetlabs/puppet/bin/augtool /usr/bin/augtool
+}