summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Anderson <telans@posteo.de>2021-03-07 12:55:48 +0100
committerDavid Seifert <soap@gentoo.org>2021-03-07 12:55:48 +0100
commit2aa5efe3151ddcdce30d865f9d8dac04f9a9eddf (patch)
tree8e97a1599fcba26ca135fc488f3985519c975f71 /app-admin
parentapp-accessibility/brltty: migrate to tmpfiles.eclass (diff)
downloadgentoo-2aa5efe3151ddcdce30d865f9d8dac04f9a9eddf.tar.gz
gentoo-2aa5efe3151ddcdce30d865f9d8dac04f9a9eddf.tar.bz2
gentoo-2aa5efe3151ddcdce30d865f9d8dac04f9a9eddf.zip
app-admin/logrotate: migrate to tmpfiles.eclass
Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Theo Anderson <telans@posteo.de> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/logrotate/logrotate-3.14.0.ebuild6
-rw-r--r--app-admin/logrotate/logrotate-3.17.0.ebuild4
-rw-r--r--app-admin/logrotate/logrotate-3.18.0.ebuild4
3 files changed, 7 insertions, 7 deletions
diff --git a/app-admin/logrotate/logrotate-3.14.0.ebuild b/app-admin/logrotate/logrotate-3.14.0.ebuild
index a31234a61191..bedd9e10b9bb 100644
--- a/app-admin/logrotate/logrotate-3.14.0.ebuild
+++ b/app-admin/logrotate/logrotate-3.14.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit systemd
+inherit systemd tmpfiles
DESCRIPTION="Rotates, compresses, and mails system logs"
HOMEPAGE="https://github.com/logrotate/logrotate"
@@ -75,7 +75,7 @@ src_install() {
use cron && install_cron_file
systemd_dounit examples/logrotate.{service,timer}
- systemd_newtmpfilesd "${FILESDIR}/${PN}.tmpfiles" "${PN}".conf
+ newtmpfiles "${FILESDIR}/${PN}.tmpfiles" "${PN}".conf
keepdir /etc/logrotate.d
}
diff --git a/app-admin/logrotate/logrotate-3.17.0.ebuild b/app-admin/logrotate/logrotate-3.17.0.ebuild
index 33eb0d103ce0..9e712b69c695 100644
--- a/app-admin/logrotate/logrotate-3.17.0.ebuild
+++ b/app-admin/logrotate/logrotate-3.17.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit systemd
+inherit systemd tmpfiles
DESCRIPTION="Rotates, compresses, and mails system logs"
HOMEPAGE="https://github.com/logrotate/logrotate"
@@ -75,7 +75,7 @@ src_install() {
use cron && install_cron_file
systemd_dounit examples/logrotate.{service,timer}
- systemd_newtmpfilesd "${FILESDIR}/${PN}.tmpfiles" "${PN}".conf
+ newtmpfiles "${FILESDIR}/${PN}.tmpfiles" "${PN}".conf
keepdir /etc/logrotate.d
}
diff --git a/app-admin/logrotate/logrotate-3.18.0.ebuild b/app-admin/logrotate/logrotate-3.18.0.ebuild
index 8d3aed775a33..ddc0d62508b4 100644
--- a/app-admin/logrotate/logrotate-3.18.0.ebuild
+++ b/app-admin/logrotate/logrotate-3.18.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit systemd
+inherit systemd tmpfiles
DESCRIPTION="Rotates, compresses, and mails system logs"
HOMEPAGE="https://github.com/logrotate/logrotate"
@@ -75,7 +75,7 @@ src_install() {
use cron && install_cron_file
systemd_dounit examples/logrotate.{service,timer}
- systemd_newtmpfilesd "${FILESDIR}/${PN}.tmpfiles" "${PN}".conf
+ newtmpfiles "${FILESDIR}/${PN}.tmpfiles" "${PN}".conf
keepdir /etc/logrotate.d
}