summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <hydrapolic@gmail.com>2018-07-11 17:24:49 +0200
committerTony Vroon <chainsaw@gentoo.org>2018-07-11 22:50:27 +0100
commit2bc72b89c96c02be0f3cd67832d549c8c1d4ec8e (patch)
tree496b15d5acd269b555d41feb87982287c7a364ae /app-admin
parentapp-admin/filebeat: bump to 5.6.10 (diff)
downloadgentoo-2bc72b89c96c02be0f3cd67832d549c8c1d4ec8e.tar.gz
gentoo-2bc72b89c96c02be0f3cd67832d549c8c1d4ec8e.tar.bz2
gentoo-2bc72b89c96c02be0f3cd67832d549c8c1d4ec8e.zip
app-admin/filebeat: bump to 6.3.1
Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/filebeat/Manifest1
-rw-r--r--app-admin/filebeat/filebeat-6.3.1.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/app-admin/filebeat/Manifest b/app-admin/filebeat/Manifest
index a1775a26dfc1..fd8bf877826b 100644
--- a/app-admin/filebeat/Manifest
+++ b/app-admin/filebeat/Manifest
@@ -3,3 +3,4 @@ DIST filebeat-5.6.10.tar.gz 18211551 BLAKE2B 5ed3a3d63fc758757cdb30e999a10bee15c
DIST filebeat-5.6.9.tar.gz 18209544 BLAKE2B 41891b984240af46fb3d9d7818203d7ef8fd5a089d7683877e3907061259442da4884976cfefcc90666699ebe3adb1ce6c87a026a50b07e218a5de6b642b9472 SHA512 2aa40afbd0f1c987aebf51d22aa03c87048766a4c7d41938ff27ffca841666d34cfbf08ae120d98d222a7d3ff447bbce9f1d65b434aef1c9d73c5019aa1558a1
DIST filebeat-6.1.1.tar.gz 17061456 BLAKE2B 5a5d23618f8140f3815c499305d99ae3dc4c4caa49535043040387922f924ee49a9494b5139f34a70d74173d97332b92909fc74e2f91a2fc0f288ef5d1493ade SHA512 54e85cfce58ba724f6b2892f115ac9ef5b1bb89ce8dc6f2a977e50ccfc07cf95fc578e46e0cadd96acd90c59f4b01446851b93c519afa094ff6dcdb7e716219a
DIST filebeat-6.2.4.tar.gz 19466271 BLAKE2B 417f1db19b7fdd9bcf66f2c3dcdf2aaa6be9ba5edff1c97a0b8f4a5d7953ef27bcbd860e097fb40e67b3b42b795b684dabb2995eee572243831f749a7184b625 SHA512 49293e28e4ca769a88f7b889ea888a559ae7e142698714e24bf5519d00c2030237cac591590aa284f17792906a6137333173716ddf5db4496217f8b5a054b19c
+DIST filebeat-6.3.1.tar.gz 20915568 BLAKE2B 048898bc4520c0dc2a0aa5257149ecb75abc0b52d9a8cae63fdfe9fc8c329b3fa30d7277ae0cb916a86477d60e82b63839956cfa7a1985961c5ee5f6622b9f83 SHA512 1c03cc8fd3b968ade678cf2290fd7bd8fed2f9daa64cd550455567296ff51517b502b54e1b2413820c25cf899b7759662c9c18278c78a2568c74a26841f5f525
diff --git a/app-admin/filebeat/filebeat-6.3.1.ebuild b/app-admin/filebeat/filebeat-6.3.1.ebuild
new file mode 100644
index 000000000000..ed1db863a864
--- /dev/null
+++ b/app-admin/filebeat/filebeat-6.3.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eapi7-ver
+
+DESCRIPTION="Lightweight log shipper for Logstash and Elasticsearch"
+HOMEPAGE="https://www.elastic.co/products/beats"
+SRC_URI="https://github.com/elastic/beats/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test"
+
+DEPEND=">=dev-lang/go-1.10.3"
+RDEPEND="!app-admin/filebeat-bin"
+
+S="${WORKDIR}/src/github.com/elastic/beats"
+
+src_unpack() {
+ mkdir -p "${S%/*}" || die
+ default
+ mv beats-${PV} "${S}" || die
+}
+
+src_prepare() {
+ default
+ sed -i "s/\(COMMIT_ID=\).*/\1${PV}/g" "${S}/libbeat/scripts/Makefile" || die
+}
+
+src_compile() {
+ GOPATH="${WORKDIR}" emake -C "${S}/filebeat"
+}
+
+src_install() {
+ keepdir /var/{lib,log}/${PN}
+
+ fperms 0750 /var/{lib,log}/${PN}
+
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+ newinitd "${FILESDIR}/${PN}.initd.1" ${PN}
+
+ docinto examples
+ dodoc ${PN}/{filebeat.yml,filebeat.reference.yml}
+
+ dobin filebeat/filebeat
+}
+
+pkg_postinst() {
+ if [[ -n "${REPLACING_VERSIONS}" ]]; then
+ elog "Please read the migration guide at:"
+ elog "https://www.elastic.co/guide/en/beats/libbeat/$(ver_cut 1-2)/upgrading.html"
+ elog ""
+ fi
+
+ elog "Example configurations:"
+ elog "${EROOT%/}/usr/share/doc/${PF}/examples"
+}