summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-29 06:55:54 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-29 07:59:35 +0100
commit2bd762a5158fe136800f1d3ad0ba20e8264df8ae (patch)
tree99a1d65a692bcc5b9dbe611920083a826dbbc104 /app-admin
parentdev-python/boto3: Bump to 1.26.18 (diff)
downloadgentoo-2bd762a5158fe136800f1d3ad0ba20e8264df8ae.tar.gz
gentoo-2bd762a5158fe136800f1d3ad0ba20e8264df8ae.tar.bz2
gentoo-2bd762a5158fe136800f1d3ad0ba20e8264df8ae.zip
app-admin/awscli: Bump to 1.27.18
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.27.18.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 87617b17f61c..0f0dce3ab8bb 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -6,4 +6,5 @@ DIST aws-cli-1.27.14.gh.tar.gz 2309344 BLAKE2B dc29dbc89ca963f7dee116b815652c846
DIST aws-cli-1.27.15.gh.tar.gz 2309456 BLAKE2B 17ef8924b61c578462de2ad1eb8e46d16d55a49cc14ca1fa21fd895fa019bcd22bc2eadea498902fd9d440b2d441902c9a78c2b3687aa3cc636894360bdb74b3 SHA512 2e76d318c88bd344ad5336472d6ef1c8231e61b00cfd52f7051bc272966ea1d374584b0f35984441963f7b0d55d74377c3bb4ce60372751d2f2d00043747da72
DIST aws-cli-1.27.16.gh.tar.gz 2309698 BLAKE2B b81d5b1dcc8219a977bfc3cfa41053c12ff8cc363bcb8e3afd9b206d69240a7b4f5ef742d2e74cf21f46bc3a36271a516bf15e1ca34272ad64b4b1dc0c67e4e2 SHA512 1570b82cb2e6cbfb14754b539840b12a606c7a81490bb45239c851757b8e3ac694b41c5842a0b0df825d355d6d6182c6fd6b3c3f26e1c7070150814959c52260
DIST aws-cli-1.27.17.gh.tar.gz 2311030 BLAKE2B d51b0e4279f24e234e09e3401cb3e9a710eb7b6e4295c48eda726c4a3fd3bfba61fe8387106d815d45878fbd897aebafbfa7f8c1035211faefedd4ac057caac7 SHA512 649834169bd1d5069544bccac22ed3ce54eaef839ac0de353127fb8e5a33f72d253e8cfd504aa1bfee06bad82f79a8342defea2178ffe6158dddd4e906497f17
+DIST aws-cli-1.27.18.gh.tar.gz 2313270 BLAKE2B 2f5dc87a2e306d024c03b6cc175736798a28fe5b125aba7e6af9fe1297e44e37fae6990df216cf58c6cdf47ac7b5fc583bed9d5125df063f328544286f4f0f82 SHA512 6f5b0b333af0f842d940cc80f0c18c55feb06c7a4cc609c2db8332126f7e868ccff6f84bfd031bf8d590ca38be9aa258527433e6fab9d63de6a96c64ae740ca2
DIST aws-cli-1.27.8.gh.tar.gz 2301766 BLAKE2B 1873d92b8d2f6d3f29a65b4177927a1a14034da71dbc95ff6abf3f49df6cf3ee192412eeea15be14c8cf9fca0a5603f2c76b80b280f4feb95e661055abcd8b60 SHA512 e53828cac1b3e10e2ddd45312d71cdb748216dbc37c3e9833e7a1320b236c3bef6a13204a38b946d9182430f169fca1ddc77d3d06c1c2c6e05978dc61f675168
diff --git a/app-admin/awscli/awscli-1.27.18.ebuild b/app-admin/awscli/awscli-1.27.18.ebuild
new file mode 100644
index 000000000000..9bcb01ac11e2
--- /dev/null
+++ b/app-admin/awscli/awscli-1.27.18.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/functional/eks/test_kubeconfig.py::TestKubeconfigLoader::test_load_simple
+ tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_env_only
+ tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_existing
+ tests/unit/customizations/eks/test_kubeconfig.py::TestKubeconfigValidator::test_valid
+ )
+
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)" --forked
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}