summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2020-03-26 13:31:50 +0000
committerJoonas Niilola <juippis@gentoo.org>2020-03-26 16:00:48 +0200
commit33c06a242f9badd4fba079b4b8b79ca0c22a2c9e (patch)
tree7ff8a6b05a6780a9729090e47238de22c926a9ed /app-admin
parentnet-im/signal-desktop-bin: remove old version (diff)
downloadgentoo-33c06a242f9badd4fba079b4b8b79ca0c22a2c9e.tar.gz
gentoo-33c06a242f9badd4fba079b4b8b79ca0c22a2c9e.tar.bz2
gentoo-33c06a242f9badd4fba079b4b8b79ca0c22a2c9e.zip
app-admin/graylog: bump to 3.2.4
Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/graylog/Manifest1
-rw-r--r--app-admin/graylog/graylog-3.2.4.ebuild83
2 files changed, 84 insertions, 0 deletions
diff --git a/app-admin/graylog/Manifest b/app-admin/graylog/Manifest
index 77bcce7132db..0c5f556dc34a 100644
--- a/app-admin/graylog/Manifest
+++ b/app-admin/graylog/Manifest
@@ -1,3 +1,4 @@
DIST graylog-2.5.1.tgz 123878927 BLAKE2B d168579be4d20e3a8081d608247e7101fc5d99ddd2b5f063f94d7e91d4095c6bd016a4bc1be0f0e08b5043b771070312286404ece5eacc51e4a8730dfc13dab1 SHA512 44e2ca00e47a34708cea94b74fdc0f56f3a381f161d25633bdf7685fbcd989937163508f8b47b0869c7daacec6c8bd2c874f9381e196ffb3194eb6e3f96b3ce9
DIST graylog-3.1.3.tgz 120983897 BLAKE2B 68e1dd7b8de7ab9fb12fd2035bcf6f0901d8d9f5083ff8efef09736819ccd70ae4dd6f466cf2fa1eaebb24b4098a26d72524f9b9a47e8dd62d0224bad189bb62 SHA512 8eec2339db474b89fc717e693ec23ca32d9a018f9bb924aab895d1a1f4e90afa9fe9547e432d13b9d0bf5831f8772763f19de41ac66f3e09ebf7e96ebd6cbccf
DIST graylog-3.2.2.tgz 125510385 BLAKE2B 87895af9c495361c03b0a6cea6299fb206152a05a69be63600cb15e57ed1c6bb90dcf58539c136361dc95bd7d138b9e6c5bc33c3ccc409e392e4b5857d175951 SHA512 c13c3daee81cd553f40156fc5add46e4af9a3436b04f2216a1460a9af7b5fe07e866451243cc04b756247d513ef76ab43ee52dc7cb67fd1b593a22e490227db7
+DIST graylog-3.2.4.tgz 125543280 BLAKE2B 77e738fb140678af3e4aae80d71e58b15bfbd9b4ffd1d08381678869cf70cadc59d2d19a27d6cdd1634917da4da8a0144543a32ae88bc644effffa6d9d62099c SHA512 97e22516d50a7309d2eb8e608b19d6424eb72c54bdfe699bb996542235b99966cb28487cc11700d6a163d65c1465b9faf681940b9b85d427a5dfb94c42ce2a1d
diff --git a/app-admin/graylog/graylog-3.2.4.ebuild b/app-admin/graylog/graylog-3.2.4.ebuild
new file mode 100644
index 000000000000..cda5c7e5b52d
--- /dev/null
+++ b/app-admin/graylog/graylog-3.2.4.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Free and open source log management"
+HOMEPAGE="https://www.graylog.org"
+SRC_URI="https://downloads.graylog.org/releases/graylog/${P}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+RESTRICT="strip"
+
+RDEPEND="!app-admin/graylog2
+ acct-group/graylog
+ acct-user/graylog
+ >=virtual/jdk-1.8:*"
+
+DOCS=(
+ COPYING README.markdown UPGRADING.rst
+)
+
+GRAYLOG_DATA_DIR="/var/lib/graylog"
+GRAYLOG_INSTALL_DIR="/usr/share/graylog"
+QA_PREBUILT="${GRAYLOG_INSTALL_DIR}/lib/sigar/libsigar*"
+
+src_prepare() {
+ default
+
+ # Stick to architecture of build host
+ if ! use amd64; then
+ rm -r lib/sigar/libsigar-amd64-*.so || die "Failed in removing AMD64 support libraries"
+ fi
+ if ! use ppc64; then
+ rm -r lib/sigar/libsigar-ppc64-*.so || die "Failed in removing PPC64 support libraries"
+ fi
+ if ! use x86; then
+ rm -r lib/sigar/libsigar-x86-*.so || die "Failed in removing X86 support libraries"
+ fi
+ # Currently unsupported platforms
+ # QA warning galore but testing/patches welcome
+ rm lib/sigar/libsigar-*freebsd*so \
+ lib/sigar/libsigar-*solaris*so \
+ lib/sigar/libsigar-*hpux*.sl \
+ lib/sigar/libsigar-*macosx*.dylib \
+ lib/sigar/libsigar-ia64-*.so \
+ lib/sigar/libsigar-ppc-*.so \
+ lib/sigar/libsigar-s390x*.so \
+ lib/sigar/*winnt* || die "Failed in removing unsupported platform libraries"
+
+ # gentoo specific paths
+ sed -i "s@\(node_id_file = \).*@\1${GRAYLOG_DATA_DIR}/node-id@g; \
+ s@\(message_journal_dir = \).*@\1${GRAYLOG_DATA_DIR}/data/journal@g;" \
+ graylog.conf.example || die
+}
+
+src_install() {
+ default
+
+ insinto /etc/graylog
+ doins graylog.conf.example
+
+ insinto "${GRAYLOG_INSTALL_DIR}"
+ doins graylog.jar
+ doins -r lib plugin
+
+ keepdir "${GRAYLOG_DATA_DIR}"
+
+ newconfd "${FILESDIR}/graylog.confd" graylog
+ newinitd "${FILESDIR}/graylog.initd" graylog
+}
+
+pkg_postinst() {
+ ewarn "Graylog does not depend on need.net any more (#439092)."
+ ewarn
+ ewarn "Please configure rc_need according to your binding address in:"
+ ewarn "/etc/conf.d/graylog"
+ ewarn
+ ewarn "Graylog requires Java >= 8"
+ ewarn "Elasticsearch 5.x or 6.x (does NOT work with 7.x)"
+ ewarn "and MongoDB 3.6 or 4.0 (does NOT work with 4.2)"
+}