summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2022-08-02 20:42:01 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2022-08-02 20:42:01 -0500
commit3a466ca0bb7fd844edb96270febdf5c96c126f72 (patch)
tree059413b1354800b71aab50fea7e42bba7cd0a2ad /app-admin
parentwww-client/qutebrowser: add 3.0.0_pre9999 (diff)
downloadgentoo-3a466ca0bb7fd844edb96270febdf5c96c126f72.tar.gz
gentoo-3a466ca0bb7fd844edb96270febdf5c96c126f72.tar.bz2
gentoo-3a466ca0bb7fd844edb96270febdf5c96c126f72.zip
app-admin/puppet: 7.18.0 bump
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/puppet/Manifest1
-rw-r--r--app-admin/puppet/puppet-7.18.0.ebuild127
2 files changed, 128 insertions, 0 deletions
diff --git a/app-admin/puppet/Manifest b/app-admin/puppet/Manifest
index c832ac180fdb..b3cbe1aa9d5b 100644
--- a/app-admin/puppet/Manifest
+++ b/app-admin/puppet/Manifest
@@ -1,3 +1,4 @@
DIST puppet-5.5.22.tar.gz 2998132 BLAKE2B 8662c89190d0904fe44ffeca1cf9a9ddca40d57ba6fb2d1e644ca353ceb55b1ca3a91416f1eef2975233c9c4498784e7d7280c111ea0cc070870cadc69341d99 SHA512 5332b084a63bdf244672cc4751022c84a1cc50d3f394a13bdcbccf7fcf4ebea67953e88957f23046608bf25e9182548449be824c18289cb2bf1e3ed29b40dc58
DIST puppet-7.16.0.tar.gz 2817116 BLAKE2B d367005ea69ceb0f89f4294e74639ad61305f23929e5edf0385eb2cce5da76fa157c5bc7408599dcca4d9adba39c3b29250e78d8f584873f72bb34452a90a74d SHA512 b1f3c6072821225c9068089f44ad9ab955534f2d91bf88b44f762e0588442b9d6191eb89909dc05b7efc3a82302d2d3dc5a5a040fbc84f81645817d695b4db72
DIST puppet-7.17.0.tar.gz 2812615 BLAKE2B 80b5115b8825a87427a688ca7a9337334180fcb7722d437f44009b5cf74ede16dac52f1648a2e7595558abb5fa92322095e71dcf0d7d8d06a2275e13caf79163 SHA512 f691b6d3e931c5cc879c8e5129af2a935bedc891964ba5cbb873d6d69e0ec61bd82ca7d413a94389cda13cb6c8c536aae6f11dade4c6e2597abc7756a74f4df0
+DIST puppet-7.18.0.tar.gz 2816776 BLAKE2B 7c653744a9aa694c6e7558295d33fa8de1958f333cb274a51119ce543846ce649755d5c37ba677d1cdcf2417b237611073ef523aa7a109a3e3dc0e75bd986614 SHA512 428268c9d8333c0624023a3d4b55b5dddfaa890eb6d88a31486c8de5112db4d1dce7553050de81c4b5ffd0fec74c5d10f3c09c3fb1826ffc196808f2b45495d4
diff --git a/app-admin/puppet/puppet-7.18.0.ebuild b/app-admin/puppet/puppet-7.18.0.ebuild
new file mode 100644
index 000000000000..b0c6d6d3ffe3
--- /dev/null
+++ b/app-admin/puppet/puppet-7.18.0.ebuild
@@ -0,0 +1,127 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_TASK_DOC="doc:all"
+RUBY_FAKEGEM_EXTRAINSTALL="locales"
+
+inherit ruby-fakegem systemd tmpfiles
+
+DESCRIPTION="A system automation and configuration management software"
+HOMEPAGE="https://puppet.com/"
+SRC_URI="http://downloads.puppetlabs.com/puppet/${P}.tar.gz"
+
+LICENSE="Apache-2.0 GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 x86"
+IUSE="augeas diff doc emacs ldap rrdtool selinux shadow sqlite vim-syntax"
+RESTRICT="test"
+
+ruby_add_rdepend "
+ dev-ruby/hiera
+ dev-ruby/json:=
+ dev-ruby/semantic_puppet
+ >=dev-ruby/facter-3.0.0
+ dev-ruby/concurrent-ruby
+ augeas? ( dev-ruby/ruby-augeas )
+ diff? ( dev-ruby/diff-lcs )
+ doc? ( dev-ruby/rdoc )
+ ldap? ( dev-ruby/ruby-ldap )
+ shadow? ( dev-ruby/ruby-shadow )
+ sqlite? ( dev-ruby/sqlite3 )
+ virtual/ruby-ssl
+ dev-ruby/hocon"
+
+ruby_add_bdepend "
+ doc? ( dev-ruby/yard )
+ test? (
+ dev-ruby/mocha
+ dev-ruby/rack
+ dev-ruby/rspec-its
+ )"
+# this should go in the above lists, but isn't because of test deps not being keyworded
+# dev-ruby/rspec-collection_matchers
+
+RDEPEND+=" ${RDEPEND}
+ rrdtool? ( >=net-analyzer/rrdtool-1.2.23[ruby] )
+ selinux? (
+ sys-libs/libselinux[ruby]
+ sec-policy/selinux-puppet
+ )
+ vim-syntax? ( >=app-vim/puppet-syntax-3.0.1 )
+ >=app-portage/eix-0.18.0
+ acct-user/puppet
+ acct-group/puppet"
+PDEPEND="emacs? ( >=app-emacs/puppet-mode-0.3-r1 )"
+
+all_ruby_prepare() {
+ # Avoid spec that require unpackaged json-schema.
+ rm spec/lib/matchers/json.rb $( grep -Rl matchers/json spec) || die
+
+ # fix systemd path
+ eapply -p0 "${FILESDIR}/puppet-systemd.patch"
+
+ # Avoid specs that can only run in the puppet.git repository. This
+ # should be narrowed down to the specific specs.
+ rm spec/integration/parser/compiler_spec.rb || die
+
+ # Avoid failing spec that need further investigation.
+ rm spec/unit/module_tool/metadata_spec.rb || die
+}
+
+each_ruby_install() {
+ each_fakegem_install
+# dosym "/usr/$(get_libdir)/ruby/gems/$(ruby_get_version)/gems/${P}" "/usr/$(get_libdir)/ruby/gems/$(ruby_get_version)/gems/${PN}"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ # systemd stuffs
+ systemd_dounit "${WORKDIR}/all/${P}/ext/systemd/puppet.service"
+
+ # tmpfiles stuff
+ newtmpfiles "${FILESDIR}/tmpfiles.d" "puppet.conf"
+
+ # openrc init stuff
+ newinitd "${FILESDIR}"/puppet.init-4.x puppet
+
+ keepdir /etc/puppetlabs/puppet/ssl
+
+ keepdir /var/lib/puppet/facts
+ keepdir /var/lib/puppet/files
+ fowners -R puppet:puppet /var/lib/puppet
+
+ fperms 0750 /var/lib/puppet
+
+ fperms 0750 /etc/puppetlabs
+ fperms 0750 /etc/puppetlabs/puppet
+ fperms 0750 /etc/puppetlabs/puppet/ssl
+ fowners -R :puppet /etc/puppetlabs
+ fowners -R :puppet /var/lib/puppet
+
+ # ext and examples files
+ for f in $(find ext examples -type f) ; do
+ docinto "$(dirname ${f})"
+ dodoc "${f}"
+ done
+}
+
+pkg_postinst() {
+ tmpfiles_process puppet.conf
+
+ elog
+ elog "Please, *don't* include the --ask option in EMERGE_EXTRA_OPTS as this could"
+ elog "cause puppet to hang while installing packages."
+ elog
+ elog "Portage Puppet module with Gentoo-specific resources:"
+ elog "http://forge.puppetlabs.com/gentoo/portage"
+ elog
+ elog "If updating from puppet 5 to 6, keep in mind that webrick (server/master)"
+ elog "suppert was removed for >=6.x, please migrate to puppetserver if you have"
+ elog "not already done so."
+ elog
+}