summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <ajak@gentoo.org>2023-09-13 21:25:23 -0700
committerJohn Helmert III <ajak@gentoo.org>2023-09-13 21:47:10 -0700
commit423bf05b2e88bbc56f80f2b55479fd6be42e51d4 (patch)
treef6b875f4df131ac7d20e730faa4480b9082dc926 /app-admin
parentsys-libs/slang: filter-lto, -fno-strict-aliasing (diff)
downloadgentoo-423bf05b2e88bbc56f80f2b55479fd6be42e51d4.tar.gz
gentoo-423bf05b2e88bbc56f80f2b55479fd6be42e51d4.tar.bz2
gentoo-423bf05b2e88bbc56f80f2b55479fd6be42e51d4.zip
app-admin/gopass: add 1.15.8
Signed-off-by: John Helmert III <ajak@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/gopass/Manifest2
-rw-r--r--app-admin/gopass/gopass-1.15.8.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/app-admin/gopass/Manifest b/app-admin/gopass/Manifest
index 143d3664d4c2..2052f6846f97 100644
--- a/app-admin/gopass/Manifest
+++ b/app-admin/gopass/Manifest
@@ -2,3 +2,5 @@ DIST gopass-1.15.4-deps.tar.xz 34045072 BLAKE2B d8525a166df31c99b20a1a7262c2e287
DIST gopass-1.15.4.tar.gz 2301976 BLAKE2B f947d0e7b7ba599743404a231d9b09380d0069489543e1cc306eb11a3dbf369368dc8c8a464abac04558907fa6c93982a56575b79b7920ee84a46c94beb815ae SHA512 c6cf67de3b3ace253822ea9890a50ecbd2829eb7b625d05327d1b3549ed3ff6b84d1155f71276fa94b6392012b0c87b4b9e488ca0d14915d40af77fc21325603
DIST gopass-1.15.5-deps.tar.xz 182300292 BLAKE2B 12878d90f59c1e15f18eefed331ffcb195292f9895243918cf6e66cc0d90b95bf0b0fa098ba80fb77ec559476c88b79e56102f191bfee6f6b68ef00dbcd7572b SHA512 1ba502d9074fd722c82a998791d291b2fba98c35339f404757b7ae10b3bb8971329e4a8c74bcf4b589e67dede0bf04b240d8a3db9812f4aa75bbd7f7ef9c1c51
DIST gopass-1.15.5.tar.gz 2304217 BLAKE2B bc20ce1f738e01800def34dac131199c249742cb1383af8bd97b0f441b47163b10ba2a3cc41962c933e343b88ce37c60c74665a599724353f3d5a245cc42cc75 SHA512 4e99db0020e87cb494fa33e6d63a6d3d7af10ebff79a32c95bfb18201f881c5e99ce6593c87cb43a6aa2f38bfcae23b1496eee9fbc88026aad41871ca83a94be
+DIST gopass-1.15.8-deps.tar.xz 285946172 BLAKE2B a72ee73cfec9b6b55625eda6f3737d9133f99f1b951c79f87f7e5ea94ec1819fc7f1c3c0b4e16db255839b9e6865adac900f2a03911523ef088a108819b57802 SHA512 2a6293b1ac29f0d27d39d6faf29477a15b362cdd51f6e7c4b79074f7fa7709fdf71f167a96e81ade6429821fe68a9129859b95fc64f6bc2107b434d66a73c78a
+DIST gopass-1.15.8.tar.gz 2309941 BLAKE2B 940855b30b132ca664e6e838cd1b3e8713a571e84c92ea873b0a0090df369492fdda46e1e2cf1e88f8e52ebe6308805ab707e9a74d3125396b0497ed2f79db5e SHA512 8c4f6fd750fa15dba7f81acccd4360c57e2454b7162625d38b1aa0d9d9fe218d2e7664c1505ff40450aab0cd829cc156b7e5544b64c790337078c6d86758cae7
diff --git a/app-admin/gopass/gopass-1.15.8.ebuild b/app-admin/gopass/gopass-1.15.8.ebuild
new file mode 100644
index 000000000000..f85c0b12c06a
--- /dev/null
+++ b/app-admin/gopass/gopass-1.15.8.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module optfeature
+
+DESCRIPTION="a simple but powerful password manager for the terminal"
+HOMEPAGE="https://www.gopass.pw/"
+SRC_URI="https://github.com/gopasspw/gopass/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~ajak/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="MIT Apache-2.0 BSD MPL-2.0 BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~riscv ~x86"
+
+DEPEND=">=dev-lang/go-1.18"
+RDEPEND="
+ dev-vcs/git
+ >=app-crypt/gnupg-2
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.15.3-skip-tests.patch"
+)
+
+src_test() {
+ # https://github.com/gopasspw/gopass/blob/v1.15.3/.github/workflows/build.yml#L38
+ git config --global user.name nobody || die
+ git config --global user.email foo.bar@example.org || die
+
+ default
+}
+
+src_install() {
+ emake install DESTDIR="${ED}/usr"
+ einstalldocs
+}
+
+pkg_postinst() {
+ optfeature "browser integration" app-admin/gopass-jsonapi
+ optfeature "git credentials helper" app-admin/git-credential-gopass
+ optfeature "haveibeenpwnd.com integration" app-admin/gopass-hibp
+ optfeature "summon secrets helper" app-admin/gopass-summon-provider
+}