summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-28 07:18:54 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-28 08:23:32 +0100
commit4cf188c06c3079fee3583d5170c29a19d42f32fb (patch)
tree93690e00c650498fab53a92a76bcd736fc01008d /app-admin
parentdev-python/boto3: Bump to 1.34.9 (diff)
downloadgentoo-4cf188c06c3079fee3583d5170c29a19d42f32fb.tar.gz
gentoo-4cf188c06c3079fee3583d5170c29a19d42f32fb.tar.bz2
gentoo-4cf188c06c3079fee3583d5170c29a19d42f32fb.zip
app-admin/awscli: Bump to 1.32.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.32.9.ebuild88
2 files changed, 89 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 2e311b3f73f5..dc79042b411c 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -2,3 +2,4 @@ DIST aws-cli-1.31.11.gh.tar.gz 2605881 BLAKE2B 816846d5dd50a382b837cb25e01be330c
DIST aws-cli-1.32.2.gh.tar.gz 2609043 BLAKE2B 18cf285e54c25605502167e4fa002f522063dd85fc0c09eb44b4513ada49dbe476ca4485bb1cb63e726c5e1bee6934ccfa340ac9c9daecae082abb1abd852426 SHA512 951814c6e5a5dcf74de12e66430c53ca010bae6a8c9984dc11ab456f1cbd4a3f32e5055b3f7587fdf8cff4c224f86bc95858a2556ed5b90981894f706ab1b023
DIST aws-cli-1.32.7.gh.tar.gz 2620400 BLAKE2B dee6686b73100c607eba165f0f8ff91217336b020644c7ef7ee95dad16f57baea0878a3da96fd2f7258271573c1245286921240d141ba3020006b7ca2b37a0b5 SHA512 1df4aa8f2a2924d0e1c84e1187db1d5b974600831d7f668e39cfa17c34896ec51c604ef52d5ce397ca5950e79cac3c2e744c9b048f12164b650aa871e0c489e7
DIST aws-cli-1.32.8.gh.tar.gz 2620170 BLAKE2B 206b166946e36252ed6f4af6c808d4773681708c5d6b31115fb21f72a9723f77d8c9d0c03793d3c4abfc01207006c42239feac8d2e4f87ec430e07d056dfd36f SHA512 d734eeb1cfee8f42e31564985eee797ca07078fae4c3a3acda44f3b1ece8e61d5baebe9b83ac7f1bbdb65969618c243c62baebe04d5474fa669732e87f6cf059
+DIST aws-cli-1.32.9.gh.tar.gz 2620477 BLAKE2B 99288c033702fc30d7903d7c38f0b0e98e08cf4f2cd46eb771c7da2609af10e17743ed132ae7c6b3f96c2797aafdab9388df01e922f2f2d08912582d06907692 SHA512 34f0153ec80aebb16d353d0a026853fab6c28542aec0343ef6639ac355c4f9d8e002c6f36f7828d9387364c09a26aa7c3155f89fec4900336cf86c755cdacb03
diff --git a/app-admin/awscli/awscli-1.32.9.ebuild b/app-admin/awscli/awscli-1.32.9.ebuild
new file mode 100644
index 000000000000..77feb2d63e3e
--- /dev/null
+++ b/app-admin/awscli/awscli-1.32.9.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit bash-completion-r1 distutils-r1
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local serial_tests=(
+ tests/functional/ecs/test_execute_command.py::TestExecuteCommand::test_execute_command_success
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_{fails,success}
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking_windows
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestNuGetLogin::test_login_nuget_sources_listed_with_backtracking
+ tests/unit/customizations/ecs/test_executecommand_startsession.py::TestExecuteCommand::test_execute_command_success
+ tests/unit/customizations/test_sessionmanager.py
+ tests/unit/test_compat.py::TestIgnoreUserSignals
+ tests/unit/test_help.py
+ tests/unit/test_utils.py::TestIgnoreCtrlC::test_ctrl_c_is_ignored
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ EPYTEST_XDIST= epytest "${serial_tests[@]}"
+
+ local EPYTEST_DESELECT=( "${serial_tests[@]}" )
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit}
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}