summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <hydrapolic@gmail.com>2018-01-03 17:24:11 +0100
committerMichał Górny <mgorny@gentoo.org>2018-01-31 22:58:29 +0100
commit52bf7e52e66bb24cb37e24a426dced93859278fc (patch)
tree6720559a9665d09d1f53313996c6ea64940920c1 /app-admin
parentapp-misc/elasticsearch: drop old (diff)
downloadgentoo-52bf7e52e66bb24cb37e24a426dced93859278fc.tar.gz
gentoo-52bf7e52e66bb24cb37e24a426dced93859278fc.tar.bz2
gentoo-52bf7e52e66bb24cb37e24a426dced93859278fc.zip
app-admin/logstash-bin: version bump to 6.1.1
Package-Manager: Portage-2.3.18, Repoman-2.3.6
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/logstash-bin/Manifest1
-rw-r--r--app-admin/logstash-bin/logstash-bin-6.1.1.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/app-admin/logstash-bin/Manifest b/app-admin/logstash-bin/Manifest
index 1d5bd66e6472..54dc647d07df 100644
--- a/app-admin/logstash-bin/Manifest
+++ b/app-admin/logstash-bin/Manifest
@@ -1,3 +1,4 @@
DIST logstash-5.5.3.zip 99551442 BLAKE2B ee29db9b606a3aae83c218d020fc8c17d19013411e3a0deb6c333489803f4d3d6809ac8806adf373e319888049826d0d4ce8f09ca6db3b1afdeb261321e349ba SHA512 a4328ad0b8192b7c5aaed155d608d9db6adeaefd640e461ef4467daa1a28a2ae25d6b2b1adcf47c5dd82b66fc1adbf8ba5f3eabcf7e69dd8719a5860795877aa
DIST logstash-5.6.5.zip 109135563 BLAKE2B 6846231439807dd4fc77ae86af849aaefcc9084482f2f88de6148da3d31ef583164da6749ebe0c4def83217e95729a933acbb3e04777db58639eaab91de06831 SHA512 f1dcbb8f67d2f2868e38646b56376428e0996cbf302837300939b8c7ff6d764417fccea40f90559c48441f939e6940e84501ee3ad1e29ad2538969f2cc12b2b8
DIST logstash-6.0.1.zip 116215793 BLAKE2B 676810b9cd62f578e31e1d63d4aae8c920590905a7344434d5e14607bab0e3ce59e2740e6839491f44ce769b24330a7a060174dcb5e6cb9cf51a31d165ba990b SHA512 395e4e2ff199d9ffc5156901d6ba6ab17771ab8f8859acede74567b2294e2d7ee2a6693e79f7b3e82c8d5c1959ad259bfb22e7992670cdcd3b73c7b72a635a31
+DIST logstash-6.1.1.zip 116335093 BLAKE2B e7a990c2ea0eb3ec7de714f038765817c76eaf9e6cef0e55106f1f1aca406ec95d6be779f24c1fa28e096b51feeef968cb31f416f99c85c2f45d798bb74aadf7 SHA512 a2a420169dff31f3d5d65628a9d1eaad930a8e544fc4e986e3671ffeea3a1d03c8f77f8b51568a0da082588a843568fb7aefe29c1c90365882f429f9536f9240
diff --git a/app-admin/logstash-bin/logstash-bin-6.1.1.ebuild b/app-admin/logstash-bin/logstash-bin-6.1.1.ebuild
new file mode 100644
index 000000000000..1977b1915acb
--- /dev/null
+++ b/app-admin/logstash-bin/logstash-bin-6.1.1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit java-pkg-2 user
+
+MY_PN="${PN%-bin}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Tool for managing events and logs"
+HOMEPAGE="https://www.elastic.co/products/logstash"
+SRC_URI="https://artifacts.elastic.co/downloads/${MY_PN}/${MY_P}.zip"
+
+# source: LICENSE.txt and NOTICE.txt
+LICENSE="Apache-2.0 MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RESTRICT="strip"
+QA_PREBUILT="opt/logstash/vendor/jruby/lib/jni/*/libjffi*.so"
+
+RDEPEND="virtual/jre:1.8"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ enewgroup ${MY_PN}
+ enewuser ${MY_PN} -1 -1 /var/lib/${MY_PN} ${MY_PN}
+}
+
+src_install() {
+ keepdir /etc/"${MY_PN}"/{conf.d,patterns,plugins}
+ keepdir "/var/lib/${MY_PN}"
+ keepdir "/var/log/${MY_PN}"
+
+ insinto "/usr/share/${MY_PN}"
+ newins "${FILESDIR}/agent.conf.sample" agent.conf
+
+ rm -v config/startup.options || die
+ insinto /etc/${MY_PN}
+ doins -r config/.
+ rm -rv config data || die
+
+ insinto "/opt/${MY_PN}"
+ doins -r .
+ fperms 0755 "/opt/${MY_PN}/bin/${MY_PN}" "/opt/${MY_PN}/vendor/jruby/bin/jruby" "/opt/${MY_PN}/bin/logstash-plugin"
+
+ newconfd "${FILESDIR}/${MY_PN}.confd-r1" "${MY_PN}"
+ newinitd "${FILESDIR}/${MY_PN}.initd-r1" "${MY_PN}"
+
+ insinto /usr/share/eselect/modules
+ doins "${FILESDIR}"/logstash-plugin.eselect
+}
+
+pkg_postinst() {
+ ewarn "The default pidfile directory has been changed from /run/logstash to /run."
+ ewarn "Please ensure any running logstash processes are shut down cleanly."
+ ewarn
+ ewarn "The default data directory has been moved from /opt/logstash/data to"
+ ewarn "/var/lib/logstash/data. Please check and move its contents as necessary."
+ ewarn
+ ewarn "Self installed plugins are removed during Logstash upgrades (Bug #622602)"
+ ewarn "Install the plugins via eselect module that will automatically re-install"
+ ewarn "all self installed plugins after Logstash upgrades."
+ einfo
+ einfo "Installing plugins:"
+ einfo "eselect logstash-plugin install logstash-output-gelf"
+ einfo
+
+ einfo "Reinstalling self installed plugins (installed via eselect module):"
+ eselect logstash-plugin reinstall
+
+ einfo
+ einfo "Sample configuration:"
+ einfo "${EROOT%/}/usr/share/${MY_PN}"
+}