summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2020-01-19 15:56:44 +0300
committerMikle Kolyada <zlogene@gentoo.org>2020-01-19 15:58:17 +0300
commit585a22a65a2e8a8510a8cdccebe42345ab1889dc (patch)
tree334392b379516092359a1d91da00a4423d799145 /app-admin
parentnet-dialup/minicom: update homepage, bug #698816 (diff)
downloadgentoo-585a22a65a2e8a8510a8cdccebe42345ab1889dc.tar.gz
gentoo-585a22a65a2e8a8510a8cdccebe42345ab1889dc.tar.bz2
gentoo-585a22a65a2e8a8510a8cdccebe42345ab1889dc.zip
app-admin/terraform: Version bump (v0.21.19)
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/terraform/Manifest1
-rw-r--r--app-admin/terraform/terraform-0.12.17.ebuild4
-rw-r--r--app-admin/terraform/terraform-0.12.19.ebuild45
3 files changed, 48 insertions, 2 deletions
diff --git a/app-admin/terraform/Manifest b/app-admin/terraform/Manifest
index 2fedad553b59..5f75a93aa9bf 100644
--- a/app-admin/terraform/Manifest
+++ b/app-admin/terraform/Manifest
@@ -4,3 +4,4 @@ DIST terraform-0.12.12.tar.gz 10441883 BLAKE2B c30366c46bc77b7b5c1a44766ce891db0
DIST terraform-0.12.15.tar.gz 10432372 BLAKE2B 9d8d70cf88ef56dbe891be266353fe2eb89b51740e22264f46e0b20785bbb8b6752e2465b02dba79bd9a30a6d0914ddfc7e9b7000f38fcbeb01580d1ac52eec3 SHA512 a63b0acd81e814b679a479ead8afe023d5fca0a925eef6b7ccbfa1916554e47a383dbe73f97d036c0c8ebe3e2289c9001ce24c50eef4e5d5eab3ca48d766150b
DIST terraform-0.12.16.tar.gz 10435715 BLAKE2B 1f2f221130ebe8df45cdde5fece7773af16b4dfc0a1a336109c9ea3eafcc5f8382069e60b7efe702b9683ab3ed586e1c1fbdbd1582423642485274490df01255 SHA512 8f499843f53a27587b08beb25973fccd08ee84191a53407ee3aa2e9aad483e597791665485a7ed6d7c94f96b611956e83fd610e603a2e8e7732eaa78d3920ed5
DIST terraform-0.12.17.tar.gz 10508005 BLAKE2B facef6de57333586445ce8839c03ccd633fe9ac68619e384b71fff921afeaf260e01b8783d61e4cc04882aa644e8eb706b08c88216f093d85e0fd081363c4103 SHA512 6311fdbf6764e585126a1e177dc498634a799ba1a68ba98682e2be29d14b40c09d0a780555f10bbde0587445d31a1e0d9810226f9e6bd3fcb248428ceb864c87
+DIST terraform-0.12.19.tar.gz 10526213 BLAKE2B 89acdb2e099532a922d49ac3d0049c522b7936817afb7836ebf643ef21fd35f3be495cde5a92ea93add144dada0f54de55b4b42a668bff08c9db789a1d4a77d1 SHA512 3acf327bdbaeddf6f13fc1a2a2335675dd3910137ef685224e7c1eafddf18d0aaa8c24aa3b1b5027b21905d2d87fbe3d49904e196c9881063d01670c4de3db66
diff --git a/app-admin/terraform/terraform-0.12.17.ebuild b/app-admin/terraform/terraform-0.12.17.ebuild
index 6183146d4a09..16e496f4ef87 100644
--- a/app-admin/terraform/terraform-0.12.17.ebuild
+++ b/app-admin/terraform/terraform-0.12.17.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -13,7 +13,7 @@ SRC_URI="https://github.com/hashicorp/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
LICENSE="Apache-2.0 BSD-2 BSD-4 ECL-2.0 imagemagick ISC JSON MIT MIT-with-advertising MPL-2.0 unicode"
SLOT="0"
-KEYWORDS="~amd64"
+KEYWORDS="amd64"
RESTRICT="test"
diff --git a/app-admin/terraform/terraform-0.12.19.ebuild b/app-admin/terraform/terraform-0.12.19.ebuild
new file mode 100644
index 000000000000..4196f78931b6
--- /dev/null
+++ b/app-admin/terraform/terraform-0.12.19.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit golang-base go-module
+
+DESCRIPTION="A tool for building, changing, and combining infrastructure safely"
+HOMEPAGE="https://www.terraform.io/"
+
+EGO_PN="github.com/hashicorp/${PN}"
+SRC_URI="https://github.com/hashicorp/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD-2 BSD-4 ECL-2.0 imagemagick ISC JSON MIT MIT-with-advertising MPL-2.0 unicode"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RESTRICT="test"
+
+DOCS=( {README,CHANGELOG}.md )
+
+src_prepare() {
+ default
+ # the sed command is necessary to generate tests outside of the
+ # default git root of `terraform', in our case the working dir
+ # is `work/$PN-$PV'
+ # sed -i -e "s/!=\s\+\"terraform\"/!=\ \"${P}\"/" \
+ # ./scripts/generate-plugins.go || die
+}
+
+src_compile() {
+ GOCACHE="${T}/go-cache" go build \
+ -work -o "bin/${PN}" ./ || die
+}
+
+src_install() {
+ dobin bin/terraform
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog "If you would like to install shell completions please run:"
+ elog " terraform -install-autocomplete"
+}