summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRodrigo Saboya <saboya@users.noreply.github.com>2017-01-16 15:48:08 -0200
committerLars Wendler <polynomial-c@gentoo.org>2017-01-17 18:38:57 +0100
commit5993df809e309937b59d1a545fe7bc9f264b5711 (patch)
treebd091e0124aa9c8461b59d31d088103653f2f6fb /app-admin
parentdev-php/ffmpeg-php: Remove package wrt bug 602164 (diff)
downloadgentoo-5993df809e309937b59d1a545fe7bc9f264b5711.tar.gz
gentoo-5993df809e309937b59d1a545fe7bc9f264b5711.tar.bz2
gentoo-5993df809e309937b59d1a545fe7bc9f264b5711.zip
app-admin/sysklogd: Fixing build issue with Glibc 2.24. bug #604232
Closes: https://github.com/gentoo/gentoo/pull/3508
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/sysklogd/files/sysklogd-1.5-glibc-2.24.patch11
-rw-r--r--app-admin/sysklogd/sysklogd-1.5.1-r1.ebuild62
2 files changed, 73 insertions, 0 deletions
diff --git a/app-admin/sysklogd/files/sysklogd-1.5-glibc-2.24.patch b/app-admin/sysklogd/files/sysklogd-1.5-glibc-2.24.patch
new file mode 100644
index 000000000000..fcddb7574590
--- /dev/null
+++ b/app-admin/sysklogd/files/sysklogd-1.5-glibc-2.24.patch
@@ -0,0 +1,11 @@
+--- sysklogd-1.5.1/syslogd.c
++++ sysklogd-1.5.1/syslogd.c
+@@ -2094,7 +2094,7 @@
+ (void) signal(SIGCHLD, reapchild); /* reset signal handler -ASP */
+ wait ((int *)0);
+ #else
+- union wait status;
++ int status;
+
+ while (wait3(&status, WNOHANG, (struct rusage *) NULL) > 0)
+ ;
diff --git a/app-admin/sysklogd/sysklogd-1.5.1-r1.ebuild b/app-admin/sysklogd/sysklogd-1.5.1-r1.ebuild
new file mode 100644
index 000000000000..9fdc76a7b23d
--- /dev/null
+++ b/app-admin/sysklogd/sysklogd-1.5.1-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DEB_PV="1.5-6"
+DESCRIPTION="Standard log daemons"
+HOMEPAGE="http://www.infodrom.org/projects/sysklogd/"
+SRC_URI="http://www.infodrom.org/projects/sysklogd/download/${P}.tar.gz
+ mirror://debian/pool/main/s/sysklogd/${PN}_${DEB_PV}.diff.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="logrotate"
+RESTRICT="test"
+
+DEPEND=""
+RDEPEND="dev-lang/perl
+ sys-apps/debianutils"
+
+src_prepare() {
+ epatch "${WORKDIR}"/${PN}_${DEB_PV}.diff
+
+ epatch "${FILESDIR}"/${PN}-1.5-debian-cron.patch
+ epatch "${FILESDIR}"/${PN}-1.5-build.patch
+
+ # CAEN/OWL security patches
+ epatch "${FILESDIR}"/${PN}-1.4.2-caen-owl-syslogd-bind.diff
+ epatch "${FILESDIR}"/${PN}-1.4.2-caen-owl-syslogd-drop-root.diff
+ epatch "${FILESDIR}"/${PN}-1.4.2-caen-owl-klogd-drop-root.diff
+
+ epatch "${FILESDIR}"/${PN}-1.5-syslog-func-collision.patch #342601
+ epatch "${FILESDIR}"/${PN}-1.5-glibc-2.24.patch #604232
+}
+
+src_configure() {
+ append-lfs-flags
+ tc-export CC
+}
+
+src_install() {
+ dosbin syslogd klogd debian/syslog-facility debian/syslogd-listfiles
+ doman *.[1-9] debian/syslogd-listfiles.8
+ insinto /etc
+ doins debian/syslog.conf
+ if use logrotate ; then
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/sysklogd.logrotate sysklogd
+ else
+ exeinto /etc/cron.daily
+ newexe debian/cron.daily syslog
+ exeinto /etc/cron.weekly
+ newexe debian/cron.weekly syslog
+ fi
+ dodoc ANNOUNCE CHANGES NEWS README.1st README.linux
+ newinitd "${FILESDIR}"/sysklogd.rc7 sysklogd
+ newconfd "${FILESDIR}"/sysklogd.confd sysklogd
+}