summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2020-10-09 11:49:13 +0000
committerJoonas Niilola <juippis@gentoo.org>2020-10-13 16:11:48 +0300
commit624721ef3ccef59556c381a4fbfb216645790e4b (patch)
tree0a357c24b1ef95019600ee354b70fdb576e99204 /app-admin
parentmedia-libs/libpgf: security cleanup (diff)
downloadgentoo-624721ef3ccef59556c381a4fbfb216645790e4b.tar.gz
gentoo-624721ef3ccef59556c381a4fbfb216645790e4b.tar.bz2
gentoo-624721ef3ccef59556c381a4fbfb216645790e4b.zip
app-admin/ngxtop: add python3.9, adjust DISTUTILS_USE_SETUPTOOLS
Closes: https://bugs.gentoo.org/745876 Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/17861 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/ngxtop/ngxtop-0.0.3_pre141201-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-admin/ngxtop/ngxtop-0.0.3_pre141201-r1.ebuild b/app-admin/ngxtop/ngxtop-0.0.3_pre141201-r1.ebuild
new file mode 100644
index 000000000000..a38a287da511
--- /dev/null
+++ b/app-admin/ngxtop/ngxtop-0.0.3_pre141201-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+PYTHON_REQ_USE="sqlite"
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="real-time metrics for nginx server (and others)"
+HOMEPAGE="https://github.com/lebinh/ngxtop"
+#SRC_URI="https://github.com/lebinh/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/docopt[${PYTHON_USEDEP}]
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ dev-python/tabulate[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.0.2-py3.patch )