summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-09-25 14:57:41 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2017-09-25 14:58:02 -0500
commit633b8bd60b7ec52b1e8e7c6952053098f59578b8 (patch)
treeba83eec6c56bad73aa1af93641bfd9111d27c4f7 /app-admin
parentdev-ruby/facter: 3.9.1 bup (diff)
downloadgentoo-633b8bd60b7ec52b1e8e7c6952053098f59578b8.tar.gz
gentoo-633b8bd60b7ec52b1e8e7c6952053098f59578b8.tar.bz2
gentoo-633b8bd60b7ec52b1e8e7c6952053098f59578b8.zip
app-admin/mcollective: 2.11.3 bup
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/mcollective/Manifest1
-rw-r--r--app-admin/mcollective/mcollective-2.11.3.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/app-admin/mcollective/Manifest b/app-admin/mcollective/Manifest
index cfcda790247e..44d898f5f30d 100644
--- a/app-admin/mcollective/Manifest
+++ b/app-admin/mcollective/Manifest
@@ -1,2 +1,3 @@
DIST mcollective-2.11.1.tar.gz 1516922 SHA256 d5e150408e61d51b3844e14c6304cf61f27243c5dc658e689bbaaee91dce6b0b SHA512 88d2511829936a5987c8ddab068f59d17f16230cb339801672238ae54ce2115e93d7271a78001176ccc203a1b70f7ee2f35992e414059f1db9cb05db210463e5 WHIRLPOOL cff40347c46464a18d6d98e3a3e2a7dab4169f5c0e1b60f08f3292cc87adcc123fc423203d664bcee1dac47a1dd44e44726702de5c2ea0ed0c5e55d8dbe0b45a
DIST mcollective-2.11.2.tar.gz 1516590 SHA256 aa3664d5ba2d4d20e448c374c315c91d55b5bb43918a04092747a4052bc3f969 SHA512 1dc393fa1a09c5151b64b84086ef9af934feeebd2700a00cc4c84696fa2a25d90a410a373b553198f5fda6e1e36808ffb8dc38edcb15bb9e4253998aa7504439 WHIRLPOOL f808d4f9ffbf733842dd29f8e0548b90a4705f8b502dcc62509380b013d69de786204025490d4fb67d657e5c6597fb0d3ffdac2724e8dbca6347511ef50be54a
+DIST mcollective-2.11.3.tar.gz 1516665 SHA256 b9080779fa56c2b77a3f37404b3ac933183e0b0940e6086b0060be2c44aa38d3 SHA512 f5e26dff03f7a671db5de12acba1ce726c8d57fb99831ddbb258da5ba297ade31ea991840fa63cb1ba261281f7f6167a8492c8764a13cc332202ccb9c88d79b8 WHIRLPOOL 69e384489c8138aecc0c404dc9a08e5d92e09deab05a43ab4781b77506f4fe6f3bbd1a9ec9399a59e8a7c89d3462d3062d73a50fae490215628826c2794bd9ff
diff --git a/app-admin/mcollective/mcollective-2.11.3.ebuild b/app-admin/mcollective/mcollective-2.11.3.ebuild
new file mode 100644
index 000000000000..795e37902641
--- /dev/null
+++ b/app-admin/mcollective/mcollective-2.11.3.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+USE_RUBY="ruby21 ruby22 ruby23"
+
+inherit ruby-ng
+
+DESCRIPTION="Framework to build server orchestration or parallel job execution
+systems"
+HOMEPAGE="https://docs.puppet.com/mcollective/"
+SRC_URI="https://github.com/puppetlabs/marionette-collective/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/all/marionette-collective-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc +client"
+
+DEPEND=""
+RDEPEND="dev-ruby/stomp"
+
+src_compile() {
+ einfo "nothing to compile"
+}
+
+each_ruby_install() {
+ cd "marionette-collective-${PV}"
+ doruby -r lib/*
+ insinto /usr/share/mcollective
+ use client && dosbin bin/mco
+ dosbin bin/mcollectived
+ if use doc ; then
+ dohtml -r doc/*
+ insinto /usr/share/doc/${P}/ext
+ doins -r ext/*
+ fi
+ newinitd "${FILESDIR}"/mcollectived.initd mcollectived
+ insinto /etc/mcollective
+ cd etc
+ for cfg in *.dist ; do
+ newins "${cfg}" "${cfg%%.dist}"
+ sed -i -e "s:^libdir.*:libdir = /usr/share/mcollective/plugins:" \
+ "${D}"/etc/mcollective/${cfg%%.dist} || die "sed failed"
+ done
+ insinto /etc/mcollective/plugin.d
+}
+
+pkg_postinst() {
+ einfo "Mcollective requires a stomp server installed and functioning before"
+ einfo "you can use it. The recommended server to use is ActiveMQ [1] but"
+ einfo "any other stomp compatible server should work."
+ einfo
+ einfo "It is recommended you read the \'getting started\' guide [2] if this"
+ einfo "is a new installation"
+ einfo
+ einfo "[1] https://activemq.apache.org/"
+ einfo "[2] https://code.google.com/p/mcollective/wiki/GettingStarted"
+}