summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-10 22:35:27 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-10 23:34:55 +0100
commit64c1cb2be3d7a828c02c9b050bcaa25d6fd53c2e (patch)
tree29588283722e88ac37d47b2217b0e985574271c0 /app-admin
parentdev-python/boto3: Bump to 1.20.3 (diff)
downloadgentoo-64c1cb2be3d7a828c02c9b050bcaa25d6fd53c2e.tar.gz
gentoo-64c1cb2be3d7a828c02c9b050bcaa25d6fd53c2e.tar.bz2
gentoo-64c1cb2be3d7a828c02c9b050bcaa25d6fd53c2e.zip
app-admin/awscli: Bump to 1.22.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.22.3.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 690351a609c6..78f44c335041 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -5,3 +5,4 @@ DIST awscli-1.21.12.tar.gz 2097963 BLAKE2B e752cb1369be9ee26b517ba1226d3e16fad0a
DIST awscli-1.21.5.tar.gz 2095418 BLAKE2B 152d0ac70e9e0120fb9b10451904af52035bce84168c055695e7dc93e56648bd7689f20ac0ecdbdfc54ccb846d51b33027d2e9ee09c5e5d1e915c0ec05b0fbfe SHA512 e3063252a50fc6033669a0ff80f82d73764a6728d623d75a27f0652e779cbeb452454d887bf5bd70199a7394df40f9758b14619778c6428a164d590e6c8aaa89
DIST awscli-1.22.1.tar.gz 2109309 BLAKE2B 24be9fca3f767745eb2bd8dd77389410a95e583c8b9fb701122c666cd190393aa32299ec2c62f19a917a235853cc6dbde5324ad665c11ec3d54f596584d19470 SHA512 b653a63f1db2f4cfeba0ef463596bd9b7d40a76b06bbeb9671eba9e14cd27f3283ba222ad97172d8399f2c9a8f8fa39f59a25a1e5f8832cba6694f26262797bc
DIST awscli-1.22.2.tar.gz 2109538 BLAKE2B 09ba6020093a80f1505bf945f0e0946cc37368a9ef1425e1ff20cfe3b19d9cb346f52f22513c58e8820a1454dd296474efaeef6349060819bb29dce972216549 SHA512 64a32f6ae4961f20c52801bcc654fbeb2a84e2bcf582e701ab266ffd61a67b1122a2dcb469ae43c363b87b8b79b59c78738adef7c4677d19c5a7bb4dcb11764b
+DIST awscli-1.22.3.tar.gz 2109828 BLAKE2B 48424e51dc05a3a23be5b8e0d71b2a9cc946e740862553e52272213ca30c0b2a863b160bd6301b6dad647369c0ee9de5f99cb6cd882000ee32cc7d89401efe2a SHA512 34ca06dc9261580937e752db42374ce104f79dfa982a553e3c11b196f6d59036ae674ff28e7176e26fe7489685e10b45c5fe4dbb0ed806e898d6e2e300bde5ab
diff --git a/app-admin/awscli/awscli-1.22.3.ebuild b/app-admin/awscli/awscli-1.22.3.ebuild
new file mode 100644
index 000000000000..d4b09dbaa2ec
--- /dev/null
+++ b/app-admin/awscli/awscli-1.22.3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="https://pypi.org/project/awscli/"
+#SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/aws/aws-cli/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/aws-cli-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+# botocore is x.(y+1).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 1)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.4.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests --install pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ distutils_install_for_testing
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit}
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}