summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@atlas.cz>2022-11-27 16:16:32 +0100
committerSam James <sam@gentoo.org>2022-12-06 09:45:08 +0000
commit69df4a3fff49a191e6e9a981c472cca9e3e438e7 (patch)
tree688119bb476fc1181eaffa8dd967019e1f28d543 /app-admin
parentnet-libs/webkit-gtk: Stabilize 2.38.2 ppc64, #879809 (diff)
downloadgentoo-69df4a3fff49a191e6e9a981c472cca9e3e438e7.tar.gz
gentoo-69df4a3fff49a191e6e9a981c472cca9e3e438e7.tar.bz2
gentoo-69df4a3fff49a191e6e9a981c472cca9e3e438e7.zip
app-admin/clustershell: add 1.9
Patches are not needed anymore. Upstream have fixed reported issue [1] and also worked in conditional unittest skips for hostname set to localhost [2], thus TreeWrokerTest.py does not need to be removed in prepare phase. [1] https://github.com/cea-hpc/clustershell/issues/488 [2] https://github.com/cea-hpc/clustershell/commit/aae7bc7ed0e25f612e2adf95d28ae909346a8d53 Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/clustershell/Manifest1
-rw-r--r--app-admin/clustershell/clustershell-1.9.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/app-admin/clustershell/Manifest b/app-admin/clustershell/Manifest
index d0d4d2bb3011..51e3fee161e3 100644
--- a/app-admin/clustershell/Manifest
+++ b/app-admin/clustershell/Manifest
@@ -1 +1,2 @@
DIST clustershell-1.8.4.gh.tar.gz 367622 BLAKE2B 1487697a49d37902f9763094da1a156f5e7cc2ab0487814207bb9da03b1109f1ce55034fc92e72262d4b9920d5c52b9f6de84ce1ff04b06d042b0a6d005f1049 SHA512 582393e56d94e62e126d91f8af074a7b57d0e781a5c929cfc374e61324c412c32fcf9a8e063a78cb805c2ff34641887a1adfc7ef9f377b881077f719dbc2adc3
+DIST clustershell-1.9.gh.tar.gz 382574 BLAKE2B 031eb9683db330f3b90ac06fa9a0409ea72c1be3d83c8d0519e0080ead715386043c925a6dbaeafdb38351c54f1508c050279603cd81bc2de60ba2df5733f636 SHA512 9eb4e9663a6381fa27311d1d70002ba64066ee6e2e08aaf772974d8097c6ca2d020563fc8478064e76bc6e56d37ed7eefc2919db99a2f5b26bd878fa7b764a15
diff --git a/app-admin/clustershell/clustershell-1.9.ebuild b/app-admin/clustershell/clustershell-1.9.ebuild
new file mode 100644
index 000000000000..4524a4f95ed9
--- /dev/null
+++ b/app-admin/clustershell/clustershell-1.9.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python framework for efficient cluster administration"
+HOMEPAGE="https://github.com/cea-hpc/clustershell/"
+SRC_URI="
+ https://github.com/cea-hpc/clustershell/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ app-shells/pdsh
+ net-misc/openssh
+ sys-devel/bc
+ )
+"
+
+RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ default
+
+ # remove test sets that require working ssh connection
+ rm tests/{CLIClush,TaskDistant*}Test.py || die
+}
+
+python_test() {
+ cd tests || die
+ # Automatic discovery does not work
+ "${EPYTHON}" -m unittest_or_fail -v *.py || die "Tests failed with ${EPYTHON}"
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ doman doc/man/man*/*
+
+ mv "${ED}/usr/etc" "${ED}/etc" || die
+}
+
+pkg_postinst() {
+ einfo "Some default system-wide config files have been installed into"
+ einfo "/etc/${PN}"
+}