summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-10 03:44:54 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-10 03:44:54 +0200
commit6b3306070341cc96b5b33557d4cf24c94ce3c954 (patch)
treeeff3b9e821ead154667cbd69c9ea9c8170ee4877 /app-admin
parentdev-python/boto3: Bump to 1.28.23 (diff)
downloadgentoo-6b3306070341cc96b5b33557d4cf24c94ce3c954.tar.gz
gentoo-6b3306070341cc96b5b33557d4cf24c94ce3c954.tar.bz2
gentoo-6b3306070341cc96b5b33557d4cf24c94ce3c954.zip
app-admin/awscli: Bump to 1.29.23
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.29.23.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index b93af00b6e8f..b1fd0a6c3808 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -10,5 +10,6 @@ DIST aws-cli-1.29.19.gh.tar.gz 2500180 BLAKE2B 64bd861ad84157e81ad9d6f2528befb55
DIST aws-cli-1.29.20.gh.tar.gz 2499798 BLAKE2B e9a8d4a8f804132a5c6ea2c5d8ef99f49c09939b0d0492adce5cfdbf0f85d9c6c2010d17d45a3905bff3888c5984c8f5d81e28dafe3ea9b8629f96dda9f1df2b SHA512 14e2dc38f5373c648973d927e549e53bf722c0b4184fb210d732ebb2af37436ede84eb6037e520f5c543b4f90eb00afca8e506fe3aca3e28dd196fd664bc8f0c
DIST aws-cli-1.29.21.gh.tar.gz 2499845 BLAKE2B 4cbc6bb9ba492c4ef3bcd03f43769888c2375a8aaf0a8365547aa00ae02d2fceec09e5d49d7893cbf561b2ef1a30f2f6f7f29bfda8affb8f000d3900d780402a SHA512 af482e8ffbbf0567f00acdeda11d65c845a48f582acd910a630567e14e5d938a7ad2942c3ca2cf75ffdc3f101add9810dedde6418e3a8df7bda8689bec3466aa
DIST aws-cli-1.29.22.gh.tar.gz 2500297 BLAKE2B 7de13b7e8ced5be80a293cbed25505420569283e54ce719958519f3748b6fdc87c11c6b106eeac0afe41c219259cd5aa3231cd2060506c755b5a687d5f04598e SHA512 874574a542261e1095265e0184c2fc82d70bbacefebf4a586960a59c0d69925f842979e9a6fb35fc685723bdd360c8dc838593539c3c0e07e2ab6395d5422c92
+DIST aws-cli-1.29.23.gh.tar.gz 2500975 BLAKE2B 52a49b0c5a436612e26c6a211afe39c88e673fa57323172db120f3e4f0e481d08f7e52162b27ad44e6d23467c0385e66a4735cbe2fe5bd858ebe7f06649e6d77 SHA512 fb95a7fa775c2527bc7fefd6dde6c5d99f1640e6ea5ba7726bb5c292025cd022cc1a03f54734b60cab11a2320d0ce85397bc5fa116c503a2cd9b44821dbe282e
DIST aws-cli-1.29.3.gh.tar.gz 2450427 BLAKE2B 6e240905c8fbb2916334c2de0e9fd851636acfbc050916baf971e2f5e5a1d93d398c77c6a1fe0766f701ad53683e5f41b1bb5519e5ac7b5e8f0a64d37e113c34 SHA512 3446e057abcc956e26b55de85383d0d40c041bcfda0f7e566309d80bbd22d567a474d93ab74461e91bdd7eaff1db9c77813912653c7864bcc851d12d2cea8ee2
DIST aws-cli-1.29.9.gh.tar.gz 2454843 BLAKE2B a4e49923aec2d09d8244e58fe737f1a0528956397050b693892b2d4521d4e41956fc2a11f6e8bc0c88d6ea16ae4f7f85276037a7864c989334109ef090623f99 SHA512 2238c70ccaa8e73cedca9a56e4cda48a62b0b26999c481585769872b42517f2a25d80b94cf9e18961c5fb81c9d8fe44bda9dbf6024e31bbc7409d6ce53f1a915
diff --git a/app-admin/awscli/awscli-1.29.23.ebuild b/app-admin/awscli/awscli-1.29.23.ebuild
new file mode 100644
index 000000000000..62c19f3a63fb
--- /dev/null
+++ b/app-admin/awscli/awscli-1.29.23.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/functional/eks/test_kubeconfig.py::TestKubeconfigLoader::test_load_simple
+ tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_env_only
+ tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_existing
+ tests/unit/customizations/eks/test_kubeconfig.py::TestKubeconfigValidator::test_valid
+ )
+
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)" --forked
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}