summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2024-02-06 07:57:01 +0200
committerViorel Munteanu <ceamac@gentoo.org>2024-02-06 07:57:01 +0200
commit7dcb4f3903ede605a1efd368a63bfbfd19d040e4 (patch)
tree1f06f850bae589c8e79de556305d6b5a1c857acc /app-admin
parentsys-libs/libnvme: fix disable-python value (diff)
downloadgentoo-7dcb4f3903ede605a1efd368a63bfbfd19d040e4.tar.gz
gentoo-7dcb4f3903ede605a1efd368a63bfbfd19d040e4.tar.bz2
gentoo-7dcb4f3903ede605a1efd368a63bfbfd19d040e4.zip
app-admin/linode-cli: add 5.48.2
Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/linode-cli/Manifest1
-rw-r--r--app-admin/linode-cli/linode-cli-5.48.2.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/app-admin/linode-cli/Manifest b/app-admin/linode-cli/Manifest
index 6505c74be302..20208957fc39 100644
--- a/app-admin/linode-cli/Manifest
+++ b/app-admin/linode-cli/Manifest
@@ -1,3 +1,4 @@
DIST linode-cli-5.45.2.tar.gz 126870 BLAKE2B adfb0862159fbd1dc887726a9d40c2534526b9fe7326c6340c52ed928aff5c9960b20a5961ed6aac7e276201e52a254fd6ba5e6aaa80da7d68e95cc0dc949f27 SHA512 9a6697b3306434cc4f59ef695d0b51e33f71b2d1be4d942e369a22328c3cbf78da0efc939f39f8da928ba5fb5bc2bc06a6ee5d0c9a8e0deb78b657738f19501d
DIST linode-cli-5.47.1.tar.gz 128364 BLAKE2B db21cdd9a1bfbe17fb17b8b0e27ca36bb15c7d3b16ddde4dcc59a9ce64cd34d644d3d5d120efb88bb146767cf9b2c3ee820a847a2fcff487a11bc3abd6973870 SHA512 b61ac1e7c97a1395b150227fe822bc2e7199ed15a44c6d93d71bfdbc2f919827e87e89cf41a47b069be06144a849f5ab11c9dd7f38d138f80ce80563f55bf75a
DIST linode-cli-5.48.1.tar.gz 141176 BLAKE2B 8317071e01f76438b9389a0d563830653611004ed6f7fbf0657af1e70d70a79927e460f7063437740b38ad7f5b15788d4cc4e9e01728cbab93944cc0086bc0bf SHA512 2183a3ca9e330af70e41c75e0bceafc0c3a93e28fd7f8e0629c1b223cea7f442a33fe437737c9c9cda59d9cf4eb60f32eb2b81189943a13b206afd9f81b5eed2
+DIST linode-cli-5.48.2.tar.gz 141600 BLAKE2B fadabfb421945809ceba396324ac9930d1fd795bceab4e90023038881fb8ba5af1b19187f414e70b5a86ea7d560202c76669dfe76ba952bcbe958b7213aff241 SHA512 f2d0e3f62ff93fc9906d70b1121e73f98319dd8afc38ddb124d35295dffef085aa75c93d299538499ea71d087de19060fc3f52ab5f6b31ef47f46435f010b0fd
diff --git a/app-admin/linode-cli/linode-cli-5.48.2.ebuild b/app-admin/linode-cli/linode-cli-5.48.2.ebuild
new file mode 100644
index 000000000000..2ce8851657d3
--- /dev/null
+++ b/app-admin/linode-cli/linode-cli-5.48.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+inherit distutils-r1 pypi
+
+DESCRIPTION="Linode Command Line Interface"
+HOMEPAGE="https://github.com/linode/linode-cli https://www.linode.com/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# Tests require network, a linode account and an API key.
+# WARNING: tests will incur costs and will wipe the account.
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/boto3[${PYTHON_USEDEP}]
+ dev-python/linode-metadata[${PYTHON_USEDEP}]
+ dev-python/openapi3[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ <dev-python/urllib3-3[${PYTHON_USEDEP}]
+"