summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-07 07:33:39 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-07 08:39:22 +0100
commit82da46cf8547d21d45a359b0df41954329169d47 (patch)
tree29c139e83c1a932ef2461e3131f604053bef4dae /app-admin
parentdev-python/boto3: Bump to 1.34.36 (diff)
downloadgentoo-82da46cf8547d21d45a359b0df41954329169d47.tar.gz
gentoo-82da46cf8547d21d45a359b0df41954329169d47.tar.bz2
gentoo-82da46cf8547d21d45a359b0df41954329169d47.zip
app-admin/awscli: Bump to 1.32.36
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.32.36.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 8dce300f06a1..4c9def638bc9 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -2,3 +2,4 @@ DIST aws-cli-1.32.23.gh.tar.gz 2627296 BLAKE2B b85f77efb7e7f9fac19fc342bcef44def
DIST aws-cli-1.32.29.gh.tar.gz 2643387 BLAKE2B 0d07a5478c5a51baf743c97aa613611aee9e84d569af1ae62e0adde56229f2973d17490a9ae287a713c2b8e54149674d416c12b5387f87504d3d1c5133a26789 SHA512 221315ab814691dc7cdcdee3fbe702275ad85dde50313249ccd57904d5bdd3266295eed885c7e80228970e04af240dbdfa7f3303c8a84d39633575cd0a579f81
DIST aws-cli-1.32.34.gh.tar.gz 2647696 BLAKE2B e255f5fe68cd9571ea3389f7f9787b95eabd6eab9f9bf196b9e733afecd357e8e68838ae82641c2f41e79595906dda701eaa9f5a109c4a3f86564ec2fb78137b SHA512 9edbde2c2c7aa67d291e3de2046e840b5f90e282e01f8b72412a10ac222e4e916ae384144ddb139b4985d298916507584d60e16cc93df7c927e653423490eb66
DIST aws-cli-1.32.35.gh.tar.gz 2647830 BLAKE2B d2fe6030562088368f387d9eed582125dac5249ae53555d8fa01d5b0b49197a5a03ee7718612f679b4121b2ad44a9c5c6dab86eea2872287674a8b5c032f56b6 SHA512 a123a94f1243c69eb1a7e2763ecd07767f97e33e1e1c3667d42a9e072ec1d8491f792376454d47147f2c191da5d8d7615ab02914a1df8bbeb11a463f6dbc4116
+DIST aws-cli-1.32.36.gh.tar.gz 2647891 BLAKE2B 57c1038cb2052bc3f7b85b3f2b2a7fd701554370dcd6aa9cfa0f2c0d3296b67ca2cf9751457a7181af9f089a710c4deeb155fa6fee3825394dd0ff5957b6ecd8 SHA512 fa5d3dab3e52d92c3891283a7b3ea76d23ab986d2234a6cc52822a95c54f8f2f6130d28f197c58d3c37959ccc3eb657b33500740fca77300f60a7c2214e98d82
diff --git a/app-admin/awscli/awscli-1.32.36.ebuild b/app-admin/awscli/awscli-1.32.36.ebuild
new file mode 100644
index 000000000000..4a677affdbc4
--- /dev/null
+++ b/app-admin/awscli/awscli-1.32.36.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit bash-completion-r1 distutils-r1
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local serial_tests=(
+ tests/functional/ecs/test_execute_command.py::TestExecuteCommand::test_execute_command_success
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_{fails,success}
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_with_new_version_plugin_success
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking_windows
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestNuGetLogin::test_login_nuget_sources_listed_with_backtracking
+ tests/unit/customizations/ecs/test_executecommand_startsession.py::TestExecuteCommand::test_execute_command_success
+ tests/unit/customizations/test_sessionmanager.py
+ tests/unit/test_compat.py::TestIgnoreUserSignals
+ tests/unit/test_help.py
+ tests/unit/test_utils.py::TestIgnoreCtrlC::test_ctrl_c_is_ignored
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ EPYTEST_XDIST= epytest "${serial_tests[@]}"
+
+ local EPYTEST_DESELECT=( "${serial_tests[@]}" )
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit}
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}