summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-09 07:44:49 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-09 09:08:02 +0200
commit8c37d19974f587a27d58c7d413e520eaf3977568 (patch)
tree38e5002e16b53506a2444fa8eae2d921b9056667 /app-admin
parentdev-python/boto3: Bump to 1.18.58 (diff)
downloadgentoo-8c37d19974f587a27d58c7d413e520eaf3977568.tar.gz
gentoo-8c37d19974f587a27d58c7d413e520eaf3977568.tar.bz2
gentoo-8c37d19974f587a27d58c7d413e520eaf3977568.zip
app-admin/awscli: Bump to 1.20.58
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.20.58.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index c8e862957913..a2be4654b410 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -6,3 +6,4 @@ DIST awscli-1.20.54.tar.gz 2082080 BLAKE2B 157e35ab297d18aa9739319801e28fabfbd9f
DIST awscli-1.20.55.tar.gz 2082482 BLAKE2B 5f8d9d84e6993e22ffd6f1e7e46b0afa2aecd12b4c2c18968e0f85d7544aced039a21b2245bfd66393bbb0d240f9b3119da7f745891b04f9156b677f613fbb63 SHA512 5d76c07417a3edcdff490ecdad9469f6f0f3077f4fccba9b6cf8518390df90d49d126e6c924a57333c5b68a97b833cb0bbb72133ddc63fd74893f888eca974a5
DIST awscli-1.20.56.tar.gz 2082836 BLAKE2B e935334dba5aaa77cbd4fe3adb789c33c9fa80832bf4ad7517024787911e377020e8cdc38b0bd87db81571a2da888acd96306198a66748597495460292286938 SHA512 5b3bfebe217c05df70421b29c6a239a76493898717bd5db10ef7001e6c9af1488a52e6e25ab85b5ed725c87402a562ebe6849eb39743681c644143f17fccc3b6
DIST awscli-1.20.57.tar.gz 2083414 BLAKE2B b3d21c0b8ceb0016def4aae9f2485dffd77bdd12a959b6c959d9c10cc3466fad9309a40102409ddf59d372bf95503a6bf87bc454d37400877a7cdc33564c0f45 SHA512 ad5d5a4de8083ce5198a49756da4ef6d630671c49ee0da0c15f06c9af1e92a9c98f2721b06df77adc47ea2b455e80e8aa92238a514039a213acbbf133753b430
+DIST awscli-1.20.58.tar.gz 2083928 BLAKE2B f8b67baa47ddb468395b0ad2029a85f40ea2241d34b00545d5e6ae9fb407eaa95aff48f3dbe59d2aed309167bb9056b0800987937ef53b0884006100b94150db SHA512 a51f530d3c0938544217febc76adc668b71ebedae2080154716fd4e3293cad8e8ce65f32a4b34f1d8069c42a596f94f123b1b043d55349e7910a98126c7bd9bf
diff --git a/app-admin/awscli/awscli-1.20.58.ebuild b/app-admin/awscli/awscli-1.20.58.ebuild
new file mode 100644
index 000000000000..81d5997098c2
--- /dev/null
+++ b/app-admin/awscli/awscli-1.20.58.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="https://pypi.org/project/awscli/"
+#SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/aws/aws-cli/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/aws-cli-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+# botocore is x.(y+1).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 1)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.4.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests --install pytest
+
+python_test() {
+ distutils_install_for_testing
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit}
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}