summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-08-19 12:35:58 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2017-08-19 12:37:55 -0500
commit95fc33666a3b35be508d48302c187d287720bd1a (patch)
tree27181b037903a6ed7d964461045d76dbbf3650c3 /app-admin
parentapp-admin/puppet-agent: 5.1.0 bup (diff)
downloadgentoo-95fc33666a3b35be508d48302c187d287720bd1a.tar.gz
gentoo-95fc33666a3b35be508d48302c187d287720bd1a.tar.bz2
gentoo-95fc33666a3b35be508d48302c187d287720bd1a.zip
app-admin/puppet: 5.1.0 bup
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/puppet/Manifest1
-rw-r--r--app-admin/puppet/puppet-5.1.0.ebuild144
2 files changed, 145 insertions, 0 deletions
diff --git a/app-admin/puppet/Manifest b/app-admin/puppet/Manifest
index 51c1a0993b51..108627c9ab24 100644
--- a/app-admin/puppet/Manifest
+++ b/app-admin/puppet/Manifest
@@ -7,3 +7,4 @@ DIST puppet-4.8.1.tar.gz 2873371 SHA256 8b3ee6b60639e2a2839ad7403fab8f8ecc390a93
DIST puppet-4.9.1.tar.gz 2912770 SHA256 db02cffb8339b349bd1ab2b15899511d3f5d449f0f591038256f0fb862f4c7db SHA512 db2bd324e4f58c583debe417ca233c613c296aa8824520c5373c8da45056ae9d09e54ceecba5c6b7d0250ea7228d6e1b83e5b690b1203de43dca8942c8f24ce2 WHIRLPOOL fd5554d5de319f8534fbada7ae6f4100d6de5a98f6646985e21c250a52a3d415ac31fc46c15c987bd7bcbc688bc8bb4d7dc9d37ebd93ecd183b3bd01d3426687
DIST puppet-5.0.0.tar.gz 2706319 SHA256 09ae5b56ff799ccfd78e3a1999aa27d6f2bf69a7a5ed19bd758cf88c17a004ab SHA512 4423001340623d00a72de16e7b585ce3874019b020b91abd4edb9b9a524bd0d709107bee4dfcdf20b2eaf99e67b3401e2883ea297659ad1debfea8fb33a665bd WHIRLPOOL 66bbb279fb9d646ada78ce28af3d2377abf63ce059b9e61ee15fc0b3b48796ea0f708f5f2c380e5dd986d4469f6a8b73606c61dfc3280aca5913d9c7fffa4f2f
DIST puppet-5.0.1.tar.gz 2715867 SHA256 ff80092c7bfde7198ec2cf776b8d0b8ba1c2c95be927a5cb5edae9f670038c4a SHA512 6038ce27f5144112bed080f0a33d0d866d4aac41b0e49436fb8a5a428ffd4c952b1e8582c4840803f9ebd6619ac0837b7b1413451f5665a9a4e02bb3f24464b3 WHIRLPOOL 6537888f122d4cfa76ec3d8a18086f7c53cbdb96f7e88f84f1910d00a6d90973b44610919863e1f569c75df9e0451f5fd134f83c3aeb1b3a563223658bd28e4f
+DIST puppet-5.1.0.tar.gz 2734018 SHA256 ceb8059704d2e79c1f9147716b596261e1c6c38da3313a2283def777ecf9193c SHA512 07019f40c5b7f18243f13abb899c2ff2ea4b135895ab98c13da3df50f8e720e2759f8eb39e349ff04286da7de504cffea3df8acf9711e8591b25001a2a3f9c15 WHIRLPOOL a5e4e44c68a503307b01729546121a03a0271bc68f8db139e7d52981f9ce9f6db4e24b18a252633794e7de1c7aceb6d833c817a291099081b31190060bb59d50
diff --git a/app-admin/puppet/puppet-5.1.0.ebuild b/app-admin/puppet/puppet-5.1.0.ebuild
new file mode 100644
index 000000000000..42e505f2b7e8
--- /dev/null
+++ b/app-admin/puppet/puppet-5.1.0.ebuild
@@ -0,0 +1,144 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+USE_RUBY="ruby21 ruby22 ruby23"
+# need to get deps up to date for this
+#USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_TASK_DOC="doc:all"
+
+inherit eutils user ruby-fakegem versionator
+
+DESCRIPTION="A system automation and configuration management software."
+HOMEPAGE="http://puppetlabs.com/"
+SRC_URI="http://downloads.puppetlabs.com/puppet/${P}.tar.gz"
+
+LICENSE="Apache-2.0 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE="augeas diff doc emacs ldap rrdtool selinux shadow sqlite vim-syntax"
+RESTRICT="test"
+
+ruby_add_rdepend "
+ dev-ruby/hiera
+ dev-ruby/json:=
+ >=dev-ruby/facter-3.0.0
+ augeas? ( dev-ruby/ruby-augeas )
+ diff? ( dev-ruby/diff-lcs )
+ doc? ( dev-ruby/rdoc )
+ ldap? ( dev-ruby/ruby-ldap )
+ shadow? ( dev-ruby/ruby-shadow )
+ sqlite? ( dev-ruby/sqlite3 )
+ virtual/ruby-ssl
+ dev-ruby/hocon"
+
+ruby_add_bdepend "
+ doc? ( dev-ruby/yard )
+ test? (
+ dev-ruby/mocha
+ dev-ruby/rack
+ dev-ruby/rspec-its
+ )"
+# this should go in the above lists, but isn't because of test deps not being keyworded
+# dev-ruby/rspec-collection_matchers
+
+RDEPEND+=" ${RDEPEND}
+ rrdtool? ( >=net-analyzer/rrdtool-1.2.23[ruby] )
+ selinux? (
+ sys-libs/libselinux[ruby]
+ sec-policy/selinux-puppet
+ )
+ vim-syntax? ( >=app-vim/puppet-syntax-3.0.1 )
+ >=app-portage/eix-0.18.0"
+PDEPEND="emacs? ( >=app-emacs/puppet-mode-0.3-r1 )"
+
+pkg_setup() {
+ enewgroup puppet
+ enewuser puppet -1 -1 /var/lib/puppet puppet
+}
+
+all_ruby_prepare() {
+ # Avoid spec that require unpackaged json-schema.
+ rm spec/lib/matchers/json.rb $( grep -Rl matchers/json spec) || die
+
+ # can't be run within portage.
+ epatch "${FILESDIR}/puppet-fix-tests-4.7.0.patch"
+
+ # fix systemd path
+ epatch "${FILESDIR}/puppet-systemd.patch"
+
+ # Avoid specs that can only run in the puppet.git repository. This
+ # should be narrowed down to the specific specs.
+ rm spec/integration/parser/compiler_spec.rb || die
+
+ # Avoid failing spec that need further investigation.
+ rm spec/unit/module_tool/metadata_spec.rb || die
+}
+
+each_ruby_install() {
+ each_fakegem_install
+# dosym "/usr/$(get_libdir)/ruby/gems/$(ruby_get_version)/gems/${P}" "/usr/$(get_libdir)/ruby/gems/$(ruby_get_version)/gems/${PN}"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ # systemd stuffs
+ insinto /usr/lib/systemd/system
+ doins "${WORKDIR}/all/${P}/ext/systemd/puppet.service"
+
+ # tmpfiles stuff
+ insinto /usr/lib/tmpfiles.d
+ newins "${FILESDIR}/tmpfiles.d" "puppet.conf"
+
+ # openrc init stuff
+ newinitd "${FILESDIR}"/puppet.init-4.x puppet
+ newinitd "${FILESDIR}"/puppetmaster.init-4.x puppetmaster
+ newconfd "${FILESDIR}"/puppetmaster.confd puppetmaster
+
+ keepdir /etc/puppetlabs/puppet/ssl
+
+ keepdir /var/lib/puppet/facts
+ keepdir /var/lib/puppet/files
+ fowners -R puppet:puppet /var/lib/puppet
+
+ fperms 0750 /var/lib/puppet
+
+ fperms 0750 /etc/puppetlabs
+ fperms 0750 /etc/puppetlabs/puppet
+ fperms 0750 /etc/puppetlabs/puppet/ssl
+ fowners -R :puppet /etc/puppetlabs
+ fowners -R :puppet /var/lib/puppet
+
+ if use ldap ; then
+ insinto /etc/openldap/schema; doins ext/ldap/puppet.schema
+ fi
+
+ # ext and examples files
+ for f in $(find ext examples -type f) ; do
+ docinto "$(dirname ${f})"; dodoc "${f}"
+ done
+}
+
+pkg_postinst() {
+ elog
+ elog "Please, *don't* include the --ask option in EMERGE_EXTRA_OPTS as this could"
+ elog "cause puppet to hang while installing packages."
+ elog
+ elog "Portage Puppet module with Gentoo-specific resources:"
+ elog "http://forge.puppetlabs.com/gentoo/portage"
+ elog
+
+ for v in ${REPLACING_VERSIONS}; do
+ if [ "$(get_major_version $v)" = "4" ]; then
+ elog
+ elog "Please see the following url for the release notes for puppet-5"
+ elog "https://docs.puppet.com/puppet/5.0/release_notes.html#if-youre-upgrading-from-puppet-4x"
+ elog
+ fi
+ done
+}