summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-30 07:25:25 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-30 08:08:10 +0100
commit96abad082e95b051f70505eff5e624ce4b45c970 (patch)
treea05d766817d173bcba0c00fad82a57a778027083 /app-admin
parentdev-python/boto3: Bump to 1.26.40 (diff)
downloadgentoo-96abad082e95b051f70505eff5e624ce4b45c970.tar.gz
gentoo-96abad082e95b051f70505eff5e624ce4b45c970.tar.bz2
gentoo-96abad082e95b051f70505eff5e624ce4b45c970.zip
app-admin/awscli: Bump to 1.27.40
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.27.40.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 64112574b748..171534ed91f1 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -8,3 +8,4 @@ DIST aws-cli-1.27.36.gh.tar.gz 2332507 BLAKE2B 215356ff11388b5ecc3c71cf6a33b7a9e
DIST aws-cli-1.27.37.gh.tar.gz 2332965 BLAKE2B 9c855f02bc63f64e3d9bb706139305a6b3dad523bd2563c9d6ca4b39b340ea242bf8e85ee369ca92d327073d9eb0a4f0e3da59b4016eaa2ce4f48aa083cc9c51 SHA512 3f53d4c15244019d1773486e192bda4ca69a9afe8e32f2fcfd9f56affc3bcc84e15a1aa4b27563f404bc5471b868eabc74c8fb3884deb0372d61a038e101202a
DIST aws-cli-1.27.38.gh.tar.gz 2333077 BLAKE2B 721ebce0e39b90b9ac18552046b62a5263ebec3d6abbe798ccbf28a9ab63dbf17699a8d2eab2d7b620717c56b8b9ff1d8b3316940a21925b3a58bfcbbc65e03b SHA512 3e529a64542fc14f179bdb5cea3b275f1a2d0d9d4df63c118f5d18067a5a69d1c7677fd8ddbb18d45cef8ce5be880fa9f2a2546d8e57475e1f35a2e0ced7b8ec
DIST aws-cli-1.27.39.gh.tar.gz 2333488 BLAKE2B a50ea5601f36646fbc0e6dfd6053ff09cfee9476fe0923f8b969e639f7c7af4c52e9482be9eae9b2b48cc905263b80117d9b49ae3e6a9a1b361f6929c6640b87 SHA512 b6f7fba1ccf4a9828af63222d422a4b83c97ed848bbae899816c1323caa450f2114527d9d1acc4c14ed54fe3aa92cae10dfd4df62e1e98ab38dddc856b0df677
+DIST aws-cli-1.27.40.gh.tar.gz 2333845 BLAKE2B d7ec9f54b9ccb46ac3248a839f2691a53fe16b1ff35e9068bce069a71570c9db64f092fa91ca237be61b8b60cace8aa2c699023dc49d1e5258d95bd676d031c2 SHA512 62e6cebc6a893558d2eb5a6ee462f8b632aa733b349ff3d71eb49c940cfd7ea66d29bf9109bf0150d3bd18745bf36f54d0eb499edd7087fdfc824c74ce4929cb
diff --git a/app-admin/awscli/awscli-1.27.40.ebuild b/app-admin/awscli/awscli-1.27.40.ebuild
new file mode 100644
index 000000000000..caea725bbca7
--- /dev/null
+++ b/app-admin/awscli/awscli-1.27.40.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/functional/eks/test_kubeconfig.py::TestKubeconfigLoader::test_load_simple
+ tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_env_only
+ tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_existing
+ tests/unit/customizations/eks/test_kubeconfig.py::TestKubeconfigValidator::test_valid
+ )
+
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)" --forked
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}