summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-09-21 13:14:12 +0100
committerMarek Szuba <marecki@gentoo.org>2022-09-21 13:18:20 +0100
commitb4a775e81cbd44186442d0a755014274ceaa3d17 (patch)
tree5f1534731046f693bfefdf254a81fc2845419592 /app-admin
parentmedia-libs/openh264: revbump 2.3.1 and update subslot (diff)
downloadgentoo-b4a775e81cbd44186442d0a755014274ceaa3d17.tar.gz
gentoo-b4a775e81cbd44186442d0a755014274ceaa3d17.tar.bz2
gentoo-b4a775e81cbd44186442d0a755014274ceaa3d17.zip
app-admin/ansible-molecule: add 4.0.1
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/ansible-molecule/Manifest1
-rw-r--r--app-admin/ansible-molecule/ansible-molecule-4.0.1.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/app-admin/ansible-molecule/Manifest b/app-admin/ansible-molecule/Manifest
index 700d4ea41538..838c6e6b4a11 100644
--- a/app-admin/ansible-molecule/Manifest
+++ b/app-admin/ansible-molecule/Manifest
@@ -1 +1,2 @@
+DIST ansible-molecule-4.0.1.tar.gz 301517 BLAKE2B 73cf7a2257368c737b9003236bf77011de167dd6f692166702e7948c136202b33bcce1c70893b61a95af9baa90e7b5266a5fa889e3bba0e5a8c9c1e6f48fec9a SHA512 7515e07bf791d5586e1f5fb4ce0d2f731c94c8268c589155340b2bdc1528534084870e66e492b2d883f9e9764293c93799a4c75478523502a2f37ad0642a472d
DIST molecule-3.5.2.tar.gz 290964 BLAKE2B b6c6bb8ecdb4230d23161e25fa003c8979f48fc1705bfba7d14204fbaa3e9c235a71db0c4ccbab5c4328ddb8a0725d3c2ba7cb4b624afda21c6453c8be824f3e SHA512 04a7d1f7e7e098c0ada71d8dc9a3e3a94320033942d8ee03f2c51ec185405d2ee13fcb44000a4942ec66923f0426717ab7e2c3a785ddda7a23515096474dc3c3
diff --git a/app-admin/ansible-molecule/ansible-molecule-4.0.1.ebuild b/app-admin/ansible-molecule/ansible-molecule-4.0.1.ebuild
new file mode 100644
index 000000000000..3e827f95a347
--- /dev/null
+++ b/app-admin/ansible-molecule/ansible-molecule-4.0.1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 optfeature
+
+MY_PN="${PN#ansible-}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A toolkit designed to aid in the development and testing of Ansible roles"
+HOMEPAGE="https://pypi.org/project/molecule/ https://github.com/ansible-community/molecule/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+IUSE="selinux"
+
+RDEPEND="$(python_gen_cond_dep '
+ >=dev-python/ansible-compat-2.2.0[${PYTHON_USEDEP}]
+ dev-python/cerberus[${PYTHON_USEDEP}]
+ >=dev-python/click-8.0[${PYTHON_USEDEP}]
+ >=dev-python/click-help-colors-0.9[${PYTHON_USEDEP}]
+ >=dev-python/enrich-1.2.7[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.11.3[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.9.1[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ <dev-python/pluggy-2.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ >=dev-python/rich-9.5.1[${PYTHON_USEDEP}]
+ >=dev-util/cookiecutter-1.7.3[${PYTHON_USEDEP}]
+ selinux? ( sys-libs/libselinux[python,${PYTHON_USEDEP}] )
+')"
+BDEPEND="$(python_gen_cond_dep '
+ >=dev-python/setuptools_scm-3.5.0[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm_git_archive-1.1[${PYTHON_USEDEP}]
+ doc? (
+ app-admin/ansible-core[${PYTHON_USEDEP}]
+ dev-python/ansible-pygments[${PYTHON_USEDEP}]
+ >=dev-python/simplejson-3.17.2[${PYTHON_USEDEP}]
+ )
+ test? (
+ >=dev-python/ansi2html-1.6.0[${PYTHON_USEDEP}]
+ dev-python/filelock[${PYTHON_USEDEP}]
+ <dev-python/pexpect-5[${PYTHON_USEDEP}]
+ >=dev-python/pytest-html-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-3.3.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-plus-0.2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-testinfra-6.1.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-2.1.0[${PYTHON_USEDEP}]
+ dev-util/yamllint
+ )
+')"
+
+S="${WORKDIR}"/${MY_P}
+
+# test_role.py doesn't play nicely with FEATURES=usersandbox. As for test_command.py:
+# - quite a few of these tests use the network;
+# - test_command_dependency[shell] only works if Molecule has previously been installed;
+# - tests involving creation of a new scenario fail on ansible-lint errors, even though
+# a config file is deployed which should skip expected issues.
+EPYTEST_DESELECT=(
+ src/molecule/test/functional/test_command.py
+ src/molecule/test/unit/command/init/test_role.py
+)
+
+distutils_enable_sphinx docs '>=dev-python/sphinx-notfound-page-0.7.1' '<dev-python/sphinx_ansible_theme-0.10.0'
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature_header "Some optional packages commonly used in Molecule scenarios:"
+ optfeature "checking playbooks for practices and behaviour that can be improved" app-admin/ansible-lint
+}