summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-21 07:17:45 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-21 08:06:44 +0200
commitb6a2d2cb65389565d7b588f11f1e681bad9694d7 (patch)
tree822883ab2c3347f3d53446a2ac39070d7f15069f /app-admin
parentdev-python/boto3: Bump to 1.28.8 (diff)
downloadgentoo-b6a2d2cb65389565d7b588f11f1e681bad9694d7.tar.gz
gentoo-b6a2d2cb65389565d7b588f11f1e681bad9694d7.tar.bz2
gentoo-b6a2d2cb65389565d7b588f11f1e681bad9694d7.zip
app-admin/awscli: Bump to 1.29.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.29.8.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index f6310d17e65f..a778016fc115 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -13,3 +13,4 @@ DIST aws-cli-1.29.3.gh.tar.gz 2450427 BLAKE2B 6e240905c8fbb2916334c2de0e9fd85163
DIST aws-cli-1.29.4.gh.tar.gz 2451404 BLAKE2B cafdfd6431b1b6720a89e2f8f5c1fe2a356c482ba57fd8c201dc9c4ca407700b529a3d4d101c3a1b7e33bb220f22d04da1bc9ebd14be00fe7faec8a834dad60b SHA512 0fe222ffe6298e7e9216089f553e4ef6e50111fcc11b9906871220624a5ea2828c47f4ca4a8251068a749ffd042a140529d9af487db169f46740b93501f00b9d
DIST aws-cli-1.29.5.gh.tar.gz 2451819 BLAKE2B ab468b3d2114a156163063c760e0274f7a606d45e51e7b498304ecb7a53dbd098a7d6930c80604625353512100a2c7c321842f8dd10072f451e68ab55ee4d8e2 SHA512 a5d6dacc5831198a0e32e80d86c69c6d25ed83c6d7102aae964c4ddb9f12963b227bfe7652d6a4f54875fc622203536b5c200fe143de79ff6c9c78dd6ecbc11e
DIST aws-cli-1.29.6.gh.tar.gz 2453838 BLAKE2B ec509401c8a86f91b2af378d70c8a8fef7e30152a4ddfa3f5595a27f07a40dd14696ff96fa3e8d5d0533a51581cd10d2e108838378e388a7e0ce869938574bab SHA512 48ceb209b67516c3c5711ad864658cc16dba73bb9f665347b67796c3c148aefb0c899c25f9f13089dc93c8506a76f16b6f23afeaba1105b2a6d9e8139c2164a1
+DIST aws-cli-1.29.8.gh.tar.gz 2454692 BLAKE2B d49d4ca27c3fd195d9a695a550f3a2693f8d79f338b6bddafa13c394e51afb4e1253c96f966a26b20a655a7808a297bd1e5b8c15188d99d084db3788153bc260 SHA512 08bffd31c88eef7dd4afe96c8c3798c9a3f1cd758974bf22682cedb5f31d00a20b2b8a6ed8a971c086a1fa7fca7884b625c3e1b9621e3fcdc32d2ee267f8cce7
diff --git a/app-admin/awscli/awscli-1.29.8.ebuild b/app-admin/awscli/awscli-1.29.8.ebuild
new file mode 100644
index 000000000000..62c19f3a63fb
--- /dev/null
+++ b/app-admin/awscli/awscli-1.29.8.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/functional/eks/test_kubeconfig.py::TestKubeconfigLoader::test_load_simple
+ tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_env_only
+ tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_existing
+ tests/unit/customizations/eks/test_kubeconfig.py::TestKubeconfigValidator::test_valid
+ )
+
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)" --forked
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}