summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2022-09-21 05:57:21 -0700
committerZac Medico <zmedico@gentoo.org>2022-09-21 05:57:27 -0700
commitb85fd58a10f811f1152c29f69c522bc58098f390 (patch)
treeb2f4e79729c5ea5069a4bb26eeeb7fbad8bab12e /app-admin
parentapp-admin/consul: stabilize 1.12.5 for amd64 (diff)
downloadgentoo-b85fd58a10f811f1152c29f69c522bc58098f390.tar.gz
gentoo-b85fd58a10f811f1152c29f69c522bc58098f390.tar.bz2
gentoo-b85fd58a10f811f1152c29f69c522bc58098f390.zip
app-admin/consul: drop 1.9.17
Bug: https://bugs.gentoo.org/872086 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/consul/Manifest2
-rw-r--r--app-admin/consul/consul-1.9.17.ebuild56
2 files changed, 0 insertions, 58 deletions
diff --git a/app-admin/consul/Manifest b/app-admin/consul/Manifest
index 91649ae09ae8..fb564830e2ca 100644
--- a/app-admin/consul/Manifest
+++ b/app-admin/consul/Manifest
@@ -2,5 +2,3 @@ DIST consul-1.12.5-deps.tar.xz 289550768 BLAKE2B d64d074987dd8abaed5defdfbcab1ff
DIST consul-1.12.5.tar.gz 25159461 BLAKE2B 4e2bdffd77d032037c6999bee0e2ba4ac6c83daee422097f7cec37c74375419336ec50b19abf9b17db9375a9ee69894ad6577499c137945f7f0557d38d6aa4dc SHA512 df735447dae074ac84dc9dbf5bf2e6d907152d233841137fc4ba632bad19b6db49a60cb79473e6432f76c99ac3c1e287be00416a6553eb3acef8b2fcc4c5dcda
DIST consul-1.13.2-deps.tar.xz 252165800 BLAKE2B b954d36ecd06c2aca46eab6680fb31c709f5d05b6645a7d5b042cdd98ae088a1d38fda6e801eede95b32d4c690f59e05161d8a70de0831d8ba47dfa8c529d32c SHA512 4468a11d53cdb9ab70b9286f5b168681d6805401fbdad0f79d02a0a98e869e0c52c098ab90c4ea3291811876444582057efe72c1972b9bb6cbfd13dfda82453b
DIST consul-1.13.2.tar.gz 25412424 BLAKE2B db6b5f86ef73d1273f2657e6d36640f6bf9252a215f914ec4fc7451cce1e3659725fecc1254401223ead034834443df18eaf54155db466e160bc70101944a8cc SHA512 2af6dd62b178aee975a05efd5c5c3b1d763b64226b6e5ff66060ff31e0b7deaba1603bd5fb4507ff48158acb087f1e4190b6b1961cef6a8809aac6a0473d85f9
-DIST consul-1.9.17-deps.tar.xz 214799320 BLAKE2B c9fe5511156d50d4155ed6050186af894b7efc29e2f311ff542f79d298769b2dc55ee1bba12ca5ba5b81eddb6959a1d7a5e55aeb533827d5e924d3a72853a418 SHA512 be9f417e721372b8eaffe8b908f1ca1d1299c897f032cfb8b7ea8b62f7c2689011c5079a450fb5eed2e4e5454f0ad6a5e3859c91bd67166193334d100968f093
-DIST consul-1.9.17.tar.gz 29480703 BLAKE2B c233eab63ea515f886234395100e47910c1acdefa0b29af5bbc96d6c078dae41e0cd4150e1f6f17daac972b3e66d3abe43b594a0c37bff790e43f0f3c0a20da2 SHA512 c859fbede7294884befd0c70469febed5a4269b21cb351f8619d13e3b29f9b8bdd8d18e9611ef34908fc54bd38f2fd0bbc6e96d4e08ab23da952c3db537fb92c
diff --git a/app-admin/consul/consul-1.9.17.ebuild b/app-admin/consul/consul-1.9.17.ebuild
deleted file mode 100644
index 79da67e99b66..000000000000
--- a/app-admin/consul/consul-1.9.17.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit go-module systemd
-
-DESCRIPTION="A tool for service discovery, monitoring and configuration"
-HOMEPAGE="https://www.consul.io"
-
-SRC_URI="https://github.com/hashicorp/consul/archive/v${PV}.tar.gz -> ${P}.tar.gz
- https://dev.gentoo.org/~zmedico/dist/${P}-deps.tar.xz"
-
-LICENSE="MPL-2.0 Apache-2.0 BSD BSD-2 CC0-1.0 ISC MIT"
-RESTRICT+=" test"
-SLOT="0"
-KEYWORDS="amd64"
-
-BDEPEND="dev-go/gox"
-COMMON_DEPEND="
- acct-group/consul
- acct-user/consul"
- DEPEND="${COMMON_DEPEND}"
- RDEPEND="${COMMON_DEPEND}"
-
-src_compile() {
- local git_commit
- git_commit=$(grep '^[[:space:]]*gitCommit[[:space:]]' vendor/k8s.io/client-go/pkg/version/base.go)
- git_commit=${git_commit#*\"}
- git_commit=${git_commit%\"*}
- [[ ${git_commit} ]] || die "failed to determine gitCommit"
-
- # The dev target sets causes build.sh to set appropriate XC_OS
- # and XC_ARCH, and skips generation of an unused zip file,
- # avoiding a dependency on app-arch/zip.
- GIT_DESCRIBE="v${PV}" \
- GIT_DIRTY="" \
- GIT_COMMIT="${git_commit}" \
- emake dev-build
-}
-
-src_install() {
- dobin bin/consul
-
- keepdir /etc/consul.d
- insinto /etc/consul.d
- doins "${FILESDIR}/"*.json.example
-
- keepdir /var/log/consul
- fowners consul:consul /var/log/consul
-
- newinitd "${FILESDIR}/consul.initd" "${PN}"
- newconfd "${FILESDIR}/consul.confd" "${PN}"
- insinto /etc/logrotate.d
- newins "${FILESDIR}/${PN}.logrotated" "${PN}"
- systemd_dounit "${FILESDIR}/consul.service"
-}