summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2021-01-19 11:04:26 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2021-01-19 11:14:06 -0600
commitbf853e96d1599b17d0e096622b507756f29b8add (patch)
tree49d322cd270616e99de7bd351c59a1e95f579b51 /app-admin
parentapp-admin/ansible-base: 2.10.5 bump (diff)
downloadgentoo-bf853e96d1599b17d0e096622b507756f29b8add.tar.gz
gentoo-bf853e96d1599b17d0e096622b507756f29b8add.tar.bz2
gentoo-bf853e96d1599b17d0e096622b507756f29b8add.zip
app-admin/ansible: 2.10.5 bump
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/ansible/Manifest1
-rw-r--r--app-admin/ansible/ansible-2.10.5.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/app-admin/ansible/Manifest b/app-admin/ansible/Manifest
index fd15caffe385..43d6ff95ccaf 100644
--- a/app-admin/ansible/Manifest
+++ b/app-admin/ansible/Manifest
@@ -1 +1,2 @@
DIST ansible-2.10.4.tar.gz 28622006 BLAKE2B 94551986f5e8ef54dd4f806a264f8373b19564f74b32bfc6d852d49b7b9ff1030ad3c2fdda2f16bc78c0dae5e07cc750a3992bca23fd9bff0f2466716ac32374 SHA512 da9517ad1f478eb8ccab3bad15f3f6ca4d6151798b5aab6db261c4b19a0ac023db1e294745a06748788820ece8980bf1c2c6274314fa0a2943b76c0658383b72
+DIST ansible-2.10.5.tar.gz 29123326 BLAKE2B a63ba7d26d2bf49f8367c48962ad77461994601b073986342ce090f7ec16a2c4d23e9176f9463adb558996ad33a5b6e27bf829983e648f2b9b3d9992b7678f01 SHA512 9eca87e0a98e2641112ac3c4fff07d624afa3db9655ba88d3ac5faa76464f7e89f6a64fe0613582c6e5528c2c0408fe1ee237f4c69353bdfcd73b264444fe3dc
diff --git a/app-admin/ansible/ansible-2.10.5.ebuild b/app-admin/ansible/ansible-2.10.5.ebuild
new file mode 100644
index 000000000000..3d022874c45f
--- /dev/null
+++ b/app-admin/ansible/ansible-2.10.5.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Model-driven deployment, config management, and command execution framework"
+HOMEPAGE="https://ansible.com/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ansible/ansible.git"
+ EGIT_BRANCH="devel"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~x64-macos"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="test"
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/netaddr[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ net-misc/sshpass
+ virtual/ssh
+ app-admin/ansible-base
+"
+DEPEND="
+ >=dev-python/packaging-16.6[${PYTHON_USEDEP}]
+ app-admin/ansible-base
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ dev-python/passlib[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )"
+
+python_compile() {
+ export ANSIBLE_SKIP_CONFLICT_CHECK=1
+ distutils-r1_python_compile
+}
+
+python_test() {
+ nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
+}