summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-06-23 23:55:26 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-06-23 23:57:41 +0200
commitc05d729df59a9aae9ba3135488b48a914da873ec (patch)
tree87e980da871b5824a62d446352ab142aeab5002f /app-admin
parentdev-libs/caliper: use HTTPs (diff)
downloadgentoo-c05d729df59a9aae9ba3135488b48a914da873ec.tar.gz
gentoo-c05d729df59a9aae9ba3135488b48a914da873ec.tar.bz2
gentoo-c05d729df59a9aae9ba3135488b48a914da873ec.zip
app-admin/entr: version bump.
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/entr/Manifest1
-rw-r--r--app-admin/entr/entr-4.1.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/app-admin/entr/Manifest b/app-admin/entr/Manifest
index 56b6e02a8549..85d5941fa910 100644
--- a/app-admin/entr/Manifest
+++ b/app-admin/entr/Manifest
@@ -1 +1,2 @@
DIST entr-4.0.tar.gz 24758 BLAKE2B 6d57cb93d55bb362b8e771745c9333a5a5eaa156f36a7c9e7318d94f0056fc98b2071bcea7fd33b68ac1dc1d5332fc849e0ea89bc2582196acd51e1490fce96e SHA512 d803c27441448374a866636e0e592a8395488e162e2e8c031aafec3457d10041dc52e10d06cc1e209cd86f69ca021171ef105056206b9afe603a89958eef2707
+DIST entr-4.1.tar.gz 25265 BLAKE2B e90a50e7ac0917441db872fcc3b228bd2d16a77a7178810d004cb23510644843dbee1b9b47aedbe7b6b696501f994201f4eab404c6de950013c0b81b042382b0 SHA512 0a80aa9caa97f2603e43957b716bf5b5746cea8bfb2f2cc884aab8c97a34341d6223035fbb5d4bf86234ea1c9314c077cec9d59ba442a2730fcbd7151425a459
diff --git a/app-admin/entr/entr-4.1.ebuild b/app-admin/entr/entr-4.1.ebuild
new file mode 100644
index 000000000000..829cf311603a
--- /dev/null
+++ b/app-admin/entr/entr-4.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs vcs-snapshot
+
+DESCRIPTION="Run arbitrary commands when files change"
+HOMEPAGE="http://entrproject.org"
+SRC_URI="http://entrproject.org/code/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-fbsd"
+IUSE="test"
+
+src_configure() {
+ sh configure || die
+ sed -i -e 's#\(^PREFIX \).*#\1\?= /usr#' Makefile.bsd || die
+}
+
+src_compile() {
+ export CC=$(tc-getCC)
+ default
+}
+
+src_test() {
+ export CC=$(tc-getCC)
+ default
+}