summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2018-12-12 15:11:32 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2018-12-12 15:17:31 +0100
commitc72323ca3a008da8a575f6417b38c5a2ac8cade5 (patch)
tree9ea195eb3a2e2fbd9c54b981612899c89c30dfe4 /app-admin
parentapp-admin/packagekit-base: 1.1.7-r2 → 1.1.12 (diff)
downloadgentoo-c72323ca3a008da8a575f6417b38c5a2ac8cade5.tar.gz
gentoo-c72323ca3a008da8a575f6417b38c5a2ac8cade5.tar.bz2
gentoo-c72323ca3a008da8a575f6417b38c5a2ac8cade5.zip
app-admin/packagekit-gtk: 1.1.7 → 1.1.12
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Gilles Dartiguelongue <eva@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/packagekit-gtk/Manifest1
-rw-r--r--app-admin/packagekit-gtk/packagekit-gtk-1.1.12.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/app-admin/packagekit-gtk/Manifest b/app-admin/packagekit-gtk/Manifest
index f4cb2740e6b1..f6a175783815 100644
--- a/app-admin/packagekit-gtk/Manifest
+++ b/app-admin/packagekit-gtk/Manifest
@@ -1 +1,2 @@
+DIST PackageKit-1.1.12.tar.xz 1439024 BLAKE2B 458cb7a9a47941214ec58846fb840f852851555dbd94ed5113745f9e375cd28edaa8475db30fb889b1722ea01bce5200a5ea7a5f52e45b424703228bff59d689 SHA512 a7428416ae85df0c8e7dbe017396921e9214612c8eb7c91020523457d0feaff86ad50d595f702d255e4091364cb10b8d9506b603b9d0e449c39fced07180840b
DIST PackageKit-1.1.7.tar.xz 1431648 BLAKE2B 0cc64e7ac38d6641a1fbd98ffad2e7920eb7b3c86ea36d3ad036541886191c38deeeb7241f81ec3d29f8268b1c84ec500511895312c29c706403607215117d5e SHA512 0d0277e24feb63e94aeb5fec2c4306ccdf5935c2f62d5eef3be8db9f534eb302eff09ea0e020db48b2dd0af9ba6b31f7960d661d1040774dccf650ebf04c4f83
diff --git a/app-admin/packagekit-gtk/packagekit-gtk-1.1.12.ebuild b/app-admin/packagekit-gtk/packagekit-gtk-1.1.12.ebuild
new file mode 100644
index 000000000000..30edc446954c
--- /dev/null
+++ b/app-admin/packagekit-gtk/packagekit-gtk-1.1.12.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit xdg
+
+MY_PN="PackageKit"
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Gtk3 PackageKit backend library"
+HOMEPAGE="https://www.freedesktop.org/software/PackageKit/"
+SRC_URI="https://www.freedesktop.org/software/${MY_PN}/releases/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/glib-2.54:2
+ media-libs/fontconfig
+ >=x11-libs/gtk+-2:2
+ >=x11-libs/gtk+-3:3
+ x11-libs/pango
+ ~app-admin/packagekit-base-${PV}[introspection]
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ econf \
+ --disable-bash-completion \
+ --disable-command-not-found \
+ --disable-cron \
+ --disable-gstreamer-plugin \
+ --disable-gtk-doc \
+ --disable-local \
+ --disable-man-pages \
+ --disable-static \
+ --disable-systemd \
+ --disable-vala \
+ --enable-dummy \
+ --enable-gtk-module \
+ --enable-introspection=yes \
+ --localstatedir=/var
+}
+
+src_compile() {
+ emake -C contrib/gtk-module
+}
+
+src_install() {
+ emake -C contrib/gtk-module DESTDIR="${D}" install
+ find "${D}" -name '*.la' -delete || die
+}