summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2022-08-19 09:48:21 +0200
committerAgostino Sarubbo <ago@gentoo.org>2022-08-19 09:48:21 +0200
commitcbcec0a193ea31fcbab1d3869b3eaeb3b946183a (patch)
treeeac46465f034cc9da275060880961e4fbb4133cc /app-admin
parentdev-python/fonttools: Stabilize 4.34.4 arm, #865775 (diff)
downloadgentoo-cbcec0a193ea31fcbab1d3869b3eaeb3b946183a.tar.gz
gentoo-cbcec0a193ea31fcbab1d3869b3eaeb3b946183a.tar.bz2
gentoo-cbcec0a193ea31fcbab1d3869b3eaeb3b946183a.zip
app-admin/exo: version bump to 1.59.0
Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/exo/Manifest1
-rw-r--r--app-admin/exo/exo-1.59.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/app-admin/exo/Manifest b/app-admin/exo/Manifest
index ed31da3e00a5..7cd149725442 100644
--- a/app-admin/exo/Manifest
+++ b/app-admin/exo/Manifest
@@ -1 +1,2 @@
DIST exo-1.58.0.tar.gz 5609630 BLAKE2B 266820bd6e51aeaf1bde21b3ecea42e5e7242ffd8b96c60b73316ab938d07764e14e387271f24bb1e71c0692eea11a97deb45e76dfc66a5db82b46a60362bf8a SHA512 5032549d98f9eb9e411387667fe64a75b7ff4f5d830047ebae1cfada2b684fa108e5b945472347d3297f45ef0b2b87baf38750f8f9814cc60af6d08584fce0a3
+DIST exo-1.59.0.tar.gz 5614442 BLAKE2B 89e7d50e33b7883b697c168d31e376f240873f416045e00fc7918335b9fff497c809b4a6f9301e6f5e633586f59694e73b50a92fea1c16475df379fab9ee7abb SHA512 06789bbb845a06f0c2b185471989f4fffcaba8350c1d6b5b6398fe0dfbb6a2c2729aee8b464328ed95ba0b028de7c238a6343a132d40c57c0c9a7ed06695d4fe
diff --git a/app-admin/exo/exo-1.59.0.ebuild b/app-admin/exo/exo-1.59.0.ebuild
new file mode 100644
index 000000000000..6149acedfa18
--- /dev/null
+++ b/app-admin/exo/exo-1.59.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Command-line tool for everything at Exoscale: compute, storage, dns"
+HOMEPAGE="https://github.com/exoscale/cli"
+SRC_URI="https://github.com/exoscale/cli/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE=""
+DEPEND="dev-lang/go:="
+RESTRICT="strip"
+QA_FLAGS_IGNORED=".*"
+
+S="${WORKDIR}/cli-${PV}"
+
+src_compile() {
+ go build -mod vendor -o ${PN} || die "build failed"
+}
+
+src_test() {
+ # run at least 'exo version' for test
+ ./exo version > /dev/null 2>&1
+ if [[ $? -ne 0 ]]
+ then
+ die "Test failed"
+ fi
+}
+
+src_install() {
+ dobin ${PN}
+}