summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2021-07-24 15:20:11 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2021-07-24 15:26:06 -0500
commitd078084e0e317ebacbf7f19766bfb3cf584020a6 (patch)
treeb88d6616c6363d65f1d7e4a67fcc227432d7232b /app-admin
parentgui-wm/sway: 1.6.1 stable amd64/arm64/x86 (diff)
downloadgentoo-d078084e0e317ebacbf7f19766bfb3cf584020a6.tar.gz
gentoo-d078084e0e317ebacbf7f19766bfb3cf584020a6.tar.bz2
gentoo-d078084e0e317ebacbf7f19766bfb3cf584020a6.zip
app-admin/puppet: 7.9.0 bump
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/puppet/Manifest1
-rw-r--r--app-admin/puppet/puppet-7.9.0.ebuild132
2 files changed, 133 insertions, 0 deletions
diff --git a/app-admin/puppet/Manifest b/app-admin/puppet/Manifest
index 391fecaf6bf6..307da3982c6a 100644
--- a/app-admin/puppet/Manifest
+++ b/app-admin/puppet/Manifest
@@ -1,2 +1,3 @@
DIST puppet-5.5.22.tar.gz 2998132 BLAKE2B 8662c89190d0904fe44ffeca1cf9a9ddca40d57ba6fb2d1e644ca353ceb55b1ca3a91416f1eef2975233c9c4498784e7d7280c111ea0cc070870cadc69341d99 SHA512 5332b084a63bdf244672cc4751022c84a1cc50d3f394a13bdcbccf7fcf4ebea67953e88957f23046608bf25e9182548449be824c18289cb2bf1e3ed29b40dc58
DIST puppet-7.8.0.tar.gz 2893281 BLAKE2B cef1d56048a72ffa18c9fe2917e4f616dd4d778eddc91c88becf06a418471af1e2cf1688aa05ad3e71f24d5bb1923eaf35b8a1419ed05a72b299af970d1427e6 SHA512 189fabe199afefc77951ee3f2bf20c749f6efe290cc3a76f5ba58892c80cc76082b1ce77c23bca87f57f62816410bc5536e4206806fe31517915c72046ace08d
+DIST puppet-7.9.0.tar.gz 2899891 BLAKE2B 06f675fc9eaac4ddfa7957847abe33928f0779f3c18dbf339067525ec69b6b87d274294a1133ec8332fbbed6111b568c63478493f3de467c63e2948bcf446b71 SHA512 6329d89530d2cb008e28116de655024e9bf944b3f41d086e0e47c41c74af3da51c283a912ac966cf7bac52f86e54304df6cf31477a5663cae09fb4d18f958cf2
diff --git a/app-admin/puppet/puppet-7.9.0.ebuild b/app-admin/puppet/puppet-7.9.0.ebuild
new file mode 100644
index 000000000000..125aa53e82ce
--- /dev/null
+++ b/app-admin/puppet/puppet-7.9.0.ebuild
@@ -0,0 +1,132 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_TASK_DOC="doc:all"
+RUBY_FAKEGEM_EXTRAINSTALL="locales"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A system automation and configuration management software."
+HOMEPAGE="https://puppet.com/"
+SRC_URI="http://downloads.puppetlabs.com/puppet/${P}.tar.gz"
+
+LICENSE="Apache-2.0 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE="augeas diff doc emacs ldap rrdtool selinux shadow sqlite vim-syntax"
+RESTRICT="test"
+
+ruby_add_rdepend "
+ dev-ruby/hiera
+ dev-ruby/json:=
+ dev-ruby/semantic_puppet
+ >=dev-ruby/facter-3.0.0
+ dev-ruby/concurrent-ruby
+ augeas? ( dev-ruby/ruby-augeas )
+ diff? ( dev-ruby/diff-lcs )
+ doc? ( dev-ruby/rdoc )
+ ldap? ( dev-ruby/ruby-ldap )
+ shadow? ( dev-ruby/ruby-shadow )
+ sqlite? ( dev-ruby/sqlite3 )
+ virtual/ruby-ssl
+ dev-ruby/hocon"
+
+ruby_add_bdepend "
+ doc? ( dev-ruby/yard )
+ test? (
+ dev-ruby/mocha
+ dev-ruby/rack
+ dev-ruby/rspec-its
+ )"
+# this should go in the above lists, but isn't because of test deps not being keyworded
+# dev-ruby/rspec-collection_matchers
+
+RDEPEND+=" ${RDEPEND}
+ rrdtool? ( >=net-analyzer/rrdtool-1.2.23[ruby] )
+ selinux? (
+ sys-libs/libselinux[ruby]
+ sec-policy/selinux-puppet
+ )
+ vim-syntax? ( >=app-vim/puppet-syntax-3.0.1 )
+ >=app-portage/eix-0.18.0
+ acct-user/puppet
+ acct-group/puppet"
+PDEPEND="emacs? ( >=app-emacs/puppet-mode-0.3-r1 )"
+
+all_ruby_prepare() {
+ # Avoid spec that require unpackaged json-schema.
+ rm spec/lib/matchers/json.rb $( grep -Rl matchers/json spec) || die
+
+ # fix systemd path
+ eapply -p0 "${FILESDIR}/puppet-systemd.patch"
+
+ # Avoid specs that can only run in the puppet.git repository. This
+ # should be narrowed down to the specific specs.
+ rm spec/integration/parser/compiler_spec.rb || die
+
+ # Avoid failing spec that need further investigation.
+ rm spec/unit/module_tool/metadata_spec.rb || die
+}
+
+each_ruby_install() {
+ each_fakegem_install
+# dosym "/usr/$(get_libdir)/ruby/gems/$(ruby_get_version)/gems/${P}" "/usr/$(get_libdir)/ruby/gems/$(ruby_get_version)/gems/${PN}"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ # systemd stuffs
+ insinto /usr/lib/systemd/system
+ doins "${WORKDIR}/all/${P}/ext/systemd/puppet.service"
+
+ # tmpfiles stuff
+ insinto /usr/lib/tmpfiles.d
+ newins "${FILESDIR}/tmpfiles.d" "puppet.conf"
+
+ # openrc init stuff
+ newinitd "${FILESDIR}"/puppet.init-4.x puppet
+
+ keepdir /etc/puppetlabs/puppet/ssl
+
+ keepdir /var/lib/puppet/facts
+ keepdir /var/lib/puppet/files
+ fowners -R puppet:puppet /var/lib/puppet
+
+ fperms 0750 /var/lib/puppet
+
+ fperms 0750 /etc/puppetlabs
+ fperms 0750 /etc/puppetlabs/puppet
+ fperms 0750 /etc/puppetlabs/puppet/ssl
+ fowners -R :puppet /etc/puppetlabs
+ fowners -R :puppet /var/lib/puppet
+
+ if use ldap ; then
+ insinto /etc/openldap/schema
+ doins ext/ldap/puppet.schema
+ fi
+
+ # ext and examples files
+ for f in $(find ext examples -type f) ; do
+ docinto "$(dirname ${f})"
+ dodoc "${f}"
+ done
+}
+
+pkg_postinst() {
+ elog
+ elog "Please, *don't* include the --ask option in EMERGE_EXTRA_OPTS as this could"
+ elog "cause puppet to hang while installing packages."
+ elog
+ elog "Portage Puppet module with Gentoo-specific resources:"
+ elog "http://forge.puppetlabs.com/gentoo/portage"
+ elog
+ elog "If updating from puppet 5 to 6, keep in mind that webrick (server/master)"
+ elog "suppert was removed for >=6.x, please migrate to puppetserver if you have"
+ elog "not already done so."
+ elog
+}