summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-27 04:37:28 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-27 05:54:37 +0200
commitd36d07c3d0e3aad78ab21e958b6d5d822e35ae40 (patch)
treead748d30a89963b71160d4c013cb041d952f7204 /app-admin
parentdev-python/boto3: Bump to 1.26.161 (diff)
downloadgentoo-d36d07c3d0e3aad78ab21e958b6d5d822e35ae40.tar.gz
gentoo-d36d07c3d0e3aad78ab21e958b6d5d822e35ae40.tar.bz2
gentoo-d36d07c3d0e3aad78ab21e958b6d5d822e35ae40.zip
app-admin/awscli: Bump to 1.27.161
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.27.161.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 4e2ca338bac9..5d8573e13a09 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -10,3 +10,4 @@ DIST aws-cli-1.27.157.gh.tar.gz 2437939 BLAKE2B 628de17b0f0203e48cdecc76a1ca0cdb
DIST aws-cli-1.27.158.gh.tar.gz 2438757 BLAKE2B 303e39d1d30f6593af1a9cb263f11b74e1d7b120a9c3c438c4b4278ff945758130179df282ade40893aea1805758ff3baa29ef7009c08a2dbc2ddf28eb278650 SHA512 04292c37e7b7338cb0103aa165d0c09f67a408711a856758dc999b976cfe6b15e50d0a57fb8ddd7ddd3f697e6b85f84a3565d993d7cb6497fc0ebd74b31e3b45
DIST aws-cli-1.27.159.gh.tar.gz 2438603 BLAKE2B 24e73c92282b8c5b9858541321ef70d22b15f726dd16a638115ea7a6af6886fc9671668954329a04c4b82befb2959ca7c1316e5ce1428b3fa62f6be514c18e74 SHA512 2f3f17bf629ba4d760eae62018b6e7117a23a950cccf3a68806794fefca0d47e92b960f209855eb47391cf93153ffe0f951f7147f99245c7110d0c7cbd7d91f7
DIST aws-cli-1.27.160.gh.tar.gz 2438945 BLAKE2B d475ebaf4d05fe52318e81d5a29f668d5c6dd14d4abc597bdd2b522335cbf7a6e2a2780ea1493350ea63a3acc25c4fe37a1e1ab3a07ca4c452ea0ca427db343c SHA512 2fd236e32860ba270b385b95453eb50cc99a5e2004ccf2f19f9c265c90044df2d3e334d164560c33d26039ac497b783869768b43d2728e5f4e1c3189d714e142
+DIST aws-cli-1.27.161.gh.tar.gz 2439433 BLAKE2B eaafb0a7429c3e8e63be6e810a9e79fa607c4fd3773a5a96acc5e7400df080a89a59ad5c880abec22c4a6be1c513945ff71c1656e7266cd010af7a098aad14e1 SHA512 b736bd404a703833e86c17e57eaded3cad4bff61898f1d9ac66d9fe0df1131f08c73abb37f87f977c55cee8a3cbffc1dd8b7467ee01f4a2709abf656a86a1e89
diff --git a/app-admin/awscli/awscli-1.27.161.ebuild b/app-admin/awscli/awscli-1.27.161.ebuild
new file mode 100644
index 000000000000..62c19f3a63fb
--- /dev/null
+++ b/app-admin/awscli/awscli-1.27.161.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/functional/eks/test_kubeconfig.py::TestKubeconfigLoader::test_load_simple
+ tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_env_only
+ tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_existing
+ tests/unit/customizations/eks/test_kubeconfig.py::TestKubeconfigValidator::test_valid
+ )
+
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)" --forked
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}