summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-09-06 23:21:52 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-09-07 10:23:49 +0200
commite6697d6b974f77fc0076bc462ee370bb3b335451 (patch)
tree1a83c1ac8dbcea1300106b501c7101f85acf67aa /app-admin
parentnet-dns/dnscrypt-proxy: add 2.0.17 pre-release (diff)
downloadgentoo-e6697d6b974f77fc0076bc462ee370bb3b335451.tar.gz
gentoo-e6697d6b974f77fc0076bc462ee370bb3b335451.tar.bz2
gentoo-e6697d6b974f77fc0076bc462ee370bb3b335451.zip
app-admin/cdist: version bump.
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/cdist/Manifest1
-rw-r--r--app-admin/cdist/cdist-4.10.1.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/app-admin/cdist/Manifest b/app-admin/cdist/Manifest
index e40c94d51ccb..a12f2034ef44 100644
--- a/app-admin/cdist/Manifest
+++ b/app-admin/cdist/Manifest
@@ -1,2 +1,3 @@
+DIST cdist-4.10.1.tar.gz 660264 BLAKE2B 7e4c9bc1e4a750865880aa442ed6c8a125b80d35ba2fbb49f6549c25764a8aea62defd95d3e32782a7290729f45e6a9a658fd2d6abaae15b3686c3ed312dce37 SHA512 d5852ddceb869a5d70c77d65b9288a780cc62794472fff1537a22d3e890b87ffc15181bc425f0bbbf43952eba12aa99046f482cf97f4afa6ca747d2cb55bea98
DIST cdist-4.6.1.tar.gz 454461 BLAKE2B 5cf5ba376b981feb6d740f53b4c4cdf51a8f0b4d4422db2c2c7312dd1288e006bfcae7c3459707e361536002a2a6b49bb8ef836783fac8167834978fb5737683 SHA512 f0c3759d00221fbd36d7662de6ccc57fc0070b8aee6a0d80e6bab6f41215c537a1cf1a6ec9fdebf81c45ad8126b8e730a14be8f1286d5baf5f4a5672611e31dc
DIST cdist-4.7.3.tar.gz 497537 BLAKE2B e743e49291d6b212810911607ac149a54e6c8423841c4149f620d2127bbeb2fdce7d5ceff76572f1599a3a3326944066ba336f93f25de50d98ad972188562709 SHA512 9b69e257c816d515e4d94bc73d26ca1cfb2343fc4fc8298aadfbb82417aa28c9759831c304b90d6427e275988442cd19681e455c98757c87426d0435dd90ae41
diff --git a/app-admin/cdist/cdist-4.10.1.ebuild b/app-admin/cdist/cdist-4.10.1.ebuild
new file mode 100644
index 000000000000..52491eaacc40
--- /dev/null
+++ b/app-admin/cdist/cdist-4.10.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A usable configuration management system"
+HOMEPAGE="https://www.nico.schottelius.org/software/cdist/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+python_install_all() {
+ use doc && HTML_DOCS=( docs/dist/html/*.html docs/dist/html/man{1,7}/*.html )
+ distutils-r1_python_install_all
+
+ doman docs/dist/man/man1/*.1 docs/dist/man/man7/*.7
+}