summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2021-11-08 13:56:45 +0100
committerAgostino Sarubbo <ago@gentoo.org>2021-11-08 13:56:45 +0100
commiteb0dfd8d2b32d31e9b3a00654fad461d2d419831 (patch)
tree129dd5386433f878c9f0378cb7e7fa8d6fa88930 /app-admin
parentdev-libs/half: half-precision floating-point library. (diff)
downloadgentoo-eb0dfd8d2b32d31e9b3a00654fad461d2d419831.tar.gz
gentoo-eb0dfd8d2b32d31e9b3a00654fad461d2d419831.tar.bz2
gentoo-eb0dfd8d2b32d31e9b3a00654fad461d2d419831.zip
app-admin/hcloud: version bump to 1.29.0
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/hcloud/Manifest1
-rw-r--r--app-admin/hcloud/hcloud-1.29.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/app-admin/hcloud/Manifest b/app-admin/hcloud/Manifest
index c26f53d1ca8d..e7fee64aa623 100644
--- a/app-admin/hcloud/Manifest
+++ b/app-admin/hcloud/Manifest
@@ -1 +1,2 @@
DIST hcloud-1.28.1.tar.xz 1498600 BLAKE2B 9489f1c119d941999a3dd6794545704e9946850bb4fef4799a1560fbc50fecc928a93437c3d7221cedbf5435d23d500bec5ffbe4b16dd754ebe934b0e7f57aeb SHA512 146fb1673fcf0939c20ed0259bc69bf05e8971fe20a25cf560023ced4631ac6d470dd270e92c44e26a1131f6cffa3ce339d4524401318764540d8a06ac3cc11f
+DIST hcloud-1.29.0.tar.xz 1499276 BLAKE2B 3ec9973fc3ecaf5ec476b2d165fc1663f4d6cd2c00c4c87efc72f3946d1d6028f9a2d20f80020203b1f8f2aa94512a1d02e05b54e9422f5b84826eb8bb552490 SHA512 b5b1e20785fc8a06954a753dbd6c5d91b2b557d0e64cb044ab55cbfb11f0fd7d0a2eb625a51e1216af86cad6f772a206d3b0ef443f256649dba38d199614d41d
diff --git a/app-admin/hcloud/hcloud-1.29.0.ebuild b/app-admin/hcloud/hcloud-1.29.0.ebuild
new file mode 100644
index 000000000000..77d54006fe99
--- /dev/null
+++ b/app-admin/hcloud/hcloud-1.29.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A command-line interface for Hetzner Cloud"
+HOMEPAGE="https://github.com/hetznercloud/cli"
+SRC_URI="https://dev.gentoo.org/~ago/distfiles/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE=""
+DEPEND="dev-lang/go:="
+RESTRICT="strip"
+QA_FLAGS_IGNORED=".*"
+
+src_compile() {
+ go build -mod vendor -o ${PN} -ldflags "-w -X github.com/hetznercloud/cli/cli.Version=${PV}-gentoo" ./cmd/${PN} || die "build failed"
+}
+
+src_test() {
+ # For upstream a simple test is run 'hcloud version'
+ ./hcloud version
+ if [[ $? -ne 0 ]]
+ then
+ die "Test failed"
+ fi
+}
+
+src_install() {
+ dobin ${PN}
+}