summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-04 03:48:35 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-04 03:48:35 +0200
commitf1f263ae0bccbd5dd609c6f8ed940022155e103d (patch)
tree5875cee054e94e2af3f4e20e0d8e097b53b81424 /app-admin
parentdev-python/boto3: Bump to 1.27.0 (diff)
downloadgentoo-f1f263ae0bccbd5dd609c6f8ed940022155e103d.tar.gz
gentoo-f1f263ae0bccbd5dd609c6f8ed940022155e103d.tar.bz2
gentoo-f1f263ae0bccbd5dd609c6f8ed940022155e103d.zip
app-admin/awscli: Bump to 1.28.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.28.0.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 6a6d95479de2..7f9e128dff8d 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -4,3 +4,4 @@ DIST aws-cli-1.27.162.gh.tar.gz 2440126 BLAKE2B dd2abeb835e52bdd3c164bc475fde491
DIST aws-cli-1.27.163.gh.tar.gz 2440844 BLAKE2B 2e89c9c5ef595f299314fa7018eb23e55f4af624789371f51c245c574c61e7d274f56356056ecc1607500f201127666358fc750521ed3342c3e2abea60f65220 SHA512 475f8c3b8e975e5c9bbd2b9f4c1ce0f0e26d4c3f063edb5427a4fb89b11eb2b37e7e468a191be0debf03781e7716b08ec4a9970baddbffc0d7110af6fb4b80aa
DIST aws-cli-1.27.164.gh.tar.gz 2441955 BLAKE2B 51a4e88eed1196baa92110c6ad671534404da05825f7dbaa8f97aa9340fb7bf6494441f02b69d354045f8abf8f3ce71605235e79bb7bbee2ac38813469b08fd0 SHA512 fb0ead9338bda6b7e64dfe86ce132f72c39df3b6e47db181b2813730d2df11938f28becc007f8a675616754ba204083f7f17a6516bf47dcd13f0f795ce4aa925
DIST aws-cli-1.27.165.gh.tar.gz 2445911 BLAKE2B 72496a0b5695c78631349b7b6efb4aee7a3681c3683cd567fe904d02d5198366e79146bfd2db373738936c88e2cd97b2e858e45de1e44ec863f386aef865367d SHA512 cde5e9bf6aa2783a0b8c90ae78686bb6a8d5e625e15826f735bcf6e138b112a56df25f4429192ed44fb7cc58e9ea736f7e7fd8ffe8ad0092ead763e3f801a7a0
+DIST aws-cli-1.28.0.gh.tar.gz 2445988 BLAKE2B 5c56f908d72cdc10c3e256dd1cc279a202d302cfee0ce860dbefec33ec78aea7afcae37aa699bab6a8644503c9ff0648d0efd60a168f180847f4392e3440658f SHA512 cc3239b7609de0dfa0bb15fea044a9f51151e6c1873c07dc1f0893b0418721eef9b28d1757bc59f7d9e603b865eec406fbe3865e0f31de2f58142ca6768bd1a3
diff --git a/app-admin/awscli/awscli-1.28.0.ebuild b/app-admin/awscli/awscli-1.28.0.ebuild
new file mode 100644
index 000000000000..62c19f3a63fb
--- /dev/null
+++ b/app-admin/awscli/awscli-1.28.0.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/functional/eks/test_kubeconfig.py::TestKubeconfigLoader::test_load_simple
+ tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_env_only
+ tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_existing
+ tests/unit/customizations/eks/test_kubeconfig.py::TestKubeconfigValidator::test_valid
+ )
+
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)" --forked
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}