summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-23 06:48:21 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-23 07:35:43 +0200
commitf7befacdb1af996960f24e6d52508ddd266b0483 (patch)
tree7e97bb7b4ae7508363b5fe96453f3db0b4003d4f /app-admin
parentdev-python/boto3: Bump to 1.26.159 (diff)
downloadgentoo-f7befacdb1af996960f24e6d52508ddd266b0483.tar.gz
gentoo-f7befacdb1af996960f24e6d52508ddd266b0483.tar.bz2
gentoo-f7befacdb1af996960f24e6d52508ddd266b0483.zip
app-admin/awscli: Bump to 1.27.159
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.27.159.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index eb1e3e7579b5..013d291d2148 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -8,3 +8,4 @@ DIST aws-cli-1.27.155.gh.tar.gz 2437165 BLAKE2B 59a757940ec6999567f1744d147078ac
DIST aws-cli-1.27.156.gh.tar.gz 2437549 BLAKE2B dd98b3605986fc9d832604bea3dc1d22daf2e5ae08637367023337dca349706edf10ad7702d914600ec02c7d137d29a9eb13d95ddaf99e402507fd45e9bdb0eb SHA512 c932a11a1ed36219f5dc22a046fd9e7e8ca8229d266fe45c626ee2ff9e6608029a733d5b335e90b6d4a38fffa04a06d1a1f84bf0b827c65fb9edf5d2f0ff8b57
DIST aws-cli-1.27.157.gh.tar.gz 2437939 BLAKE2B 628de17b0f0203e48cdecc76a1ca0cdbf111224f652f650d5501677027c486faf2ea06d9c95321b6586d50f9e042698b1ba11696f3a5ab2e0734aa004db9e9cc SHA512 87f4c790b0c49d353473fc577d6bd2568a2ecd6359a9e53165a2e14ce112113286b9f2bd34be83db219cd72c59e5dbc8098aef3e8fa98297da44f21865dffd9e
DIST aws-cli-1.27.158.gh.tar.gz 2438757 BLAKE2B 303e39d1d30f6593af1a9cb263f11b74e1d7b120a9c3c438c4b4278ff945758130179df282ade40893aea1805758ff3baa29ef7009c08a2dbc2ddf28eb278650 SHA512 04292c37e7b7338cb0103aa165d0c09f67a408711a856758dc999b976cfe6b15e50d0a57fb8ddd7ddd3f697e6b85f84a3565d993d7cb6497fc0ebd74b31e3b45
+DIST aws-cli-1.27.159.gh.tar.gz 2438603 BLAKE2B 24e73c92282b8c5b9858541321ef70d22b15f726dd16a638115ea7a6af6886fc9671668954329a04c4b82befb2959ca7c1316e5ce1428b3fa62f6be514c18e74 SHA512 2f3f17bf629ba4d760eae62018b6e7117a23a950cccf3a68806794fefca0d47e92b960f209855eb47391cf93153ffe0f951f7147f99245c7110d0c7cbd7d91f7
diff --git a/app-admin/awscli/awscli-1.27.159.ebuild b/app-admin/awscli/awscli-1.27.159.ebuild
new file mode 100644
index 000000000000..62c19f3a63fb
--- /dev/null
+++ b/app-admin/awscli/awscli-1.27.159.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/functional/eks/test_kubeconfig.py::TestKubeconfigLoader::test_load_simple
+ tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_env_only
+ tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_existing
+ tests/unit/customizations/eks/test_kubeconfig.py::TestKubeconfigValidator::test_valid
+ )
+
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)" --forked
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}