summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-05 20:21:55 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-06 15:46:38 +0100
commita6b0460f056d5520c2f3a344ce6c5525bc678b8a (patch)
treeac939dad3f0704538a2a4db374d73f3cb4cf8421 /app-alternatives
parentsys-cluster/openmpi: Stabilize 4.1.4 x86, #884589 (diff)
downloadgentoo-a6b0460f056d5520c2f3a344ce6c5525bc678b8a.tar.gz
gentoo-a6b0460f056d5520c2f3a344ce6c5525bc678b8a.tar.bz2
gentoo-a6b0460f056d5520c2f3a344ce6c5525bc678b8a.zip
app-alternatives/bc: Use app-alternatives.eclass
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-alternatives')
-rw-r--r--app-alternatives/bc/bc-0.ebuild37
1 files changed, 14 insertions, 23 deletions
diff --git a/app-alternatives/bc/bc-0.ebuild b/app-alternatives/bc/bc-0.ebuild
index 1befe0bb8fa5..95732aa6d6b7 100644
--- a/app-alternatives/bc/bc-0.ebuild
+++ b/app-alternatives/bc/bc-0.ebuild
@@ -3,35 +3,26 @@
EAPI=8
-DESCRIPTION="bc symlink"
-HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Base/Alternatives"
-SRC_URI=""
-S=${WORKDIR}
+ALTERNATIVES=(
+ "gnu:>=sys-devel/bc-1.07.1-r6"
+ gh:sci-calculators/bc-gh
+)
+
+inherit app-alternatives
-LICENSE="CC0-1.0"
-SLOT="0"
+DESCRIPTION="bc symlink"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="+gnu gh"
-REQUIRED_USE="^^ ( gnu gh )"
RDEPEND="
- gnu? ( >=sys-devel/bc-1.07.1-r6 )
- gh? ( sci-calculators/bc-gh )
!<sys-devel/bc-1.07.1-r6
"
src_install() {
- if use gnu; then
- dosym bc-reference /usr/bin/bc
- dosym dc-reference /usr/bin/dc
- newman - bc.1 <<<".so bc-reference.1"
- newman - dc.1 <<<".so dc-reference.1"
- elif use gh; then
- dosym bc-gh /usr/bin/bc
- dosym dc-gh /usr/bin/dc
- newman - bc.1 <<<".so bc-gh.1"
- newman - dc.1 <<<".so dc-gh.1"
- else
- die "Invalid USE flag combination (broken REQUIRED_USE?)"
- fi
+ local suffix=$(get_alternative)
+ [[ ${suffix} == gnu ]] && suffix=reference
+
+ dosym "bc-${suffix}" /usr/bin/bc
+ dosym "dc-${suffix}" /usr/bin/dc
+ newman - bc.1 <<<".so bc-${suffix}.1"
+ newman - dc.1 <<<".so dc-${suffix}.1"
}