summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-12-02 06:18:20 +0000
committerSam James <sam@gentoo.org>2022-12-02 21:09:30 +0000
commitd05bcafc980182a12a9c8a86dd23fdc9bc7885d5 (patch)
tree7feae990adbe0d2406e4d5559c45e3b85ba60018 /app-alternatives
parentapp-alternatives/lex: New package to control lex symlinks (diff)
downloadgentoo-d05bcafc980182a12a9c8a86dd23fdc9bc7885d5.tar.gz
gentoo-d05bcafc980182a12a9c8a86dd23fdc9bc7885d5.tar.bz2
gentoo-d05bcafc980182a12a9c8a86dd23fdc9bc7885d5.zip
app-alternatives/lex: install env.d file for LEX
Without this, autotools will end up probing for flex even when it's not specifically needed. If packages really do need flex, it's not expected that ebuild maintainers will fix the underlying problem, but the ebuilds should then set LEX=flex and BDEPEND on it. If upstream is active, they should consider reporting the problem to them though. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-alternatives')
-rw-r--r--app-alternatives/lex/lex-0.ebuild8
1 files changed, 8 insertions, 0 deletions
diff --git a/app-alternatives/lex/lex-0.ebuild b/app-alternatives/lex/lex-0.ebuild
index 260f9d0ba5f2..88a00b0f7b8f 100644
--- a/app-alternatives/lex/lex-0.ebuild
+++ b/app-alternatives/lex/lex-0.ebuild
@@ -24,9 +24,17 @@ src_install() {
if use reflex; then
dosym reflex /bin/lex
newman - lex.1 <<<".so reflex.1"
+
+ newenvd - 90lex <<-EOF
+ LEX=reflex
+ EOF
elif use flex; then
dosym flex /bin/lex
newman - lex.1 <<<".so flex.1"
+
+ newenvd - 90lex <<-EOF
+ LEX=flex
+ EOF
else
die "Invalid USE flag combination (broken REQUIRED_USE?)"
fi