summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRalph Seichter <github@seichter.de>2021-02-12 05:19:19 +0100
committerSam James <sam@gentoo.org>2021-02-12 15:10:12 +0000
commit11a23a070a9d270c6dc069e588a9504666982bdf (patch)
treed56b94f2788dbf35a9e680b02989471c63d98fe5 /app-antivirus/fangfrisch
parentdev-lisp/sbcl: remove unused patch (diff)
downloadgentoo-11a23a070a9d270c6dc069e588a9504666982bdf.tar.gz
gentoo-11a23a070a9d270c6dc069e588a9504666982bdf.tar.bz2
gentoo-11a23a070a9d270c6dc069e588a9504666982bdf.zip
app-antivirus/fangfrisch: Bump to version 1.4.0
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Ralph Seichter <gentoo@seichter.de> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-antivirus/fangfrisch')
-rw-r--r--app-antivirus/fangfrisch/Manifest1
-rw-r--r--app-antivirus/fangfrisch/fangfrisch-1.4.0.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/app-antivirus/fangfrisch/Manifest b/app-antivirus/fangfrisch/Manifest
index 324c2f1d531e..a32eea10bfea 100644
--- a/app-antivirus/fangfrisch/Manifest
+++ b/app-antivirus/fangfrisch/Manifest
@@ -1,2 +1,3 @@
DIST fangfrisch-1.2.0.tar.gz 113088 BLAKE2B 9fb5f4b838e6337128c9e988f5749864cadacb74c9e3006f29cf8b976592af88c00ff5359cd70e4d6901e24cfc01b061861b7b1a563a82d66b2d71c970627c26 SHA512 6f6c0cfc4d840f99186c83e6109c6234ff5bfb44e19bcd3309056347392e46da56e17106259508864b05397d39ea92500ab6863b50d55efc790d88b59f88ee3b
DIST fangfrisch-1.3.0.tar.gz 114361 BLAKE2B eca124f02f814d2915c4dbba45b6e4dc620e250730a32b34d3f5f5eaa33945e697d2d887f29251f1f8a3b1813476a54092091235a786e84695a3bc1cadebad28 SHA512 9c138737908a02efa5c9b4c6792a31e2a4908f8ab27e8cecab78612f812ab151afef75a405f47695779a949485aa88a3a5830efd02344ec334e6f37425cffe49
+DIST fangfrisch-1.4.0.tar.gz 115303 BLAKE2B 6dea9305ad22e8beff0fc04219d24da995c36e0838e1be8b98d12b11db1f68d7ca4f6084d15270c09e8a4b8d94a7bdfe1b9bb336abef1767b1ded2d1751fa22b SHA512 5fca7b7e8d24daadfb450851c70391fce94943a718bbed4fc76efe08a730cce313d92e7d9a6a8324a0b0039871f8c77f1fcd3744c569826cc0d2e7a7fd4e9b32
diff --git a/app-antivirus/fangfrisch/fangfrisch-1.4.0.ebuild b/app-antivirus/fangfrisch/fangfrisch-1.4.0.ebuild
new file mode 100644
index 000000000000..3c01329a331e
--- /dev/null
+++ b/app-antivirus/fangfrisch/fangfrisch-1.4.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1 readme.gentoo-r1
+
+DESCRIPTION="Update and verify unofficial Clam Anti-Virus signatures"
+HOMEPAGE="https://github.com/rseichter/fangfrisch https://pypi.org/project/fangfrisch/"
+SRC_URI="https://github.com/rseichter/fangfrisch/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+MY_CONF="/etc/${PN}.conf"
+MY_DBDIR="/var/lib/${PN}"
+DISABLE_AUTOFORMATTING=1
+DOC_CONTENTS="See https://rseichter.github.io/fangfrisch/ for the official
+documentation.
+
+### Fresh installations:
+
+Modify ${MY_CONF} according to your preferences.
+Assuming you place the database into ${MY_DBDIR}
+(recommended), execute the following commands in a root shell:
+
+mkdir -m 0770 ${MY_DBDIR}
+chgrp clamav ${MY_DBDIR}
+sudo -u clamav -- fangfrisch -c ${MY_CONF} initdb
+
+You can now enable /etc/cron.d/${PN} for periodic updates.
+
+### Alternative: Updating from release 1.0.1:
+
+Either create a fresh database or manually delete all existing
+database tables, then run the initdb command as shown above."
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=dev-python/requests-2.22.0[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-1.3.11[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+python_prepare_all() {
+ sed -i -e '/SQLAlchemy/d' setup.py || die
+ # Due to the nature of Fangfrisch, most tests require network
+ # connectivity. Upstream CI reports show that the tests are
+ # successful, so instead of a pick-and-choose approach, the
+ # complete tests directory is removed in this ebuild.
+ if [ -d tests ]; then
+ rm -r tests || die
+ fi
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ insinto /etc
+ doins "${FILESDIR}/${PN}.conf"
+ insinto /etc/cron.d
+ newins "${FILESDIR}/${PN}.cron" ${PN}
+ distutils-r1_python_install_all
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ FORCE_PRINT_ELOG=1 readme.gentoo_print_elog
+}