summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-03 08:37:04 +0100
committerSam James <sam@gentoo.org>2023-05-03 08:37:36 +0100
commit1934fabc48a8cbca6ce416498139b9a0e3537145 (patch)
treef135ad974894f76ca9ee66480898b508dbcfa2a1 /app-antivirus
parentnet-vpn/protonvpn-cli: add github upstream metadata (diff)
downloadgentoo-1934fabc48a8cbca6ce416498139b9a0e3537145.tar.gz
gentoo-1934fabc48a8cbca6ce416498139b9a0e3537145.tar.bz2
gentoo-1934fabc48a8cbca6ce416498139b9a0e3537145.zip
app-antivirus/fangfrisch: add 1.6.1
Closes: https://bugs.gentoo.org/905635 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-antivirus')
-rw-r--r--app-antivirus/fangfrisch/Manifest1
-rw-r--r--app-antivirus/fangfrisch/fangfrisch-1.6.1.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/app-antivirus/fangfrisch/Manifest b/app-antivirus/fangfrisch/Manifest
index feb73e3f2b62..704246031a23 100644
--- a/app-antivirus/fangfrisch/Manifest
+++ b/app-antivirus/fangfrisch/Manifest
@@ -1 +1,2 @@
DIST fangfrisch-1.5.0.tar.gz 115352 BLAKE2B 2c8ed5484255e336a960285f4eb13180691b2e4da0260f6ed2d1308575f5104cb79602c6c5bda93d2889dfdf24817748560376c9e13e6071810d9246b6120724 SHA512 cb15933d0cacc0912e7f1f103a213e277905a40ff4f7fe818c60d28c2ce92377aaea77b413f55f0ae8701e41eb35bcb2c3b3e04c624a6a57533ca621f93e00f5
+DIST fangfrisch-1.6.1.gh.tar.gz 113497 BLAKE2B a37b5b29b31a1d0166112b8939e691acc1721a91bda9e364a90c0c8d4ea7b7d3e1a24b8849c9ef4f0632996ed7bbdfc7985ab04c44c8ca4d57df21294867fd32 SHA512 a16b39b6520d80f69c561bc2d56fef28acaca35a9da214be920cdd907f76d3d6674ed4aa1290ad11a9364ede11472594d7e331ecd21924fe23e005ef9501d4ac
diff --git a/app-antivirus/fangfrisch/fangfrisch-1.6.1.ebuild b/app-antivirus/fangfrisch/fangfrisch-1.6.1.ebuild
new file mode 100644
index 000000000000..f7a0fa269684
--- /dev/null
+++ b/app-antivirus/fangfrisch/fangfrisch-1.6.1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 readme.gentoo-r1 systemd
+
+DESCRIPTION="Update and verify unofficial Clam Anti-Virus signatures"
+HOMEPAGE="https://github.com/rseichter/fangfrisch https://pypi.org/project/fangfrisch/"
+SRC_URI="https://github.com/rseichter/fangfrisch/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+MY_CONF="/etc/${PN}.conf"
+MY_DBDIR="/var/lib/${PN}"
+DISABLE_AUTOFORMATTING=1
+DOC_CONTENTS="See https://rseichter.github.io/fangfrisch/ for the official
+documentation.
+
+### Fresh installations:
+
+Modify ${MY_CONF} according to your preferences.
+Assuming you place the database into ${MY_DBDIR}
+(recommended), execute the following commands in a root shell:
+
+mkdir -m 0770 ${MY_DBDIR}
+chgrp clamav ${MY_DBDIR}
+sudo -u clamav -- fangfrisch -c ${MY_CONF} initdb
+
+You can now enable /etc/cron.d/${PN} for periodic updates.
+
+### Alternative: Updating from release 1.0.1:
+
+Either create a fresh database or manually delete all existing
+database tables, then run the initdb command as shown above."
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# Due to the nature of Fangfrisch, most tests require network
+# connectivity and/or access keys to download signature files.
+PROPERTIES="test_network"
+RESTRICT="test"
+
+DEPEND="
+ >=dev-python/requests-2.22.0[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-1.4.0[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+
+distutils_enable_tests unittest
+
+python_prepare_all() {
+ sed -i -e '/SQLAlchemy/d' setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ insinto /etc
+ doins "${FILESDIR}/${PN}.conf"
+
+ insinto /etc/cron.d
+ newins "${FILESDIR}/${PN}.cron" ${PN}
+
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ systemd_dounit "${FILESDIR}/${PN}.timer"
+
+ distutils-r1_python_install_all
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ FORCE_PRINT_ELOG=1 readme.gentoo_print_elog
+}