summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-31 00:13:08 +0100
committerSam James <sam@gentoo.org>2021-07-31 00:29:44 +0100
commitaa01641a281298fed7ae12579fa2cb2b79181797 (patch)
tree07733fd83eb034b853dd8be21cc7432c80bad273 /app-antivirus
parentapp-admin/puppetdb: [QA] call tmpfiles_process in pkg_postinst (diff)
downloadgentoo-aa01641a281298fed7ae12579fa2cb2b79181797.tar.gz
gentoo-aa01641a281298fed7ae12579fa2cb2b79181797.tar.bz2
gentoo-aa01641a281298fed7ae12579fa2cb2b79181797.zip
app-antivirus/clamav: [QA] call tmpfiles_process in pkg_postinst
This is needed to actually apply the tmpfiles configuration we've installed in the ebuild. See tmpfiles.eclass documentation. Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-antivirus')
-rw-r--r--app-antivirus/clamav/clamav-0.103.2.ebuild6
-rw-r--r--app-antivirus/clamav/clamav-0.103.3-r1.ebuild6
-rw-r--r--app-antivirus/clamav/clamav-0.103.3.ebuild6
3 files changed, 18 insertions, 0 deletions
diff --git a/app-antivirus/clamav/clamav-0.103.2.ebuild b/app-antivirus/clamav/clamav-0.103.2.ebuild
index 2a26103218b3..62e7fa4618a6 100644
--- a/app-antivirus/clamav/clamav-0.103.2.ebuild
+++ b/app-antivirus/clamav/clamav-0.103.2.ebuild
@@ -215,6 +215,12 @@ src_test() {
}
pkg_postinst() {
+ if ! use libclamav-only ; then
+ if use systemd ; then
+ tmpfiles_process clamav.conf
+ fi
+ fi
+
if use milter ; then
elog "For simple instructions how to setup the clamav-milter read the"
elog "clamav-milter.README.gentoo in /usr/share/doc/${PF}"
diff --git a/app-antivirus/clamav/clamav-0.103.3-r1.ebuild b/app-antivirus/clamav/clamav-0.103.3-r1.ebuild
index 95b7377cd083..1eb403b44251 100644
--- a/app-antivirus/clamav/clamav-0.103.3-r1.ebuild
+++ b/app-antivirus/clamav/clamav-0.103.3-r1.ebuild
@@ -215,6 +215,12 @@ src_test() {
}
pkg_postinst() {
+ if ! use libclamav-only ; then
+ if use systemd ; then
+ tmpfiles_process clamav.conf
+ fi
+ fi
+
if use milter ; then
elog "For simple instructions how to setup the clamav-milter read the"
elog "clamav-milter.README.gentoo in /usr/share/doc/${PF}"
diff --git a/app-antivirus/clamav/clamav-0.103.3.ebuild b/app-antivirus/clamav/clamav-0.103.3.ebuild
index 2e786a0b7c00..533e4dc2d083 100644
--- a/app-antivirus/clamav/clamav-0.103.3.ebuild
+++ b/app-antivirus/clamav/clamav-0.103.3.ebuild
@@ -215,6 +215,12 @@ src_test() {
}
pkg_postinst() {
+ if ! use libclamav-only ; then
+ if use systemd ; then
+ tmpfiles_process clamav.conf
+ fi
+ fi
+
if use milter ; then
elog "For simple instructions how to setup the clamav-milter read the"
elog "clamav-milter.README.gentoo in /usr/share/doc/${PF}"