summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRalph Seichter <github@seichter.de>2021-10-12 17:23:19 +0200
committerSam James <sam@gentoo.org>2021-10-20 03:06:28 +0000
commite2deecc834b581ff71007fdfbc67a43a4eba0290 (patch)
treeb42df805584dae1405ec889c65551d6948892325 /app-antivirus
parentdev-util/kbuild: use -b switch for has_version (diff)
downloadgentoo-e2deecc834b581ff71007fdfbc67a43a4eba0290.tar.gz
gentoo-e2deecc834b581ff71007fdfbc67a43a4eba0290.tar.bz2
gentoo-e2deecc834b581ff71007fdfbc67a43a4eba0290.zip
app-antivirus/fangfrisch: Bump to version 1.5.0
Upstream release 1.5.0. This ebuild resolves an issue regarding the use of DISTUTILS_USE_SETUPTOOLS. Closes: https://bugs.gentoo.org/813303 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Ralph Seichter <gentoo@seichter.de> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-antivirus')
-rw-r--r--app-antivirus/fangfrisch/Manifest1
-rw-r--r--app-antivirus/fangfrisch/fangfrisch-1.5.0.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/app-antivirus/fangfrisch/Manifest b/app-antivirus/fangfrisch/Manifest
index b37f9e780eac..b2906046058d 100644
--- a/app-antivirus/fangfrisch/Manifest
+++ b/app-antivirus/fangfrisch/Manifest
@@ -1 +1,2 @@
DIST fangfrisch-1.4.0.tar.gz 115303 BLAKE2B 6dea9305ad22e8beff0fc04219d24da995c36e0838e1be8b98d12b11db1f68d7ca4f6084d15270c09e8a4b8d94a7bdfe1b9bb336abef1767b1ded2d1751fa22b SHA512 5fca7b7e8d24daadfb450851c70391fce94943a718bbed4fc76efe08a730cce313d92e7d9a6a8324a0b0039871f8c77f1fcd3744c569826cc0d2e7a7fd4e9b32
+DIST fangfrisch-1.5.0.tar.gz 115352 BLAKE2B 2c8ed5484255e336a960285f4eb13180691b2e4da0260f6ed2d1308575f5104cb79602c6c5bda93d2889dfdf24817748560376c9e13e6071810d9246b6120724 SHA512 cb15933d0cacc0912e7f1f103a213e277905a40ff4f7fe818c60d28c2ce92377aaea77b413f55f0ae8701e41eb35bcb2c3b3e04c624a6a57533ca621f93e00f5
diff --git a/app-antivirus/fangfrisch/fangfrisch-1.5.0.ebuild b/app-antivirus/fangfrisch/fangfrisch-1.5.0.ebuild
new file mode 100644
index 000000000000..61ed49126cdf
--- /dev/null
+++ b/app-antivirus/fangfrisch/fangfrisch-1.5.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1 readme.gentoo-r1
+
+DESCRIPTION="Update and verify unofficial Clam Anti-Virus signatures"
+HOMEPAGE="https://github.com/rseichter/fangfrisch https://pypi.org/project/fangfrisch/"
+SRC_URI="https://github.com/rseichter/fangfrisch/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+MY_CONF="/etc/${PN}.conf"
+MY_DBDIR="/var/lib/${PN}"
+DISABLE_AUTOFORMATTING=1
+DOC_CONTENTS="See https://rseichter.github.io/fangfrisch/ for the official
+documentation.
+
+### Fresh installations:
+
+Modify ${MY_CONF} according to your preferences.
+Assuming you place the database into ${MY_DBDIR}
+(recommended), execute the following commands in a root shell:
+
+mkdir -m 0770 ${MY_DBDIR}
+chgrp clamav ${MY_DBDIR}
+sudo -u clamav -- fangfrisch -c ${MY_CONF} initdb
+
+You can now enable /etc/cron.d/${PN} for periodic updates.
+
+### Alternative: Updating from release 1.0.1:
+
+Either create a fresh database or manually delete all existing
+database tables, then run the initdb command as shown above."
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=dev-python/requests-2.22.0[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-1.3.11[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+python_prepare_all() {
+ sed -i -e '/SQLAlchemy/d' setup.py || die
+ # Due to the nature of Fangfrisch, most tests require network
+ # connectivity. Upstream CI reports show that the tests are
+ # successful, so instead of a pick-and-choose approach, the
+ # complete tests directory is removed in this ebuild.
+ if [ -d tests ]; then
+ rm -r tests || die
+ fi
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ insinto /etc
+ doins "${FILESDIR}/${PN}.conf"
+ insinto /etc/cron.d
+ newins "${FILESDIR}/${PN}.cron" ${PN}
+ distutils-r1_python_install_all
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ FORCE_PRINT_ELOG=1 readme.gentoo_print_elog
+}