summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-arch/advancecomp/advancecomp-1.19.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-arch/advancecomp/advancecomp-1.19.ebuild')
-rw-r--r--app-arch/advancecomp/advancecomp-1.19.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/app-arch/advancecomp/advancecomp-1.19.ebuild b/app-arch/advancecomp/advancecomp-1.19.ebuild
new file mode 100644
index 000000000000..a5ea44e1117e
--- /dev/null
+++ b/app-arch/advancecomp/advancecomp-1.19.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Recompress ZIP, PNG and MNG using deflate 7-Zip, considerably improving compression"
+HOMEPAGE="http://advancemame.sourceforge.net/comp-readme.html"
+SRC_URI="mirror://sourceforge/project/advancemame/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3 LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="mng png test"
+
+RDEPEND="app-arch/bzip2
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
+# test? (
+# app-text/tofrodos
+# dev-util/valgrind
+# )"
+
+RESTRICT="test" #282441, #523212
+
+src_configure() {
+ econf --enable-bzip2 \
+ $(use_enable test valgrind)
+}
+
+src_install() {
+ dobin advdef advzip
+
+ if use png; then
+ dobin advpng
+ doman doc/advpng.1
+ fi
+
+ if use mng; then
+ dobin advmng
+ doman doc/advmng.1
+ fi
+
+ dodoc HISTORY AUTHORS README
+ doman doc/advdef.1 doc/advzip.1
+}